Choose style:

Author Topic: (SOLVED) Only boot in recovery mode  (Read 152 times)

0 Members and 1 Guest are viewing this topic.

Offline vawogbemi

  • nOOb
  • *
  • Posts: 2
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
(SOLVED) Only boot in recovery mode
« on: August 28, 2019, 08:06:21 pm »
After I did this tutorial to enable fn keys my laptop stop booting normally and can only boot in recovery mode. Something like this also happened when I enabled my realtek 8723de network controller.


System Info:
Code: [Select]
System:    Host: NichirinBlade Kernel: 4.15.0-58-generic x86_64 bits: 64 gcc: 7.4.0
           Desktop: N/A Distro: Peppermint Ten
Machine:   Device: laptop System: HP product: HP Laptop 15-bw0xx v: Type1ProductConfigId serial: N/A
           Mobo: HP model: 8330 v: 27.26 serial: N/A
           UEFI: Insyde v: F.11 date: 07/05/2017
Battery    BAT1: charge: 17.9 Wh 59.5% condition: 30.0/31.1 Wh (97%)
           model: Hewlett-Packard PABAS0241231 status: Charging
CPU:       Dual core AMD E2-9000e RADEON R2 4 COMPUTE CORES 2C+2G (-MCP-)
           arch: Excavator rev.0 cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 5988
           clock speeds: max: 1500 MHz 1: 1549 MHz 2: 1454 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Stoney [Radeon R2/R3/R4/R5 Graphics]
           bus-ID: 00:01.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: fbdev,ati (unloaded: modesetting,vesa,radeon)
           Resolution: 1366x768@76.00hz
           OpenGL: renderer: llvmpipe (LLVM 8.0, 128 bits)
           version: 3.3 Mesa 19.0.8 Direct Render: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] Family 15h (Models 60h-6fh) Audio Controller
           driver: snd_hda_intel bus-ID: 00:09.2
           Card-2 Advanced Micro Devices [AMD/ATI] Device 15b3
           driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.15.0-58-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Realtek Device d723 driver: rtl8723de port: 2000 bus-ID: 03:00.0
           IF: wlp3s0 state: up speed: N/A duplex: N/A mac: <filter>
Drives:    HDD Total Size: 500.1GB (1.7% used)
           ID-1: /dev/sda model: ST500LT012 size: 500.1GB
Partition: ID-1: / size: 457G used: 8.1G (2%) fs: ext4 dev: /dev/sda2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 69.5C mobo: 20.0C
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://ca.archive.ubuntu.com/ubuntu/ bionic main restricted
           deb http://ca.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
           deb http://ca.archive.ubuntu.com/ubuntu/ bionic universe
           deb http://ca.archive.ubuntu.com/ubuntu/ bionic-updates universe
           deb http://ca.archive.ubuntu.com/ubuntu/ bionic multiverse
           deb http://ca.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
           deb http://ca.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu bionic-security main restricted
           deb http://security.ubuntu.com/ubuntu bionic-security universe
           deb http://security.ubuntu.com/ubuntu bionic-security multiverse
           Active apt sources in file: /etc/apt/sources.list.d/peppermint.list
           deb http://ppa.launchpad.net/peppermintos/p10-release/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/vscode.list
           deb [arch=amd64] http://packages.microsoft.com/repos/vscode stable main
Info:      Processes: 175 Uptime: 9 min Memory: 1051.4/3895.4MB
           Init: systemd runlevel: 5 Gcc sys: 7.4.0
           Client: Shell (bash 4.4.201) inxi: 2.3.56
« Last Edit: August 29, 2019, 10:26:39 am by vawogbemi »

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1812
  • Karma: 474
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: Only boot in recovery mode
« Reply #1 on: August 29, 2019, 04:07:06 am »
Hi vawogbemi,

After I did this tutorial to enable fn keys my laptop stop booting normally and can only boot in recovery mode.


Could you be more clear? Which tutorial? Can you provide a link to it or at least tell us what steps you followed from the tutorial?  :-\

Quote
Something like this also happened when I enabled my realtek 8723de network controller.


This implies that the problem was resolved (at that time). Could you tell us how you resolved the issue at that time?

Regards,

-- Slim
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline vawogbemi

  • nOOb
  • *
  • Posts: 2
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Only boot in recovery mode
« Reply #2 on: August 29, 2019, 10:24:06 am »
It was http://ubuntuhandbook.org/index.php/2018/02/enable-fn-keys-hp-ubuntu-16-04/ and it turns out that this line makes the computer not initialize the ram disk

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26273
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: (SOLVED) Only boot in recovery mode
« Reply #3 on: August 29, 2019, 11:00:26 am »
Don't you enable the Fn (function) keys on the HP Laptop 15-bw0xx by disabling "Action Keys" in the BIOS ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec