Author Topic: Startup errors ( SOLVED )  (Read 2487 times)

Offline arky217

  • Member
  • ***
  • Posts: 172
  • Karma: 11
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Startup errors ( SOLVED )
« on: September 28, 2017, 08:36:39 am »
Every time I have started Peppermint 8 for the last several weeks,
I have been getting these errors flash momentarly on the screen.

I copied them from the kernel log and posted them below.
Any idea what they are and what is causing them ?

Code: [Select]
Sep 28 10:29:11 jim-550-110 kernel: [   12.165512] ACPI Error: Field [D128] at 1152 exceeds Buffer [NULL] size 160 (bits) (20160930/dsopcode-236)
Sep 28 10:29:11 jim-550-110 kernel: [   12.165542] ACPI Error: Method parse/execution failed [\HWMC] (Node ffff9ac2930d59d8), AE_AML_BUFFER_LIMIT (20160930/psparse-543)
Sep 28 10:29:11 jim-550-110 kernel: [   12.165948] ACPI Error: Method parse/execution failed [\_SB.WMID.WMAA] (Node ffff9ac2930d5460), AE_AML_BUFFER_LIMIT (20160930/psparse-543)
Sep 28 10:29:11 jim-550-110 kernel: [   12.166023] ACPI Error: Field [D128] at 1152 exceeds Buffer [NULL] size 160 (bits) (20160930/dsopcode-236)
Sep 28 10:29:11 jim-550-110 kernel: [   12.166046] ACPI Error: Method parse/execution failed [\HWMC] (Node ffff9ac2930d59d8), AE_AML_BUFFER_LIMIT (20160930/psparse-543)
Sep 28 10:29:11 jim-550-110 kernel: [   12.166077] ACPI Error: Method parse/execution failed [\_SB.WMID.WMAA] (Node ffff9ac2930d5460), AE_AML_BUFFER_LIMIT (20160930/psparse-543)
Sep 28 10:29:11 jim-550-110 kernel: [   12.166131] ACPI Error: Field [D128] at 1152 exceeds Buffer [NULL] size 160 (bits) (20160930/dsopcode-236)
Sep 28 10:29:11 jim-550-110 kernel: [   12.166154] ACPI Error: Method parse/execution failed [\HWMC] (Node ffff9ac2930d59d8), AE_AML_BUFFER_LIMIT (20160930/psparse-543)
Sep 28 10:29:11 jim-550-110 kernel: [   12.166182] ACPI Error: Method parse/execution failed [\_SB.WMID.WMAA] (Node ffff9ac2930d5460), AE_AML_BUFFER_LIMIT (20160930/psparse-543)
Sep 28 10:29:11 jim-550-110 kernel: [   12.166261] input: HP WMI hotkeys as /devices/virtual/input/input10
Sep 28 10:29:11 jim-550-110 kernel: [   12.166394] ACPI Error: Field [D128] at 1152 exceeds Buffer [NULL] size 160 (bits) (20160930/dsopcode-236)
Sep 28 10:29:11 jim-550-110 kernel: [   12.166435] ACPI Error: Method parse/execution failed [\HWMC] (Node ffff9ac2930d59d8), AE_AML_BUFFER_LIMIT (20160930/psparse-543)
Sep 28 10:29:11 jim-550-110 kernel: [   12.166489] ACPI Error: Method parse/execution failed [\_SB.WMID.WMAA] (Node ffff9ac2930d5460), AE_AML_BUFFER_LIMIT (20160930/psparse-543)
Sep 28 10:29:11 jim-550-110 kernel: [   12.166576] ACPI Error: Field [D128] at 1152 exceeds Buffer [NULL] size 160 (bits) (20160930/dsopcode-236)
Sep 28 10:29:11 jim-550-110 kernel: [   12.166607] ACPI Error: Method parse/execution failed [\HWMC] (Node ffff9ac2930d59d8), AE_AML_BUFFER_LIMIT (20160930/psparse-543)
Sep 28 10:29:11 jim-550-110 kernel: [   12.166637] ACPI Error: Method parse/execution failed [\_SB.WMID.WMAA] (Node ffff9ac2930d5460), AE_AML_BUFFER_LIMIT (20160930/psparse-543)
« Last Edit: September 28, 2017, 07:29:35 pm by arky217 »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Startup errors
« Reply #1 on: September 28, 2017, 01:07:51 pm »
Okay those errors were probably always there in the logs, but according to the Arch forum the kernel devs have changed the way they're displayed in kernels >= 4.9, so they probably only started displaying AT BOOT when the HWE rolled you from the 4.8 kernel series to the 4.10 kernel series:
https://bbs.archlinux.org/viewtopic.php?id=223804

If everything appears to be working properly, you can possibly hide the error by adding:-
Code: [Select]
loglevel=3to the kernel boot line:
https://bbs.archlinux.org/viewtopic.php?id=226044

That won't "fix" the error, but if it's having no adverse effects it should at least "hide" the error messages during boot.



As explained here, this likely needs fixing by the OEM at the BIOS level:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1338412
are there any BIOS updates for your PC ?
« Last Edit: September 29, 2017, 02:42:03 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline arky217

  • Member
  • ***
  • Posts: 172
  • Karma: 11
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Startup errors
« Reply #2 on: September 28, 2017, 07:29:03 pm »
No, I haven't noticed anything different about Peppermint since the errors started showing at boot.

And I checked to see if there were any bios updates for my computer, but there aren't any.

So, since it doesn't bother me at all, I'll just mark this thread solved.

Thanks, for looking into it for me !

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Startup errors ( SOLVED )
« Reply #3 on: September 29, 2017, 02:42:46 am »
No problem arky217 :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec