Choose style:

Author Topic: (SOLVED) Input Method Editor-no menu item  (Read 2348 times)

0 Members and 1 Guest are viewing this topic.

Offline Ramlee

  • nOOb
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
(SOLVED) Input Method Editor-no menu item
« on: September 08, 2015, 10:13:43 am »
First post; Hi everyone.  I've just made the move over to Peppermint and so far I'm impressed.  Although my first language is English, I also like/need to type in Japanese.  Setting up Anthy or Mozc on almost any other distro has usually been pretty straightforward but so far I have yet to locate a keyboard/preference menu item that would allow me to do this.  Can anyone point me in the right direction?

Cheers Ramlee.
« Last Edit: September 09, 2015, 09:32:50 am by Ramlee »

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1678
  • Karma: 455
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 9 - 64bit
Re: Input Method Editor-no menu item
« Reply #1 on: September 09, 2015, 12:27:21 am »
Hi Ramlee,

Have you tried to install anthy? It is available in the software repositories for Peppermint Six. If you have not tried to install it, I suggest trying it. To do this you can use the synaptic package manager program that is already installed in your Peppermint Six installation.

I have never tried this program before, but I would imagine that setting it up in Peppermint Six should be rather similar to setting it up in other distros. If you have problems, get back to the forum here and describe your efforts as detailed as possible, including any error messages you get. Sometimes it helps, when having problems using newly installed software, to start it from a terminal session as then you can see error messages that you otherwise might not see. To start a terminal session you can use the sortcut key combination of these 3 keys: <Ctrl><Alt><t>. Once the terminal has started, enter the program name (e.g. anthy) and then press the Enter key ("Carriage Return / New Line" key).

Regards,

-- Slim
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1011
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Input Method Editor-no menu item
« Reply #2 on: September 09, 2015, 01:35:10 am »
Hi Ramlee, welcome to the Peppermint Forum  8)!  I'm not sure if this is what you are looking for.  You can change the keyboard layout in the Peppermint Control Center.  Navigate to: menu > Preferences > Peppermint Control Center.  Click on the Keyboard & Pointer tab and locate the: Select Keyboard Layout button.  There's a Japanese option in the skinny left hand panel.  I hope this helps  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline Ramlee

  • nOOb
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Input Method Editor-no menu item
« Reply #3 on: September 09, 2015, 05:27:42 am »
Hi Andy,

The menu item you referred to Select Keyboard Layout, simply informs the OS which keyboard layout to assume for the purposes of typing text.  I happen to be using an old Dell laptop with a Japanese keyboard as the unit was setup by Dell primarily for Japanese consumers.   When I installed P6, I was asked what keyboard layout I had so that item has already been selected.  Selecting a Japanese keyboard layout does not however allow you to type Japanese; one still needs to install a language pack (fonts etc.) or two as well as an input method editor (IME).  Most distros come with an IME prepackaged which allows you to switch between different character input options; P6 does not out of the box.  Thanks for the suggestion.

Offline Ramlee

  • nOOb
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Input Method Editor-no menu item
« Reply #4 on: September 09, 2015, 05:42:53 am »
Slim . Fatz,

Thanks for the reply.  I found a Japanese IME walkthrough for Mint.

http://www.localizingjapan.com/blog/2011/12/03/japanese-input-on-linux-mint-12-lisa/

I knew that I didn't have iBus installed yet so I quickly installed that package from the software manage; straight on to iBus Anthy and I thought I was good to go.  When I checked in the available input methods though Anthy had not registered so I couldn't select it.  I rebooted out of desperation....fingers crossed, still not there.  I thought 'right!'  I'm going to install iBus Mozc and again was stunned to not see it among the input methods.  Not quite sure where to go from here.

Cheers Ramlee.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24444
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Input Method Editor-no menu item
« Reply #5 on: September 09, 2015, 08:16:42 am »
OK, run:
Code: [Select]
sudo apt-get install ibus ibus-anthy ibus-mozc mozc-utils-gui
once done, log off/on  <-- IMPORTANT

Now go to
menu > Preferences > Language Support
if it asks to install language support, say yes

click "Install / Remove Languages" .. and put a tick in the boxes of the languages you want, then click the "Apply Changes" button.

Once that's done, log off/on again.  <-- IMPORTANT

now go to:
menu > Preferences > Keyboard Input Method > Input Method (tab)
put a tick in the "Customise active input methods" box.

then in the "Select an input method" drop menu, select a language you want (you may need to select "show all input methods") .. then click the "Add" button.

then in the "Select an input method" drop menu, select another language you want (you may need to select "show all input methods") .. then click the "Add" button.

Now click the little keyboard icon in the system tray (by the clock) and you should be able to switch between the keyboard layouts.
« Last Edit: September 09, 2015, 09:53:30 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ramlee

  • nOOb
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Input Method Editor-no menu item
« Reply #6 on: September 09, 2015, 09:30:11 am »
PCNetSpec,

You're a champ! 8)   You provided the final piece to the puzzle.  I'd more or less done everything you advised me to do but I failed to comprehend how the 'show all input methods' tab worked.


then in the "Select an input method" drop menu, select a language you want (you may need to select "show all input methods") .. then click the "Add" button.

Previous attempts to access this dropdown menu showed me nothing but for some reason all the installed IMEs were present. :o  Hooray!

In the interests of completeness, I should also mention that I had successfully installed SCIM Anthy and it was working as expected.  I personally prefer the iBus IME though.

Thanks to everyone who weighed in on this.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24444
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: (SOLVED) Input Method Editor-no menu item
« Reply #7 on: September 09, 2015, 09:55:02 am »
For my part, you're most welcome .. thanks for marking the topic solved :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline mdavies5

  • nOOb
  • *
  • Posts: 9
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6-2015
Re: (SOLVED) Input Method Editor-no menu item
« Reply #8 on: September 09, 2015, 10:07:41 pm »
PCNETSpec, Thanks for this tutorial. I am new to Peppermint, coming from Debian and Mint, and the keyboard input selection was the only function missing. I needed to use Thai and English and it did not work at first. I installed ibus-libthai and ibus-table-thai using Synaptic and it now works fine.
I road test many distros and Peppermint was one the easiest to install and configure with absolutely no bugs to report

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24444
  • Karma: 2698
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: (SOLVED) Input Method Editor-no menu item
« Reply #9 on: September 09, 2015, 10:28:22 pm »
Hi mdavies5, and welcome to the forum, and Peppermint...

I'm happy it was of some use to you, thanks for the feedback it's always nice to know this stuff is useful to someone other than just the original poster. :)
« Last Edit: September 09, 2015, 10:30:56 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec