Choose style:

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - ogopogo

Pages: [1] 2 3 4
1
New Users / Re: Can't reboot... [SOLVED]
« on: May 03, 2019, 11:56:13 pm »
Hi Slim,     Thank you for your answer.

Reducing the size of the /home partition sounds to me the best solution as I use most of the programs that I have installed and keep up with nixing those that are just sitting there idle.

I am quite comfortable using gparted so things are looking good.  Appreciate your help!   :)

2
New Users / Re: Can't reboot... [SOLVED]
« on: May 02, 2019, 03:41:36 pm »
Hi Slim.Fatz,      All my personal files are located in the DATA partition. I don't see any duplicates or backups of anything I recognize as being my own in the "/" directory. Does the size appear larger than normal for just OS files?

After I ran all the commands you suggested, here's what came out.... notice the "/" came out higher.... Perhaps because of the "dist-upgrade"?
I am currently running linux-image - 4.15.0-47 and have 48 also as a backup.

Code: [Select]
gerry@gerry-X542BA ~ $ df -h
Filesystem      Size  Used Avail Use% Mounted on
udev            3.7G     0  3.7G   0% /dev
tmpfs           749M  3.4M  746M   1% /run
/dev/sda3        15G   11G  3.7G  74% /
tmpfs           3.7G   39M  3.7G   2% /dev/shm
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           3.7G     0  3.7G   0% /sys/fs/cgroup
/dev/sda2        18G  6.1G   11G  37% /home
/dev/sda1       511M  7.3M  504M   2% /boot/efi
/dev/sda4       883G  152G  687G  19% /mnt/DATA
tmpfs           749M   20K  749M   1% /run/user/1000

3
New Users / Re: Can't reboot...SOLVED
« on: May 01, 2019, 08:13:37 pm »
Code: [Select]
gerry@gerry-X542BA ~ $ df -h
Filesystem      Size  Used Avail Use% Mounted on
udev            3.7G     0  3.7G   0% /dev
tmpfs           749M  2.9M  746M   1% /run
/dev/sda3        15G   10G  4.0G  72% /
tmpfs           3.7G   22M  3.7G   1% /dev/shm
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           3.7G     0  3.7G   0% /sys/fs/cgroup
/dev/sda2        18G  7.4G  9.3G  45% /home
/dev/sda1       511M  7.3M  504M   2% /boot/efi
/dev/sda4       883G  152G  687G  19% /mnt/DATA
tmpfs           749M   16K  749M   1% /run/user/1000

So right after I cleaned "/" it is 72% full. Would you recommend for me to make the partition bigger or is it ok?

4
New Users / Re: Can't reboot.....SOLVED
« on: May 01, 2019, 11:50:18 am »
Yes, secure boot is disabled. 

I went to the all mighty Google and found that others were experiencing the same problem with Nvidia and giving the same error:

https://askubuntu.com/questions/1089077/pkcs7-signature-not-signed-with-a-trusted-key-problem-pc-not-booting-graphical

Booting into recovery mode and then running "dpkg repair" sounded the best and easiest solution but it kept saying my "/" was full and to empty some of it out before proceeding. I can't remember the exact wording but in recovery mode there is an option to free up some space. As it was running, I couldn't believe how much the system had crammed full of (what looked like to me) kernels. After that finished, I ran dpkg repair again but with success this time.

After that my system booted up and I immediately deleted the Nvidia driver with synaptic. Not sure I want to try nvidia again anytime soon without further research into seeing whether it would solve a few small issues: 1) display brightness going to 100% after every suspend   2) Wireless mouse not being recognized sometimes after coming out of suspend.

Anyway, problem solved.....

5
New Users / Can't reboot... [SOLVED]
« on: May 01, 2019, 12:00:54 am »
Hello,     I've been wanting to try the nvidia driver to see if it would solve some minor glitches I keep having so using the synaptic package manager, I downloaded/installed  the nvida driver 390. After rebooting I was brought to the login screen (which was odd because I had set it to auto login). When I tried to login though  I'm getting the error:
" ....PKCS#7 Signature not signed with a trusted key". Even when I try to login as guest it still gives me the same error and can't login. I had to use the live usb to get to here to ask what might be wrong and how to correct this error. Any help is very appreciated.   :'(

- Just tried to login again using a different kernel and still not able to get past the login screen (however no error is given , just keeps coming back to the login screen)
- Second thing I tired was to enter into recovery mode and ran the reload grub option....again with no luck

6
Software & Applications / Re: Display Brightness to 100% after suspend
« on: March 17, 2019, 11:40:14 am »
Doesn't seem like it happens to many people....more of an annoyance than anything but I guess I can live with it if there is no solution.   :'(

7
Software & Applications / Re: Display Brightness to 100% after suspend
« on: March 17, 2019, 11:39:43 am »
Maybe there's no solution to this problem/annoyance but when I accidently posted twice and wanted to delete the duplicate post, there was no option to do so.

8
Software & Applications / Re: Display Brightness to 100% after suspend
« on: March 15, 2019, 04:52:04 pm »
I adjust the brightness either by right clicking on the battery icon in the panel and sliding it left or right or fn key with F5 or F6 (on my computer).

9
Software & Applications / Display Brightness to 100% after suspend
« on: March 14, 2019, 11:10:33 pm »
HI all,      I am using Xfce Power Manager with Peppermint 9 and each time I put my computer into suspend I have the display brightness set 'just right'.
After I come out of suspend, the display brightness is always up full blast. Is there a way to have it remember what I had it set to or is this just the way it is?

I have looked at the Topic: https://forum.peppermintos.com/index.php/topic,2952.msg29234.html#msg29234
where a fellow was having a similar problem and the fix didn't work for me (perhaps because he was interested in having the brightness stick after a reboot or shutdown not suspend).

10
is DATA on an internal drive ?

if so, you could change directory to /mnt/DATA
Code: [Select]
cd /mnt/DATA
then recursively change the permission of all FILES to 644:
Code: [Select]
find . -type f -exec chmod 0644 {} \;
and all DIRECTORIES to 755:
Code: [Select]
find . -type d -exec chmod 0755 {} \;
BE AWARE, if DATA is on an external drive the above commands could take some considerable time (depending on the amount of files/folders).

and remember, the above commands wil only work on files/folders you own.

ALSO bear in mind that going to mark ALL files as non-executable .. even scripts and binaries (not just text files).

HOORAY!  This worked like a charm. Thank you very much PCNetSpec!   :)

BTW..... All the info on the DATA partition on my HD I owned and there were no scripts or binaries to worry about either.

Thank you everyone else for you participation too!

11
Code: [Select]
erry@gerry-X542BA ~ $ ls -al /mnt
total 16
drwxr-xr-x  4 root  root  4096 Jul 11  2018 .
drwxr-xr-x 24 root  root  4096 Mar  5 10:58 ..
drwxr-xr-x 11 gerry gerry 4096 Jan  2 17:03 DATA
drwxr-xr-x  2 root  root  4096 Jul 10  2018 usb-WD_My_Passport_0820_575846314541343836504641-0:0-part1

12
Ok, If you would have all those files in the same directory, and according to the man page I've linked earlier, I guess you could change that for all the files inside that directory using
Code: [Select]
chmod -R u -x /path/to/directory/*

EDIT: Command corrected and...  tested on NetBSD. Sorry, but it's the machine that I have with me at the moment.

This is the output for that command:
Code: [Select]
gerry@gerry-X542BA ~ $ sudo chmod -R u -x /home/gerry/Documents/*
chmod: cannot access 'u': No such file or directory

This question reminds me of my own problems with file permissions from this post https://forum.peppermintos.com/index.php/topic,5936.0.html...  Now that Win10 is gone I'mma revisit
Read through this post which does seem very similar. Doesn't seem there was a solution though that could be applied here other than just grin and bear it until I eventually find them all and manually uncheck the boxes.  :-\

That's not a default ..  where is the text file ?
These text files are everywhere....mostly in my personal documents folders though: /mnt/DATA/Desktop,Documents, Music etc.

That's probably the issue .. as these are on a drive/partition you're mounting via fstab, your fstab entry needs fixing, and or the permissions of the mountpoint need fixing.
(so new files aren't created with the execute bit set)

Here is the output of my fstab.... anything I can change here to make my DATA partition (that contains the text files in question) to not make them executable?

Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb3 during installation
UUID=d747ec97-d505-4a37-9211-f11d35851d5f /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sdb1 during installation
UUID=84C4-377A  /boot/efi       vfat    umask=0077      0       1
# /home was on /dev/sdb2 during installation
UUID=2c6a20db-1cb8-4168-ae39-0d3e4b6e0270 /home           ext4    defaults        0       2
/swapfile                                 none            swap    sw              0       0
/dev/disk/by-id/usb-WD_My_Passport_0820_575846314541343836504641-0:0-part1 /mnt/usb-WD_My_Passport_0820_575846314541343836504641-0:0-part1 auto nosuid,nodev,nofail,x-gvfs-show 0 0
# User defined DATA partition. Created by "ogopogo".  Mount point is at /mnt/DATA ...
UUID=0bf84ff1-6444-4549-8d0c-8e23295d477b /mnt/DATA ext4 defaults 0 2
 

"permissions of the mountpoint need fixing."   Do you mean here? This is a screenshot of the permissions for one of the mountpoints where the text files are located


 

13
Well, you own the file, so just uncheck the box. I'm sure there's some terminal command to do it, but that's easier. (I know how to make them executable, but not the opposite)

As far as why it's set that way by default, I have no idea. I've never had that happen and I've created a new text document as recently as Thursday. In what format did you save it?

No problems with checking or unchecking the box, its having to do it with every text file I have that's the pain. I think it all started after I reinstalled Peppermint one time.
Once they are unchecked, they stay unchecked the next time I open them. These files were never originally created with this box checked but somehow all got checked at the same time.
All were saved as: Text(text/plain)

https://linux.die.net/man/1/chmod
Thank you for the link, but what it said was Chinese to me.... I would need that dumbed down a bit  ;) in order to understand or do anything with it.

That's not a default ..  where is the text file ?
These text files are everywhere....mostly in my personal documents folders though: /mnt/DATA/Desktop,Documents, Music etc.

14
Hi All,   I'm having an issue where I open a text file and get the following window:


 


I then have to right click on the file/ properties / permissions / then uncheck the box "allow to executing file as program"


 


Why is this checked as a default setting and how do I permanently keep this from happening?  Any help is appreciated! 


15
User Submitted Tutorials / Re: How To: Use symlinks to a DATA partition
« on: January 03, 2019, 02:12:10 pm »
Thank you for your reply PCNetSpec.
None of the fixes apply to me and I'm limited with my bandwidth so I'll go ahead with the .iso I already have.  8)

Pages: [1] 2 3 4