Peppermint OS Community Forum

Support => Hardware => Topic started by: pbuydid on November 07, 2018, 07:51:00 pm

Title: Ati drivers not loaded in last kernels
Post by: pbuydid on November 07, 2018, 07:51:00 pm
Hi everybody.
I've been using Peppermint 7 since it was launched and I feel so comfortable using it. Because I love Plasma, I early installed it using synaptic, the repos incluided in Peppermint. And it looks ok.
I use composite to give some effects to my desktops.
My hardware:
Sony Vaio Laptop
E2 Processor (Dual Core)
6 GB Ram
VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6320]
Running Peppermint 7 64 bits


From some time to now, I noticed the system goes slowly when effects run. It happend after some kernel updates. Then I tried to update to official AMD drivers and it was the worst I could do. FPS in my desktop falls down to 5 or 4 when composite starts. It happens when I load the following last installed kernels (via system update):
4.15.0-36
4.15.0-38
4.4.0-138


I kept some of my old kernels installed and when I loaded the old one, it works perfect!!!  That kernel is version 4.4.0-92

I did some investigation and found that are diferences in the modules loaded in the old kernel and the last ones. When I use GLXINFO to test my OpenGl parameters, I obtain the following....

In Kernel 4.4.0-92 (the one that runs perfect):
Quote
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
OpenGL vendor string: X.Org
[...]
 Device: AMD PALM (DRM 2.43.0 / 4.4.0-92-generic, LLVM 6.0.0) (0x9806)

In updated kernels (graphics and performance working bad):
Quote
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
OpenGL vendor string: VMware, Inc.

I think there is a problem, in the new kernels it loads VMware resources and no AMD.
But I don't know how to follow.... Is it possible to configure the updated kernels to load the ATI drivers correctly?
I hope to give the correct information.
Thanks in advance!!
Title: Re: Ati drivers not loaded in last kernels
Post by: alynur on November 07, 2018, 09:28:18 pm
Hi pbuydid, try installing kernel 4.18. People are repoting it runs great in P 7. Good luck.
Title: Re: Ati drivers not loaded in last kernels
Post by: pbuydid on November 16, 2018, 01:16:23 pm
Thank you.
Now I have other problem: While I'm trying to install the kernell you suggest to me, I get a new error:
Kmod is not configured yet  :(

I will keep on trying