Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Bigoeuf

Pages: [1] 2 3 ... 12
1
Advanced Topics / Re: Broken Grub on Pep9
« on: June 18, 2020, 08:33:13 am »
@harriskev
Have a look at https://www.supergrubdisk.org/super-grub2-disk/ 15.6mb .iso for me - burned to a CD - though please read through the site thoroughly to find info & which download is right for you.
I had to use it reasonably recently when I managed to cock my grub installation up - excellent tool.  ;)

As an afterthought as you may notice I'm on Pepp 7 & its fine for me on my old Dell Inspiron 1501 (circa 2006) - anything greater than 4.4.x kernel plays havoc with shutdown unfortunately - I've been around the buoy troubleshooting & its problematic for me to say the least sooo I've unfortunately had to look elsewhere going forward on this old banger - however Pepp 7 is good for another 9 months support if you're so inclined  :)

2
Networking / Re: Trying to ressurect an Inspiron 6000 (ABANDONED)
« on: May 11, 2020, 03:45:19 am »
Hello Chalesm

I think you are more technically proficient than me & this may come a little late & I don't know if its of any help but lets see.

I see you've connected via ethernet (no problem there) & your WiFi is enabled - hardware & software switch-wise. As you say your WiFi card is identified by your system & you are trying to configuring it via Network Manager?
I presumed you've installed Pepp 10? If so do you have the same issue running from a Live-USB of Pepp 10? Perhaps a re-download (possible corruption issues)? or maybe a different distro? (see below)

I've got a an Inspiron 1501 which is similar to your Inspiron 6000 - vintage & construction wise. Mine has a 15.6" screen (though only 1280x800 resolution) & its also AMD Turion CPU.
Networking wise it has the same ethernet card as yours (BCM4401-B0) but the WiFi card is also Broadcom (BCM4311). I haven't been able to get my ethernet to work (I think I may of physically damaged the port) but the WiFi works fine - so I have no issue, however I am using Pepp 7 on this machine. I tried upgrading to Pepp 8 when it came out a few years ago & I had issues (hanging at shutdown primarily), which after testing I pinned down to the newer kernel - anything above the 4.4.XXX series.

Now its possible that your WiFi card for your laptop isn't fully supported in the newer Pepp 10 kernel (5.0.0-37 with Hardware Enablement Stack) - but you also mentioned that your D-Link DWA 171 A1 USB adapter is problematic too?
So maybe try running a Pepp 7 Live-USB & see if you have any joy with your WiFi card then?

As a footnote (& perhaps shouldn't say this on the Pepp forum - but for your hardware case it may be useful) support for Pepp 7 will effectively end in April 2021 so I will have to find an alternative (other than compiling the kernel myself for a later version of Pepp  :o) & I have been dabbling with freebsd (nomadbsd is a nice prebuilt 'distro' version - runs from a USB stick, with persistence, but can also be installed). I think all of the bsd's support older hardware though some reading & researching maybe required for specific cases.

I've been a happy Pepp user for a long time - but nothing stays the same/ stands still - good luck.

3
Good Afternoon

@ Leviticus
I believe it was personal see my post above:  https://forum.peppermintos.com/index.php/topic,9275.msg93706.html#msg93706
it deals with mistake(s) & also "sloppiness" and attitude.

However since he released that video I believe 'Learn Linux' has had somewhat of an 'epiphany' as he subsequently put out another on his channel, 'Our Attitude in the Linux Community', on 19 Jan 2020 in which he expresses his shame of his attitude in 'Let's Be Honest about Peppermint OS 10 Respin'.

He starts by saying that he knew of Mark's passing but not before he put out his 'Let's Be Honest about Peppermint OS 10 Respin' video. As far as I see this can only be correct - he put out the video on 12 Jan 2020 & Mark's passing was announced on the forum on 14 Jan 2020, which was the earliest time it was divulged, as far as I'm aware.

He mentions the "..security flaw.." which is valid, but the fundamental thing with 'Our Attitude in the Linux Community' is his reproach-fullness, with talk of respect & legacy & honesty.

Although he says at the end of 'Our Attitude in the Linux Community'    "....this thing with Mark has got me thinking...."
regarding his change in attitude I'm also making an educated guess that he has read my post:  https://forum.peppermintos.com/index.php/topic,9275.msg93706.html#msg93706
 because quite early on in his video he uses the phrase 'Elephant in the room' a couple of times which is the same phrase I used near the beginning of my post. If so, & my post has some bearing on his 'epiphany', then I'm glad, not in a vitriolic way but in a positive awareness way.

Quote
My issue with the action taken is that the person responsible for the video made no attempt at responsible disclosure. Generally speaking it's good practice to disclose a vulnerability to the creators/maintainers of a given piece of software first and then release that information publicly either after the issue is fixed or if the issue isn't addressed within a reasonable amount of time. The responsible disclosure model is generally regarded as more ethical than full disclosure and non-disclosure models.
Quote
I certainly don't agree with everything he said, but many of his criticisms are valid and represent areas where we should at least be asking ourselves if we're doing it the right way.

Yes agree with those points kendall but I think his attitude in his 'Let's Be Honest about Peppermint OS 10 Respin' video 'coloured' how, & maybe why, it was produced - something that 'Learn Linux' has acknowledged with 'Our Attitude in the Linux Community'

As I mentioned in my post I respect his talent & the fact that he produces & shares his knowledge & scripts etc with the community. I stand by that & all else I put in that post too, including him pointing out the the 777 permissions problem on /usr/bin/gnome-desktop-item-edit - although I think it should of been done in a more responsible way as kendall mentioned.
However I appreciate his contrition in his 'Our Attitude in the Linux Community' video - perhaps we can move forward with a spirit of reconciliation.  :)

4
I can only echo Slim.Fatz post
I am too devastated to say anything else right now.
Condolences to his family.
Regards Zeb...

It is only now slowly sinking in that I have lost a true friend. I only knew him through here and comments in live streams but Mark kept me honest and down to earth. His unquenchable desire to help people is something that I can only aspire to attain. He will forever be remembered in my heart.

I hope his closest family find some solace in knowing what a great community he built around him in Linux and each and every one of us offer our condolences to them in their darkest hour.

Goodbye my friend, I miss you so much 💔

Well said Zeb

5
Morning Andy
Hope your OK despite the shocking news this week? I don't know if you met Mark 'in the flesh' so to speak but even if not you must have known him very well from on here - very tragic  :(
Thanks for confirming that - now people on Pepp 10 can be aware.
Unless you have any different thoughts I do suggest the course of action I gave in my previous post to sort out this issue - can only see positives from it & now this knowledge of the problem is out 'in the wild' now I suggest sooner rather than later.

6
Hello
I started this response to this topic before I learnt of Mark's passing but still feel I ought to contribute as I have an opinion & think I understand the crux of what 'Learn Linux' is saying about the elephant in the room - the 777 permissions problem - I think the rest has been pretty much covered by Zeb & quite frankly, IMHO, is:

    "Much ado about nothing" William Shakespeare


Firstly I have no reason to doubt his assertion that the file:
Code: [Select]
gnome-desktop-item-editexists at:
 
Code: [Select]
/usr/bin
with root:root ownership & 777 permissions on Pepp 10 - but has anybody checked?
(There are no such issues for me here on Pepp 7).

He correctly demonstrates in his video - due to the 777 permissions - he was able to open, edit & save the file without needing to use elevated privelages (sudo or su), & subsequently was then able to execute the newly saved file (with the newly edited & saved command), again without needing to use elevated privelages, & the Folder/Directory he created was duly deleted.

However this Folder/Directory he created was in the Home user space (Home Directory) & not in the Root user space, which would, from my testing require super user privileges to execute - I stand to be corrected, but if I am correct then yes it may certainly affect the Home directory (recursively) but wouldn't the Root user space.

Obviously this still isn't good & in the absence of any other suggestions may I offer changing the permissions of the offending file to 755, which is pretty standard for executables in such locations:

Code: [Select]
sudo chmod 755 /usr/bin/gnome-desktop-item-editThis would certainly mitigate against this permissions issue but people would need to report if they notice any adverse effects (which quite frankly I doubt). Perhaps would of been helpful if 'Learn Linux' had perhaps suggested a solution to this "significant security issue" - I'm sure its well within his cerebral capacity - but I don't think it was his motivation with this video (see below).


I have watched a fair few of his YouTube videos. I have been impressed & find them educational & have indeed used some of his code.
He is obviously clever & knowledgeable & also productive. His interest is more aligned to programming, minimalism & efficiency (he has/had a script to Simplify Ubuntu that allows the user to strip out undesired 'cruft' from a standard Ubuntu install for example) - all kudos to him for producing & sharing his knowledge & scripts etc

But Peppermint isn't really like that, it, IMHO is a 'light on its feet' distro with the sound Ubuntu base that has a nice hybrid DE, & for me, just works OOTB.
I can't speak specifically about Pepp 10 re-spin - I'm on Pepp 7 (Ubuntu 16.04 base) which incidentally been pretty much sound as a pound for me over the last 3½ years.
I would say Peppermint OS caters for all - from the non too technically gifted of us up, who would just like to use something pretty nimble that gives a nice sound base for expanding in a desired direction & combination - i.e. gaming, office, graphics, audio, video etc. but is also easy to use & maintain.

A lot of the stuff he complains about has been included to try & make it easier for the 'average' user - cover all bases so to speak i.e. as Zeb said about the multiple software managers, without having to delve too much, if at all, into the terminal, which would be a bit of an anathema to 'Learn Linux' aka 'TerminalForLife'.

I don't use the Software Manager, & could quite frankly bin it (I generally use the terminal), but some people might. I do, & will, avoid snaps like the plague, I don't like the ethos - understand it but don't like it.
Other stuff too - Samba & Bluetooth both uninstalled as I have no use for them - same with Printers & Simple Scan, but I have left them installed.
Any other 'excess' software could also be removed - 'Learn Linux' even does it himself in Ubuntu as I've mentioned above.
There are plenty of people that are a fan of ICE, but I'm not, so I removed all the SSB's via the ICE app & uninstalled it - must of taken me all of 5 mins, if that -it really wasn't the end of the world but the way 'Learn Linux' goes on about it you would think it was!


Though I think 'Learn Linux' is pretty bright cookie I also think his intellectual nose got somewhat put out of joint in the forums along the way when he was using Peppermint as I feel he:

     "...doth protest too much" Macbeth

he says while on the forums he experienced invidious behaviour:
     "....sod you!...foul attitude.....childish....obnoxious....not nice people"

but subsequently in his video uses disdainful language & tone of his own:
     "....pissed on everything....a bit of an offence....sloppy"


I've been a forum member since February 2016 & he was Ichy on the forums back in 2016/7. Looking at the the topics he posted under I find it difficult to understand where he gets his 'intense' dislike of our community from?? Maybe he was 'proxying out' his dislike in regard to other forum members 'treatment'? However I don't know of many, if any, complaints?


English Bob commented on this video on YouTube:
     "...maybe you should have reported it on their forums before you slag it off .."

I'm afraid to say Steve I don't think this was the purpose of this video - I think this was an opportunity for him to demonstrate his technical prowess & vent his spleen somewhat - I think he wanted:

      "...his pound of flesh" The Merchant of Venice

for his perceived injurious experience on the forums - but I may be wrong??.


There is a saying my late father use to wheel out now & again:

      "The importance of feelings is directly proportional to the feeling of importance"

I'll let that hang there a while.


As for "sloppiness" it seems 'Learn Linux' is well qualified in that department:

 - his failed attempts at installing & later using Void Linux through lack of attention to the instructions (which incidentally even I have managed - funnily enough by following instructions).

 - In his 'Your Comments!' video (13/01/20) on YouTube he starts by saying:
    "Guess what - I just spent 35 minutes recording a video - this video - another video, but for this purpose - & I hadn't enabled sound in simple screen recorder - ohh my God was that annoying ..."
I bet it was - & also very sloppy - even more so as this occurrence, by his own free admission, isn't unique!

    'People in glass houses...'??

or perhaps my final Shakespeare reference:

     "Better a witty fool, than a foolish wit." Twelfth Night

Think I've said enough now - Turrah.


P.S. I'm not registered on YouTube but if anyone wishes to link this post in a comment under his video feel free.

7
Afternoon All

Normally I would say Good Afternoon but this is obviously not. I would like to echo the sentiments of the other posts in this thread, like you all, I'm stunned - Mark was but a year older than myself.
I don't know the circumstances, & frankly its non of my business, but I would like to extend my condolences to his family & friends, & to those of you that knew him through this community.
I couldn't class myself as a regular on here, & couldn't in all honesty call Mark a friend - I just didn't know him well enough - but whenever I needed help Mark was inevitably there & was indeed friendly.

He will be very sorely & sadly missed

RIP Mr Peppermint

8
News and Reviews / Re: Firefox Certificate Issues - Extensions etc
« on: May 08, 2019, 04:25:19 am »
Looks like all fixed now (for me anyway) with latest updates that upgrade to FF 66.0.4 - also confirmed here:

https://www.mozilla.org/en-US/firefox/66.0.4/releasenotes/

Though in the Release Notes it does make this caveat:

Quote
A small number of add-ons may be listed as unsupported or may not appear in about:addons. Their data is not lost; users should be able to re-install the add-ons and recover the data

However FF 66.0.5 has already been release by Mozilla:

https://www.mozilla.org/en-US/firefox/66.0.5/releasenotes/

that comments:

Quote
Fixed    Further improvements to re-enable web extensions which had been disabled for users with a master password set

That will undoubtedly filter down through the Ubunutu/ Pepp Repos in due course  :)


9
News and Reviews / Firefox Certificate Issues - Extensions etc
« on: May 04, 2019, 03:06:34 am »
Morning
Whilst using Firefox just all my extensions suddenly were made 'legacy & no longer supported by Firefox' since then a notice banner appeared when I tried to reinstall the extensions:
Quote
Due to a certificate issue, add-ons are not working and will fail to install. We are currently working on this issue and you can track updates at https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047/
No fixed as of this moment - hopefully soon
 ;)

10
Networking / Re: intel centrino advanced n6200
« on: February 01, 2019, 09:23:23 pm »
Good Morning Bob
Don't want to be speaking out of turn but I don't think you need to install any wifi drivers for Peppermint - certainly from 7 onwards any road - but I stand to be corrected by Mark or any of the inner circle  ;)

I did have a very similar wifi card to yours installed on my Dell E6430 laptop that worked 'out the box' with Pepp 8 on a live USB. I made a copy of the specs at the time:

Code: [Select]
peppermint@peppermint ~ $ inxi -Fz
System:    Host: peppermint Kernel: 4.8.0-53-generic x86_64 (64 bit)
           Desktop: N/A Distro: Peppermint Eight
Machine:   System: Dell (portable) product: Latitude E6430 v: 01
           Mobo: Dell model: 0H3MT5 v: A00 Bios: Dell v: A18 date: 01/18/2016
CPU:       Quad core Intel Core i7-3720QM (-HT-MCP-) cache: 6144 KB
           clock speeds: max: 3600 MHz 1: 1623 MHz 2: 1200 MHz 3: 1199 MHz
           4: 3400 MHz 5: 2599 MHz 6: 1202 MHz 7: 1199 MHz 8: 1289 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
           Card-2: NVIDIA GF108GLM [NVS 5200M]
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1600x900@59.99hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile
           GLX Version: 3.0 Mesa 17.0.2
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e
           IF: eno1 state: down mac: <filter>
           Card-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi
           IF: wlp3s0 state: down mac: <filter>

Note the second to last line where it shows the Intel wifi card with the iwlwif driver.

Are you sure you have got the wifi card enabled? - apparently there is both a  there is a hardware & a software wireless switch on these laptops - look here:

https://ccit.college.columbia.edu/knowledgebase/article/how-manage-wireless-lenovo-laptops

From what I've seen I believe your hardware wireless switch is on the right side edge right near the front on your laptop

HTH  :)

11
Software & Applications / Re: How do you run Bluetooth anyway?
« on: January 19, 2019, 03:23:53 pm »
Evening Mynaardt - mi old colonial cousin & A Happy New Year to you

This maybe of some assistance:

This is your wifi card:

https://www.intel.com/content/dam/www/public/us/en/documents/product-briefs/centrino-advanced-n-6205-brief.pdf

Note: No Bluetooth


You could replace it with:

https://www.intel.com/content/dam/www/public/us/en/documents/product-briefs/centrino-advanced-n-6235-brief.pdf

Note: Bluetooth - Its an upgraded card in the same series so I can't see why it won't work


A quick search turned up this:

https://www.amazon.ca/Centrino-Advanced-N-6235-5ghz-920119/dp/B007QXLIWI/ref=sr_1_1?keywords=centrino-6235&qid=1547939159&sr=8-1

Note: This is not me recommending or advocating you buy from this seller it is purely an example - I'll leave you to research that.

You may wish to upgrade to a higher spec wifi card that is capable of communicating using the latest AC standard (which I have done - though it is of no use to me with my home router as it is not of that same standard) which maybe of similar cost as the N standard one. You may need to check with Lenovo about whats available & compatibility.


Youtube video showing how to access wifi card for replacement:

https://www.youtube.com/watch?v=M3aivW-7qJk

1. Remove battery
2. Remove back center access panel

See wifi card next to SODIMM (RAM)

3. Remove wifi card (as shown - I would use plastic utensils though)
4. Reverse procedure - hopefully job done

Seems simple as you like. I've done various hardware mods/upgrades to my Dell Laptops (CPU's, SSD/HDD, RAM, Wifi Card, Keyboard, daughter board) some of which have been considerably more involved & with one exception (E6430 speakers which maybe a motherboard fault) everything has been upgraded satisfactorily.

HTH & Good luck  ;)

12
Hardware / Re: Dell Latitude 6430 - Speakers
« on: August 30, 2018, 06:30:12 am »
Blimey funny you should mention that - I haven't had any overheating problems yet but I was well aware that the replacement CPU went from 31w (the previous TL-50) to 35w. I bought some half decent thermal paste Arctic MX-4 instead of the distinctly average Startech stuff I had been using.
I also made up a little launcher to call:

Code: [Select]
watch -n 1 sensors
It dynamically monitors the sensors in my case  just the CPU.

I periodically look at my CPU temp as & when - here it is (not rocket science its exactly as seen) & when called, via the thermometer icon next to the volume icon in the tray, the terminal output :



Yes upgraded the RAM to 2gig & now 4gig some time ago (original was 516mb & the CPU was MK-36 single core 2.0ghz - always struggling)
Smashing little battle bus & in a few ways I prefer it to the E6430 - speakers obviously (hopefully to be remedied) bigger screen & tuff as old boots  :P
Its got problems though - the graphics struggle a bit & the battery doesn't charge & the Ethernet port isn't working either (both require the soldering iron if & when I get round to it)

13
Hardware / Re: Dell Latitude 6430 - Speakers
« on: August 30, 2018, 04:19:32 am »
Afternoon
Just an update (if anyone's interested lol  ;D )

So as per:

Quote
I'm gonna get a replacement IO Daughter Board off Fleabay

I did indeed (only cost a little more 'cos mine got an additional Nvidia graphics chip but still only £11 - delivered & its brand new  ;) )

Did the 'deed' last Saturday when it chucked it down all day & Ta-Darrr!   - no change speakers still the same  :(

Everything else seems to work on the new IO Daughter Board just the same as the one I replaced it with, including the headphone jack which produces good sound too.

Well I guess regarding the speakers:

Quote
So either I am unlucky with my second-hand purchases....

So as they said in the old 'Topic' adverts - 'Try again Toby' so I'll buy another set & hopefully that will sort it. The problem is without a 'guaranteed' working set I'm just taking pot luck with fingers  crossed. So 'Once more into the breach...' (quotes ey? - I'm full of 'em lol  :D )


Off topic I know - but loosely connected  ;) had a result with the old banger (Inspiron 1501) though - got pretty much the top CPU that my board will work with - yes the mighty AMD Turion 64 x 2 TL 60 2.00 ghz (TMDTL60HAX5CT) - an upgrade of 0.4 ghz plus double the L2 cache - fitted it last week - small but noticeable upgrade in performance all for the princely sum of £2.49 delivered - happy bunny  :)  which is just as well as this is still my 'daily driver' 'cos of the speaker issue & the CPU isn't susceptible to the ongoing spectre issues (according to the spectre-meltdown-checker anyway). However it is still on P7 - because of the 4.4 kernel anything above that & it fails to shutdown nothing wrong with P7 at all - I'm very content with it but support won't go on forever (2020??) - may have to learn to compile my own kernel  :o you'll have to standby on here if I do lol  :D

14
Hardware / Re: Dell Latitude 6430 - Speakers
« on: August 01, 2018, 06:42:00 pm »
Cheers for digging that out Mark because I certainly had never seen it - perhaps I was barking up the wrong tree by putting in poor & distorted speaker output  ???
Prompted by your lead Mark I did a bit more rooting around & although I couldn't find an exact match for my circumstances it would seem a definite possibility that the issue in the link you gave could be the problem & to cut a long story short (as Spandau Ballet once said) I'm gonna get a replacement IO Daughter Board off Fleabay  ;)
Fingers crossed its OK & its that that's the problem - cos it entails stripping the lappy right down - again  ::)


15
Hardware / Re: Dell Latitude 6430 - Speakers
« on: August 01, 2018, 08:31:47 am »
Yep & from the other Linux OS (Void) that I have installed too  :( .
I also tested headphones from the jack with both & the sound was good - dare I say even excellent  :)
So I would say it's definitely hardware related - specifically to the speakers - so I really need to 'test' in that area because the soundcard (I presume) is not the issue  ???

Pages: [1] 2 3 ... 12