Choose style:

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - osde8info

Pages: [1]
1
virtualbox peppermint vm installs require you to run ./VBoxLinuxAdditions.run twice

run VBoxLinuxAdditions.run
it fails with the error "modprobe vboxsf failed"
reboot

run VBoxLinuxAdditions.run
it fails
it works

Code: [Select]
# ./VBoxLinuxAdditions.run 
Verifying archive integrity... All good.
Uncompressing VirtualBox 5.2.6 Guest Additions for Linux........
VirtualBox Guest Additions installer
Copying additional installer modules ...
Installing additional modules ...
VirtualBox Guest Additions: Building the VirtualBox Guest Additions kernel modules.
VirtualBox Guest Additions: Running kernel modules will not be replaced until the system is restarted
VirtualBox Guest Additions: Starting.
VirtualBox Guest Additions: modprobe vboxsf failed

Code: [Select]
# cat y.y
# ./VBoxLinuxAdditions.run
Verifying archive integrity... All good.
Uncompressing VirtualBox 5.2.6 Guest Additions for Linux........
VirtualBox Guest Additions installer
Removing installed version 5.2.6 of VirtualBox Guest Additions...
Copying additional installer modules ...
Installing additional modules ...
VirtualBox Guest Additions: Building the VirtualBox Guest Additions kernel modules.
VirtualBox Guest Additions: Running kernel modules will not be replaced until the system is restarted
VirtualBox Guest Additions: Starting.

2
Installation / cannot install open-vm-tools-desktop
« on: February 09, 2018, 10:43:28 am »
(im having problems with vmwaretools now so am trying to try open-vm-tools-desktop again)

# aptitude install open-vm-tools-desktop

Code: [Select]
The following NEW packages will be installed:
  open-vm-tools-desktop open-vm-tools-dkms{a} xserver-xorg-core{ab} xserver-xorg-input-vmmouse{a}
0 packages upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,905 kB of archives. After unpacking 11.4 MB will be used.
The following packages have unmet dependencies:
 xserver-xorg-core : Conflicts: xserver-xorg-video-modesetting which is a virtual package, provided by:
                                 - xserver-xorg-core-hwe-16.04, but 2:1.19.5-0ubuntu2~16.04.1 is installed.                                 - xserver-xorg-core-hwe-16.04, but 2:1.19.5-0ubuntu2~16.04.1 is installed.                                 - xserver-xorg-core, but 2:1.18.4-0ubuntu0.7 is to be installed.                                 - xserver-xorg-core, but 2:1.18.4-0ubuntu0.7 is to be installed.
 xserver-xorg-hwe-16.04 : Conflicts: xserver-xorg-core (>= 0~) but 2:1.18.4-0ubuntu0.7 is to be installed.
 xserver-xorg-core-hwe-16.04 : Conflicts: xserver-xorg-core but 2:1.18.4-0ubuntu0.7 is to be installed.
                               Conflicts: xserver-xorg-video-modesetting which is a virtual package, provided by:
                                           - xserver-xorg-core-hwe-16.04, but 2:1.19.5-0ubuntu2~16.04.1 is installed.                                           - xserver-xorg-core-hwe-16.04, but 2:1.19.5-0ubuntu2~16.04.1 is installed.                                           - xserver-xorg-core, but 2:1.18.4-0ubuntu0.7 is to be installed.                                           - xserver-xorg-core, but 2:1.18.4-0ubuntu0.7 is to be installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:       
1)     xserver-xorg-core [Not Installed]                         
2)     xserver-xorg-input-vmmouse [Not Installed]                 

     Leave the following dependencies unresolved:                 
3)     open-vm-tools-desktop recommends xserver-xorg-input-vmmouse


Accept this solution? [Y/n/q/?] n

3
Software & Applications / eclipse says SIGSEGV
« on: February 09, 2018, 06:46:29 am »
eclipse says SIGSEGV

Code: [Select]
$ eclipse-installer/eclipse-inst 
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f88bb846004, pid=14054, tid=14055
#
# JRE version: OpenJDK Runtime Environment (9.0) (build 9-internal+0-2016-04-14-195246.buildd.src)
# Java VM: OpenJDK 64-Bit Server VM (9-internal+0-2016-04-14-195246.buildd.src, mixed mode, tiered, compressed oops, serial gc, linux-amd64)
# Problematic frame:
# C  [libflashplayer.so+0x700004]
#
# No core dump will be written. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/me/hs_err_pid14054.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

Code: [Select]
---------------  T H R E A D  ---------------

Current thread (0x00007f894c011000):  JavaThread "main" [_thread_in_native, id=14055, stack(0x00007f89530f6000,0x00007f
89531f7000)]

Stack: [0x00007f89530f6000,0x00007f89531f7000],  sp=0x00007f89531f3958,  free space=1014k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C  [libflashplayer.so+0x700004]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j  org.eclipse.swt.internal.webkit.WebKitGTK._webkit_web_view_new()J+0
j  org.eclipse.swt.internal.webkit.WebKitGTK.webkit_web_view_new()J+7
j  org.eclipse.swt.browser.WebKit.create(Lorg/eclipse/swt/widgets/Composite;I)V+312
j  org.eclipse.swt.browser.Browser.<init>(Lorg/eclipse/swt/widgets/Composite;I)V+81
j  org.eclipse.oomph.ui.UIUtil$2.run()V+15
j  org.eclipse.oomph.ui.UIUtil.syncExec(Ljava/lang/Runnable;)V+16
j  org.eclipse.oomph.ui.UIUtil.isBrowserAvailable()Z+13

4
News and Reviews / peppermint os group now on flickr
« on: February 08, 2018, 05:06:58 pm »
add your peppermint photos and screenshots here

https://www.flickr.com/groups/peppermintos/

5
thinkpad t410 with virtualbox and peppermint 8

Code: [Select]
# inxi -Fz
System:    Host: pepp Kernel: 4.13.0-32-generic x86_64 (64 bit) Desktop: N/A Distro: Peppermint Eight
Machine:   System: innotek (portable) product: VirtualBox v: 1.2
           Mobo: Oracle model: VirtualBox v: 1.2 Bios: innotek v: VirtualBox date: 12/01/2006
CPU:       Single core Intel Core i5 M 540 (-UP-) cache: 3072 KB speed: 2526 MHz (max)
Graphics:  Card: InnoTek Systemberatung VirtualBox Graphics Adapter
           Display Server: X.org 1.19.5 drivers: (unloaded: fbdev,vesa)
           tty size: 111x34 Advanced Data: N/A for root
Audio:     Card Intel 82801AA AC'97 Audio Controller driver: snd_intel8x0 Sound: ALSA v: k4.13.0-32-generic
Network:   Card: Intel 82540EM Gigabit Ethernet Controller driver: e1000
           IF: enp0s3 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 27.5GB (27.5% used) ID-1: /dev/sda model: VBOX_HARDDISK size: 27.5GB
Partition: ID-1: / size: 24G used: 5.2G (24%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 161 Uptime: 36 min Memory: 1248.1/3052.7MB Client: Shell (bash) inxi: 2.2.35

6
run eclipse (oxygen2) from the command line and you will get

Code: [Select]
(Eclipse:10611): Gtk-WARNING **: Error loading image 'file:///usr/share/themes/Pepirus/assets/null.png': Error opening file: No such file or directory

(Eclipse:10611): GLib-CRITICAL **: g_base64_encode_step: assertion 'in != NULL' failed

(Eclipse:10611): GLib-CRITICAL **: g_base64_encode_step: assertion 'in != NULL' failed

(Eclipse:10611): GLib-CRITICAL **: g_base64_encode_step: assertion 'in != NULL' failed

(Eclipse:10611): GLib-CRITICAL **: g_base64_encode_step: assertion 'in != NULL' failed

(Eclipse:10611): GLib-CRITICAL **: g_base64_encode_step: assertion 'in != NULL' failed

7
in a peppermint 8 vmware vm open-vm-tools and open-vm-tools-desktop do not work so when installing peppermint 8 into a vmware vm do not use open-vm-tools (the screen never resizes)

use VMware Workstation Player | Manage | Install VMware tools instead
and when you run vmware-config-tools.pl say NO to all the questions
ESPECIALLY
Would you like to enable VMware automatic kernel modules? NO

Pages: [1]