Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - ScubaSteve

Pages: [1] 2 3
1
Software & Applications / Re: Flash player projector
« on: January 13, 2019, 05:39:51 pm »
Its just a stand-alone flash player. Tried to download the 64 bit projector from adobe's website but it is just blank when I try to use it.

https://forums.adobe.com/thread/1388144
https://www.adobe.com/support/flashplayer/debug_downloads.html

2
Software & Applications / Re: Flash player projector
« on: January 12, 2019, 06:06:26 pm »
Quote
System:    Host: steve-ThinkPad-T430 Kernel: 4.15.0-43-generic x86_64 (64 bit)
           Desktop: N/A Distro: Peppermint Eight
Machine:   System: LENOVO (portable) product: 2344BPU v: ThinkPad T430
           Mobo: LENOVO model: 2344BPU v: Win8 Pro DPK TPG
           Bios: LENOVO v: G1ETA7WW (2.67 ) date: 12/08/2014
CPU:       Dual core Intel Core i7-3520M (-HT-MCP-) cache: 4096 KB
           clock speeds: max: 3600 MHz 1: 1197 MHz 2: 1197 MHz 3: 1197 MHz
           4: 1197 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
           Card-2: NVIDIA GF108M [NVS 5400M]
           Display Server: X.Org 1.19.6 driver: nvidia
           Resolution: 1600x900@60.00hz
           GLX Renderer: NVS 5400M/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 384.130
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-43-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e
           IF: enp0s25 state: down mac: <filter>
           Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (6.6% used)
           ID-1: /dev/sda model: HGST_HTS725050A7 size: 500.1GB
Partition: ID-1: / size: 451G used: 24G (6%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 8.27GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 59.0C mobo: N/A gpu: 55C
           Fan Speeds (in rpm): cpu: 3968
Info:      Processes: 194 Uptime: 50 min Memory: 1552.7/7678.2MB
           Client: Shell (bash) inxi: 2.2.35

3
Software & Applications / Flash player projector
« on: January 12, 2019, 06:01:55 pm »
Is there a place to download Flash Projector? I downloaded the 64 bit from Adobe's website, but it just shows a blank white screen.

4
Hardware / Re: PIV OR CAC card reader
« on: April 23, 2018, 08:56:59 pm »
This is what I get, which does not appear to be a change compared to before. Still think the drivers are working thought

Code: [Select]
Mon Apr 23 23:55:17 2018
Reader 0: SCM Microsystems Inc. SCR 3310 [CCID Interface] (53311724217924) 00 00
  Card state: Card inserted,
  ATR: 3B DB 96 00 80 1F 03 00 31 C0 64 B0 F3 10 00 0F 90 00 88

ATR: 3B DB 96 00 80 1F 03 00 31 C0 64 B0 F3 10 00 0F 90 00 88
+ TS = 3B --> Direct Convention
+ T0 = DB, Y(1): 1101, K: 11 (historical bytes)
  TA(1) = 96 --> Fi=512, Di=32, 16 cycles/ETU
    250000 bits/s at 4 MHz, fMax for Fi = 5 MHz => 312500 bits/s
  TC(1) = 00 --> Extra guard time: 0
  TD(1) = 80 --> Y(i+1) = 1000, Protocol T = 0
-----
  TD(2) = 1F --> Y(i+1) = 0001, Protocol T = 15 - Global interface bytes following
-----
  TA(3) = 03 --> Clock stop: not supported - Class accepted by the card: (3G) A 5V B 3V
+ Historical bytes: 00 31 C0 64 B0 F3 10 00 0F 90 00
  Category indicator byte: 00 (compact TLV data object)
    Tag: 3, len: 1 (card service data byte)
      Card service data byte: C0
        - Application selection: by full DF name
        - Application selection: by partial DF name
        - EF.DIR and EF.ATR access services: by GET RECORD(s) command
        - Card with MF
    Tag: 6, len: 4 (pre-issuing data)
      Data: B0 F3 10 00
    Mandatory status indicator (3 last bytes)
      LCS (life card cycle): 0F (unknown)
      SW: 9000 (Normal processing.)
+ TCK = 88 (correct checksum)

Possibly identified card (using /usr/share/pcsc/smartcard_list.txt):
## ## ## ## ##...

5
Hardware / Re: PIV OR CAC card reader
« on: April 16, 2018, 08:01:19 pm »
No giving up.

I have completed these steps and I feel like everything from a hardware situation has been handled. I believe the drivers are working because the SC reader will actually light up now when plugged in or when I insert the card.This changed after installing the drivers. nothing from LSUSB has changed. Thanks for fixing all that stuff.

Sounds like the next big hurdle is downloading the certs, and I have contacted IT about this. Does that sound right. Is there a way to check if I have installed the drivers correctly? Again thanks for all the help with this guys. Super helpful.

6
Hardware / Re: PIV OR CAC card reader
« on: April 08, 2018, 12:39:13 pm »
No blame Christianvl, I obviously need a lot of hand-holding on this. So the good news is the output for the PIV card reader appears to be working. Please see below. I have taken out some of the info but it does seem to be reading. Still don't think I have successfully installed the drivers though. When I try to access Citrix it instantly says no.

Code: [Select]
steve@steve-ThinkPad-T430 ~ $ pcsc_scan
PC/SC device scanner
V 1.4.25 (c) 2001-2011, Ludovic Rousseau <ludovic.rousseau@free.fr>
Compiled with PC/SC lite version: 1.8.14
Using reader plug'n play mechanism
Scanning present readers...
0: SCM Microsystems Inc. SCR 3310 [CCID Interface] (53311724217924) 00 00

Sun Apr  8 15:37:48 2018
Reader 0: SCM Microsystems Inc. SCR 3310 [CCID Interface] (53311724217924) 00 00
  Card state: Card inserted,
  ATR: 3B DB 96 00 80 1F 03 00 31 C0 64 B0 F3 10 00 0F 90 00 88

ATR: 3B DB 96 00 80 1F 03 00 31 C0 64 B0 F3 10 00 0F 90 00 88
+ TS = 3B --> Direct Convention
+ T0 = DB, Y(1): 1101, K: 11 (historical bytes)
  TA(1) = 96 --> Fi=512, Di=32, 16 cycles/ETU
    250000 bits/s at 4 MHz, fMax for Fi = 5 MHz => 312500 bits/s
  TC(1) = 00 --> Extra guard time: 0
  TD(1) = 80 --> Y(i+1) = 1000, Protocol T = 0
-----
  TD(2) = 1F --> Y(i+1) = 0001, Protocol T = 15 - Global interface bytes following
-----
  TA(3) = 03 --> Clock stop: not supported - Class accepted by the card: (3G) A 5V B 3V
+ Historical bytes: 00 31 C0 64 B0 F3 10 00 0F 90 00
  Category indicator byte: 00 (compact TLV data object)
    Tag: 3, len: 1 (card service data byte)
      Card service data byte: C0
        - Application selection: by full DF name
        - Application selection: by partial DF name
        - EF.DIR and EF.ATR access services: by GET RECORD(s) command
        - Card with MF
    Tag: 6, len: 4 (pre-issuing data)
      Data: B0 F3 10 00
    Mandatory status indicator (3 last bytes)
      LCS (life card cycle): 0F (unknown)
      SW: 9000 (Normal processing.)
+ TCK = 88 (correct checksum)

Possibly identified card (using /usr/share/pcsc/smartcard_list.txt):

  ** here it lists the agency I work for and a number of codes**

But than...

Code: [Select]
steve@steve-ThinkPad-T430 ~ $ sudo dpkg --force-all -i safesignidentityclient_3.0.77-Ubuntu_amd64.deb
dpkg: error processing archive safesignidentityclient_3.0.77-Ubuntu_amd64.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 safesignidentityclient_3.0.77-Ubuntu_amd64.deb

That is why I am assuming I have not downloaded the driver correctly. Does that sound right. Again thanks for all the help guys.

7
Hardware / Re: PIV OR CAC card reader
« on: April 07, 2018, 12:55:42 pm »
So I have completed this.

Code: [Select]
steve@steve-ThinkPad-T430 ~ $ sudo apt-get install libpcsclite1 pcscd pcsc-tools
[sudo] password for steve:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libpcsclite1 is already the newest version (1.8.14-1ubuntu1.16.04.1).
libpcsclite1 set to manually installed.
The following packages were automatically installed and are no longer required:
  fonts-linuxlibertine linux-headers-4.4.0-101 linux-headers-4.4.0-101-generic
  linux-image-4.4.0-101-generic linux-image-extra-4.4.0-101-generic
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libccid libpcsc-perl
Suggested packages:
  pcmciautils
The following NEW packages will be installed:
  libccid libpcsc-perl pcsc-tools pcscd
0 upgraded, 4 newly installed, 0 to remove and 209 not upgraded.
Need to get 273 kB of archives.
After this operation, 928 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 libpcsc-perl amd64 1.4.14-1build1 [43.8 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 libccid amd64 1.4.22-1ubuntu0.1 [85.8 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 pcsc-tools amd64 1.4.25-1 [87.7 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 pcscd amd64 1.8.14-1ubuntu1.16.04.1 [55.7 kB]
Fetched 273 kB in 0s (892 kB/s)
Selecting previously unselected package libpcsc-perl.
(Reading database ... 351252 files and directories currently installed.)
Preparing to unpack .../libpcsc-perl_1.4.14-1build1_amd64.deb ...
Unpacking libpcsc-perl (1.4.14-1build1) ...
Selecting previously unselected package libccid.
Preparing to unpack .../libccid_1.4.22-1ubuntu0.1_amd64.deb ...
Unpacking libccid (1.4.22-1ubuntu0.1) ...
Selecting previously unselected package pcsc-tools.
Preparing to unpack .../pcsc-tools_1.4.25-1_amd64.deb ...
Unpacking pcsc-tools (1.4.25-1) ...
Selecting previously unselected package pcscd.
Preparing to unpack .../pcscd_1.8.14-1ubuntu1.16.04.1_amd64.deb ...
Unpacking pcscd (1.8.14-1ubuntu1.16.04.1) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for systemd (229-4ubuntu21.1) ...
Processing triggers for ureadahead (0.100.0-19) ...
ureadahead will be reprofiled on next reboot
Setting up libpcsc-perl (1.4.14-1build1) ...
Setting up libccid (1.4.22-1ubuntu0.1) ...
Setting up pcsc-tools (1.4.25-1) ...
Setting up pcscd (1.8.14-1ubuntu1.16.04.1) ...
Processing triggers for systemd (229-4ubuntu21.1) ...
Processing triggers for ureadahead (0.100.0-19) ...

But than hit a snag. Terminal says only root can add group, and I have no clue what that means. Moreover I got an error when trying to install the driver. Please see below, and thanks for all the help with this guys.

Code: [Select]
steve@steve-ThinkPad-T430 ~ $ addgroup scard
addgroup: Only root may add a user or group to the system.
steve@steve-ThinkPad-T430 ~ $ sudo dpkg –force-all -i safesignidentityclient_3.0.77-Ubuntu_amd64.deb
[sudo] password for steve:
dpkg: error: need an action option

Type dpkg --help for help about installing and deinstalling packages [*];
Use 'apt' or 'aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through 'less' or 'more' !

8
Hardware / Re: PIV OR CAC card reader
« on: April 05, 2018, 08:46:22 pm »
So it looks like it will read the SCR (smart card reader), but nothing when I put the CAC/PIV card in. I would imagine this means I need the coolkeys and PCSC stuff. I will install tomorrow.

I have read that CAC guide, but will definitely need some help deciphering. The first hurdle crossed though. I appreciate the help.

Code: [Select]
steve@steve-ThinkPad-T430 ~ $ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 04f2:b2db Chicony Electronics Co., Ltd
Bus 001 Device 004: ID 0a5c:21e6 Broadcom Corp. BCM20702 Bluetooth 4.0 [ThinkPad]
Bus 001 Device 003: ID 147e:2020 Upek TouchChip Fingerprint Coprocessor (WBF advanced mode)
Bus 001 Device 007: ID 04e6:5116 SCM Microsystems, Inc. SCR331-LC1 / SCR3310 SmartCard Reader
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

9
Hardware / Re: PIV OR CAC card reader
« on: April 04, 2018, 07:54:04 pm »
Code: [Select]
steve@steve-ThinkPad-T430 ~ $ inxi -Fz
System:    Host: steve-ThinkPad-T430 Kernel: 4.13.0-32-generic x86_64 (64 bit)
           Desktop: N/A Distro: Peppermint Eight
Machine:   System: LENOVO (portable) product: 2344BPU v: ThinkPad T430
           Mobo: LENOVO model: 2344BPU v: Win8 Pro DPK TPG
           Bios: LENOVO v: G1ETA7WW (2.67 ) date: 12/08/2014
CPU:       Dual core Intel Core i7-3520M (-HT-MCP-) cache: 4096 KB
           clock speeds: max: 3600 MHz 1: 2893 MHz 2: 2893 MHz 3: 2893 MHz
           4: 2893 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
           Card-2: NVIDIA GF108M [NVS 5400M]
           Display Server: X.Org 1.19.5 driver: nvidia
           Resolution: 1600x900@60.00hz
           GLX Renderer: NVS 5400M/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 384.111
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.13.0-32-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e
           IF: enp0s25 state: down mac: <filter>
           Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (4.3% used)
           ID-1: /dev/sda model: HGST_HTS725050A7 size: 500.1GB
Partition: ID-1: / size: 451G used: 13G (3%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 8.27GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 63.0C mobo: N/A gpu: 59C
           Fan Speeds (in rpm): cpu: 3994
Info:      Processes: 197 Uptime: 1:07 Memory: 1386.6/7678.5MB
           Client: Shell (bash) inxi: 2.2.35

10
Hardware / PIV OR CAC card reader
« on: April 04, 2018, 07:50:21 pm »
Trying to use the Citrix App in Chromium for remote access at work, but need a PIV or CAC card reader installed first. Anyone been success with this? Plugging to the USB does nothing right now.

11
Software & Applications / Another Steam Error
« on: February 17, 2018, 06:49:16 am »
Ok, have been having issues with Steam on playonlinux, now through the software manager. I get the message below when just using Steam without playonlinux.  Can I not have both?

"Couldn't set up Steam data - please contact technical support"

Code: [Select]
steve@steve-ThinkPad-T430 ~ $ inxi -Fz
System:    Host: steve-ThinkPad-T430 Kernel: 4.13.0-32-generic x86_64 (64 bit)
           Desktop: N/A Distro: Peppermint Eight
Machine:   System: LENOVO (portable) product: 2344BPU v: ThinkPad T430
           Mobo: LENOVO model: 2344BPU v: Win8 Pro DPK TPG
           Bios: LENOVO v: G1ETA7WW (2.67 ) date: 12/08/2014
CPU:       Dual core Intel Core i7-3520M (-HT-MCP-) cache: 4096 KB
           clock speeds: max: 3600 MHz 1: 2893 MHz 2: 2893 MHz 3: 2893 MHz
           4: 2893 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
           Card-2: NVIDIA GF108M [NVS 5400M]
           Display Server: X.Org 1.19.5 driver: nvidia
           Resolution: 1600x900@60.00hz
           GLX Renderer: NVS 5400M/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 384.111
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.13.0-32-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e
           IF: enp0s25 state: down mac: <filter>
           Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (4.3% used)
           ID-1: /dev/sda model: HGST_HTS725050A7 size: 500.1GB
Partition: ID-1: / size: 451G used: 13G (3%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 8.27GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 63.0C mobo: N/A gpu: 59C
           Fan Speeds (in rpm): cpu: 3994
Info:      Processes: 197 Uptime: 1:07 Memory: 1386.6/7678.5MB
           Client: Shell (bash) inxi: 2.2.35

12
Software & Applications / Re: Steam pictures will not load
« on: February 08, 2018, 07:03:01 pm »
So this seems like a verison or a "staging" issue. I found this video online but 2.0 staging has not been woring either. Has anyone else has this issue?

https://www.youtube.com/watch?v=CkB9de90sbc&t=700s

13
Software & Applications / Re: Steam pictures will not load
« on: February 06, 2018, 06:55:43 pm »
I added it through playonlinux. I am gonna use the sudo command and see if that changes anything.

How would I go about using the command line?

14
Software & Applications / Steam pictures will not load
« on: February 05, 2018, 08:15:58 pm »
I am running Steam on Playon Linux, but the pictures will not load. I received an error message about not having enough memory, but I had playonlinux working fine with 07 on the same machine.

Code: [Select]
steve@steve-ThinkPad-T430 ~ $ inxi -Fz
System:    Host: steve-ThinkPad-T430 Kernel: 4.13.0-32-generic x86_64 (64 bit)
           Desktop: N/A Distro: Peppermint Eight
Machine:   System: LENOVO (portable) product: 2344BPU v: ThinkPad T430
           Mobo: LENOVO model: 2344BPU v: Win8 Pro DPK TPG
           Bios: LENOVO v: G1ETA7WW (2.67 ) date: 12/08/2014
CPU:       Dual core Intel Core i7-3520M (-HT-MCP-) cache: 4096 KB
           clock speeds: max: 3600 MHz 1: 2893 MHz 2: 2893 MHz 3: 2893 MHz
           4: 2893 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
           Card-2: NVIDIA GF108M [NVS 5400M]
           Display Server: X.Org 1.19.5 driver: nvidia
           Resolution: 1600x900@60.00hz
           GLX Renderer: NVS 5400M/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 384.111
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.13.0-32-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e
           IF: enp0s25 state: down mac: <filter>
           Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (3.6% used)
           ID-1: /dev/sda model: HGST_HTS725050A7 size: 500.1GB
Partition: ID-1: / size: 451G used: 9.4G (3%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 8.27GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 57.0C mobo: N/A gpu: 53C
           Fan Speeds (in rpm): cpu: 3785
Info:      Processes: 207 Uptime: 1:54 Memory: 1231.2/7678.5MB
           Client: Shell (bash) inxi: 2.2.35

15
Hardware / Re: Battery Won't Charge
« on: January 30, 2018, 06:05:48 pm »
Code: [Select]
Battery 0: Unknown, 0%
Adapter 0: on-line
Thermal 0: ok, 55.0 degrees C
Thermal 0: trip point 0 switches to mode critical at temperature 200.0 degrees C
Cooling 0: Processor 0 of 10
Cooling 1: Processor 0 of 10
Cooling 2: LCD 0 of 15
Cooling 3: intel_powerclamp no state information available
Cooling 4: Processor 0 of 10
Cooling 5: Processor 0 of 10
Cooling 6: LCD 0 of 15
Cooling 7: x86_pkg_temp no state information available

Is the ACPI -V output

Pages: [1] 2 3