Peppermint OS

Support => Hardware => Topic started by: demag on June 27, 2020, 04:10:40 pm

Title: New Ryzen system problem (Solved)
Post by: demag on June 27, 2020, 04:10:40 pm
Firstly my deepest condolences for PCNETSPECS sad passing, I only found out very recently.

I just built a new system with MSI Tomahawk Max B450 mb. Ryzen 5 3600 and 16g ram.
My old system was Gigabyte mb. AMD FX8350 and 16g ram which ran in Legacy and booted with Grub 2.
I had 3 x Peppermint hdds (8,9 and 10!) and one Win 10 hdd.
My problem I can't boot into anything on the new system but bios can see the hdds.
I eventually put a new Win10 install on a NVME drive that I fitted just to get something up and running.
I can see other hdds in Windows disk manager.
I tried to install Peppermint 10 on a blank hdd but the the dvd was ignored and the system booted straight into the new Win10 install.
I've read articles where Linux is installed on these boards but can't find out how to do it.
Any help would be greatly appreciated.
Thanks. :-\
Title: Re: New Ryzen system problem
Post by: murraymint on June 28, 2020, 01:33:52 am
I don't think it's normally possible to boot a DVD on a UEFI system. Try a USB stick or see here:
Title: Re: New Ryzen system problem
Post by: demag on June 28, 2020, 03:13:43 am
Ooh thanks murraymint it's all slowly making sense now. I'll have another look later, wifey will kill me if I start messing now. :P
Looking on web I found Rufus and an interesting project called LinuxBoot.
Title: Re: New Ryzen system problem
Post by: Bear on June 28, 2020, 08:30:26 am
If you've a running Windows system then Rufus is a very easy tool to build yourself a bootable USB stick from an ISO image. Watch out for a UEFI trying to enforce Secure Boot (see the Rufus website for more information).
Title: Re: New Ryzen system problem
Post by: demag on June 29, 2020, 03:25:20 pm
Well I've been fighting this for three days now. I also asked on the MSI forum but got no replies from there. It doesn't matter what I try I can't get anything to boot or install apart from that Win 10 on the nvme drive.

Since my last post I have also noticed my internet is crawling, download speed about 1.5Mbps (should be 64) I did a search and found others having similar problems. There was a bios update to cure this but many people are still having trouble and are having to jump through hoops to speed it up. Just to prove to myself it wasn't my internet playing up I did an Ookla speed test with my phone over wifi and got 51.64Mbps, not a bad difference.
I have contacted the retailer for a returns note as this board is next to useless for me and I've ordered a Gigabyte Aorus Pro B450 board which hopefully will be better.

I remember on my old AM3+ system which I built many years ago I tried an Asus board. It was a real pig to set up then an Asrock which was better but not easy by any means and some years later I once again rebuilt it with a Gigabyte board which was just plain sailing and when I switched it on it just worked, I had to do some fine tuning but it was never a problem. It wasn't as cutting edge as the Asus or Asrock but I could do everything I needed.

Hopefully the new board will be here tomorrow so I'll keep you updated.
Title: Re: New Ryzen system problem
Post by: demag on June 30, 2020, 04:14:31 pm
I am cautiously going to say "good news" :). The Gigabyte board arrived today so I stripped the MSI out and installed it. I connected it to a few of my drives and booted but nothing doing, however this was early days as all I'd really done was set the bios to Legacy.

I connected the cd rom, fitted a spare (old) 80gig drive and tried booting into a live Peppermint session. Success! :D I just flicked around and everything appeared to be working so went for an install, another success :D ;D so I updated grub then turned off and fitted my old 2tb Win 10 drive. Booted and did another grub update, restarted and I'd got my old Win10 back. I tried a couple of games and noticed everything running a lot cooler and fps through the roof.

I also did an internet speed test and I'm back up to full speed 60+ Mbps.

Well I think I've learned my lesson, stick with Gigabyte ;D
Title: Re: New Ryzen system problem (Solved)
Post by: Slim.Fatz on June 30, 2020, 11:47:15 pm
Hi demag,

Glad to hear that you resolved your issue (unfortunately, at some expen$e to you  >:( ). And thank you for marking this thread as (Solved).  8)


-- Slim