Peppermint OS

Support => New Users => Topic started by: lliam53 on May 06, 2020, 01:50:00 am

Title: Dual boot with W10, prevent grub SOLVED
Post by: lliam53 on May 06, 2020, 01:50:00 am
Now I have some [very positive] experience with P10 on an old machine  ;D I have dcided to replace the Linux Mint I installed  as dual boot with W10 on my main machine with P10. During the set up of this dual boot I found [after much trial and re-installation] that W10 would not restart correctly to finish updates and or new software intalls if a grub was invoked during reboot. I have therfore managed to remove the grub that Mint had created [renewd the windows mbr] and made a separate grub on a flash drive [super_grub2]. This way when I restart the W10 I leave out the flash drive and W10 [completly blind to the Linux system] restarts without a hitch. In order to use my Linux [Mint] OS I simply insert the flash drive and I get the grub OS choice [which includes W10]. How can I prevent the grub being created during the P10 installation on this dual boot machine? I am sure that the super grub flash drive will function as before.

Thanks again!
Title: Re: Dual boot with W10, prevent grub
Post by: Slim.Fatz on May 06, 2020, 03:45:02 am
Hi straybit,

OK, the answer is: you don't prevent it -- however, you install grub in a location that does not cause problems. So assume that your Peppermint 10 installation is going on /dev/sda6 (replace this with the actual value for your machine, of course). Then, during the installation you get asked where grub should be installed. Do not select /dev/sda but instead use /dev/sda6. That way grub will not be in the way of your M$ boot process.

I have never used super_grub2, but if your machine has two USB ports, then during the installation of Peppermint 10 you could also have the super_grub2 flash drive plugged in and select it as the location to install grub (rather than /dev/sda6). Alternatively, you could probably also remake your super_grub2 flash drive the way you did for Linux Mint only use the Peppermint 10 grub (if that makes any sense).

Regards,

-- Slim
Title: Re: Dual boot with W10, prevent grub
Post by: alynur on May 06, 2020, 05:22:31 am
Hi  lliam53, so when you first start up your computer, you are presented with grub where you can select either W10 or Mint, correct? If you don't select anything, what os will automatically boot up?

edit; I am refering to before you deleted grub and made your grub-2 usb stick.
Title: Re: Dual boot with W10, prevent grub
Post by: Slim.Fatz on May 06, 2020, 05:24:52 am
Hi alynur,

No! He does not see the grub menu (except for the case where he uses the super_grub2 flash drive) but is dumped straight into M$ Windoze (as I understand him).

Regards,

-- Slim
Title: Re: Dual boot with W10, prevent grub
Post by: lliam53 on May 07, 2020, 01:40:07 am
Hey Slim and Alynur, thanks for your input. Just to be clear on my 'grub situation' with my dual boot with LMint and W10. After finishing the LMint installation my machine booted to the LMint grub which gave me the choice between LMint and W10. This would be fine in itself were it not for the fact that W10 can not cope with this interuption to a reboot required by [software] updates. The LMint grub I had was OK but needed to be 'out of the loop' for W10. The grub was such that if I did nothing then LMint would start as first. The supergrub I have on my flash drive presents first with a menu for various options [div analyses, partitioning etc.] AND the option to 'reveal' boot options, only then can I make a choice, Lynux is always top of the list [of previous versions before updates?] with Windows down the bottom.
Without the flash drive present the windows mbr takes command and W10 starts up, which is fine by me, and is the situation I wish to maintain after P10 installation. I shall be trying the P10 installation in the coming days and shall take Slims advice to redirect the grub to a different location. I suppose I could try installing to another flash drive even... I shall keep you posted. As it may take some time for me to get round to this should I post this question as SOLVED and come back after my installation?

Thanks again, lliam
Title: Re: Dual boot with W10, prevent grub
Post by: Slim.Fatz on May 07, 2020, 05:18:49 am
Hi lliam53,

You can leave the issue as is because it is really not solved yet (as I see it), but the choice is yours.  ;)

Regards,

-- Slim
Title: Re: Dual boot with W10, prevent grub
Post by: jlschwartz on May 07, 2020, 07:22:30 am
If your system defaults to Peppermint in the grub menu, you change that so it defaults to windows and you need to select Peppermint.  That way updates just work automatically.  The grub menu times out and then starts windows.  That's what I have done for years and it works fine.
Title: Re: Dual boot with W10, prevent grub
Post by: murraymint on May 07, 2020, 07:23:44 am
No, they seem to be saying that Winders won't play nice with Grub any more.
Title: Re: Dual boot with W10, prevent grub
Post by: spence on May 07, 2020, 09:45:01 am
Traditionally one installs Win10 first, uses windows tools to shave the partitons to allow space for whatever other linux distros of one's choosing. Last time I installed Win10 was this time last year on this little mini asus.

I have been ensuring that I was installing via GPT instead of MBR which would theoretically allow an infinite number of subsequent partitions.
While whatever version of Winblows one wants to also work with must be installed first, keep in mind that the linux distro one wants to be default, must be the last distro installed.

I also used to install as Legacy Mode, but @VinDSL's example led me to choose UEFI mode on my last several installations ... I have never successfully dual booted with Secure Boot enabled though.

All that said, it seems my fellow devs are saying recent Win10 updates make this more difficult than ever...


 :-X
Title: Re: Dual boot with W10, prevent grub
Post by: alynur on May 07, 2020, 12:00:32 pm
No, they seem to be saying that Winders won't play nice with Grub any more.


I think lliam53 doesn't know how to change the default boot order in grub, which is why I asked and jlschwartz mentioned. That may be all of his problem. I know there was a discussion in another post about windows update hiding grub altogether but at this point the OP has not indicated that. I would suggest that he, the OP, boot into Peppermint, if he has it installed, and run sudo install-grub /dev/sdx and see what happens. If he gets a grub menu, he can change the default boot order as jlshwartz has suggested.
Title: Re: Dual boot with W10, prevent grub
Post by: VinDSL on May 07, 2020, 01:33:14 pm
Don't know if this will help, but... maybe: https://is.gd/Nkc8WX   :)







Title: Re: Dual boot with W10, prevent grub
Post by: lliam53 on May 08, 2020, 01:39:37 am
It would appear my question has spawned some interesting discussion. I am confident in my conclusion that [my present version: Prof, of] W10 in it's present [complete] update state just can not be trusted to cope with any form of interuption [so anything other than the windows mbr] to the update-reboot processes. That in itself is enough for me to stick with my supergrub flash drive option. I have no wish to start down a road of grub editing, which could leave me with an unresponsive system if I make a mistake, so I shall be sticking to Slims advice. It is true to say that I have not taken the trouble to learn how to change the grub order, probably because I see no real reason to, being given a choice is enough for me. I shall leave the post as it is for now. Thank you for all the input   lliam53
Title: Re: Dual boot with W10, prevent grub
Post by: clatterfordslim on May 08, 2020, 07:06:13 pm
The latest version of W10, with April 2020 updates is causing grub not to read the W10 partition. Simply put this update is a big security one, also unable to transfer files from Linux partition over to W10, even as root. There is another big update coming this month too, not sure if it involves more security or not. I have icy dock configuration on my computers, so just I take out W10 when not gaming, plus my bios enables me to control which hard drive to boot first. I have Peppermint 10 re-spin booting first, plus it accommodates two 1TB drives, one the main system the other my home folder. Am in the process of getting 2TB SSD for home drive. All the things I collect within Linux and making backups of the info I collect, am slowly running out of room. So will have to take time to double backup backups to my dropbox account with 2TB of space that I'm paying £95.00 British pounds for a year, with hardly the time to use it.  Icy docks are fantastic if you have enough SATA ports on your motherboard? Plus the fact SSD's hardly need any power to run. I feel sorry for people with only a limited amount of space on their hardware, especially where dual booting is concerned on the same drive and as of now W10 has gotten more secure as in Linux grub not able to read the W10 partition at all, though I'm sure there is a way to switch off all the security in W10, but to what end, making you vulnerable to all and sundry.  :(
Title: Re: Dual boot with W10, prevent grub
Post by: tjloman on May 09, 2020, 06:13:20 pm
Might not be feasible for some, but here's how my boot works: If I press nothing, it boots from /dev/sda1 (with the Windows loader, so it will go straight there). By pressing f12 during the BIOS screen (Varies by motherboard mfg, usually labeled - boot options) and then I select a second hard drive, which contains GRUB, to boot into Linux. :) :)
Title: Re: Dual boot with W10, prevent grub
Post by: lliam53 on May 10, 2020, 07:58:38 am
Well here's the story so far: after doing a thoro survey of my system to be absolutely sure where the [to be removed] liuxMINT partition was I made a start with the P10 installation. Downloaded the 64bit version and made my USB drive, all ready to go. Rebooted with the flash drive and went straight to 'Install' .  Choosing the option 'something else' I entered the menu: Choosing the boot location is simple so then I went for it 'install'. That's when all the new stuff starts. I get the remark 'root' not defined [or such] 'must be taken care of in the partition menu' trying various options when I passed thru a menu where there was a drop down from a window with 'do not use this partition' I chose /boot [root is not mentioned][or was there a list with EXT4 'sometypeorother' ?]. Install went forward but tripped and stopped, I am now back in the 'live session' off the usb drive and /now the whole installation option just fails as soon as I pass the 'normal installation' choices menu. I get 'ubi partman failed with exit code 10, further info MAY be found in /var/log/syslog'... wherever that may be. It would apear that some partition action has been started and broken off which has now 'messed' up the whole process. I am going to look at cleaning up the whole MINT partition with gparted and starting again. Nevertheless I expect to get that 'where must the root go' question again which i see no way of answering without going into the installation-partition option which warns met that a new partition table will erase everything on my SSD where my windows partion also resides, so thats a no go.

Before you can do something you must first do [learn]something else

IN ADDITION: Gparted refuses to do anything with the partition as it is 'busy'. Reboot back to W10 [so no flash drive present] is still OK so I can be gratefull for that I suppose. I shall carry on after another reboot via the P10 flash drive.....

PS should anyone have emailed me, I had miss-spelled my email adress, sorry for that... :'( corrected it now
Title: Re: Dual boot with W10, prevent grub
Post by: Bear on May 10, 2020, 08:13:03 am
Out of curiosity I installed some optional Win10 updates yesterday on my dual-boot machine. When it came to restart Windows it went into the BIOS as usual and came up with the grub boot options. All I had to do was a few down-arrows then Enter to select Windows as normal. Windows then completed it's updates and all seems well.
Title: Re: Dual boot with W10, prevent grub
Post by: Slim.Fatz on May 10, 2020, 09:18:20 am
Hi lliam53,

You are correct: "root" is not listed in that drop down but rather the linux short form "/" is listed and is where the system files all get installed. Just like "~" is the short form for "/home/<username>" you need to remember that "/" is short for "root".  ;)

 
As long as you only select the partition(s) on which you wish to install PepperminOS (and, in your case you only need the one that will then become your "/" partition) then only that selected partition will be erased. I suggest using the ext4 file system. You do not need a swap partition as the installation program will set up a swap file when no swap partition is found or when you do not specify that one should be created.  8)

 
Gparted will not operate on partitions that are mounted! You must unmount any partition that you want to change with gparted (or not mount it in the first place) and then gparted can be used to do various things to that partition.  ;)

Regards,

-- Slim
Title: Re: Dual boot with W10, prevent grub
Post by: cavy on May 10, 2020, 09:27:52 am
Hi lliam53,

Please boot into PMOS10 live environment with your usb stick.

Then run these commands in a terminal, separately, also press the enter twice after each printout, this will aid you, with a less cluttered view, to read each printout.

Code: [Select]
[ -d /sys/firmware/efi ] && echo "Installed in UEFI mode" || echo "Installed in Legacy mode"
Code: [Select]
sudo efibootmgr -v
Code: [Select]
inxi -Fxz
Code: [Select]
inxi -p
When placing each command printout into the reply box, right click your mouse and cover each printout separately, then click the # symbol. This maintain the integrity of printout for legibility purposes, as it would appear in the terminal.

Is it your intention to retrain windies...?

regards cavy   :D
Title: Re: Dual boot with W10, prevent grub
Post by: Slim.Fatz on May 10, 2020, 09:45:03 am

Is it your intention to retrain windies...?

regards cavy   :D



Only if he has already trained windies -- otherwise, probably not ...  :D 


Regards,


-- Slim
Title: Re: Dual boot with W10, prevent grub
Post by: clatterfordslim on May 10, 2020, 08:38:53 pm
Out of curiosity I installed some optional Win10 updates yesterday on my dual-boot machine. When it came to restart Windows it went into the BIOS as usual and came up with the grub boot options. All I had to do was a few down-arrows then Enter to select Windows as normal. Windows then completed it's updates and all seems well.

I installed W10 home international ISO maybe there is a difference between this and normal? Still security is not a bad thing.  ;D
Title: Re: Dual boot with W10, prevent grub
Post by: lliam53 on May 11, 2020, 07:54:24 am
Well here I can now report success in installing P10. I decided to remake my flash drive on a newer usb stick, just in case.. that after verifying my iso [again = OK]. Once more went thru the install menu's [something else] choosing to set the partition to EXT4 journalling.. and putting / in the mount field, and of course setting the boot to the same partition as my install. I had chosen not to install the downloads at the same time but accept third party drivers. Long story short, it has all worked out: W10 still boots preferentially when my Grub drive is not present and I get the grub choice menu when it is. Lo and behold! The MINT boot is also present [?] and Mint actually still runs! I was absolutely certain that I had formatted the partition it was on [Gparted] AND installed P10 [with another format] onto the same partition! I can only assume that Mint had installed itself onto another of the disks present in my machine as apposed to the SSD OR both Gparted and P10 will not 'damage' another brother Linux version and P10 ended up installed alongside. I shall be looking into that at a later date. For now my initial question is answered, so I shall be posting this a SOLVED tomorrow... Thanks for the input     lliam
Title: Re: Dual boot with W10, prevent grub
Post by: Slim.Fatz on May 11, 2020, 09:41:19 am
Hi lliam53,

Great news !! And congratulations too.  8)


As far as having installed PeppermintOS and still having your Mint installation: they must be on separate partitions because they will not work together in the same partition (same drive, yes; but not in the same partition). In fact, I don't even think that it's possible to install one in the other's partition without eliminating the original occupant.  ;) ;D


Regards,

-- Slim
Title: Re: Dual boot with W10, prevent grub
Post by: lliam53 on May 12, 2020, 02:35:24 am
As a final report on this matter I can say that peppermint is up and running and behaving perfectly. The whole boot procedure is AOK using my superGrub flash drive, or not [straight into W10]. Transpires that the Mint I had installed previously had nestled itself on another HDD partition on another drive on my system and not to my SSD where P10 now resides [in its own partition], so that's still here too. For the moment this post can be considered as SOLVED. Once more thanks to one and all for the input and good advice, particularly Slim  [/ means root is a good one....] If all goes well I hope to ween off Windows.....

lliam signing off for now.
Title: Re: Dual boot with W10, prevent grub
Post by: clatterfordslim on May 12, 2020, 07:42:27 am
If all goes well I hope to ween off Windows.....



I've only got W10 for gaming on if I did not have to keep tweaking Pep to play not just the latest, but nearly all of my Winders games, then I would not have bothered with W10. So pleased everything worked out, welcome to the world of Peppermint.  ;D
Title: Re: Dual boot with W10, prevent grub SOLVED
Post by: alynur on May 12, 2020, 02:24:24 pm
Hi lliam53, glad you got it working. Just out of curiousity, could you post a photo of your hard drive setup as shown in gparted?