Peppermint OS Community Forum

Support => Hardware => Topic started by: susan365 on September 05, 2014, 08:49:39 am

Title: I tried to open my downloaded driver,message dependency not satisfied [SOLVED]
Post by: susan365 on September 05, 2014, 08:49:39 am
When I went to open the downloaded driver I got a message

ERROR: Dependency is not satisfiable: lsb(>=3.2)

in the description it says:
This product supports only EPSON ESC/P-R printers. This package can be used for all EPSON ESC/P-R printers.
For detail list of supported printer, please refer to below site: http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
(Converted from a rpm package by alien version 8.79ubuntu0.1.)


It also says this:
No lintian available.
Please install using sudo apt-get install lintian

any suggestions,
Thanks again, Susan
Title: Re: I tried to open my downloaded driver but message says dependency not satisfied
Post by: PCNetSpec on September 05, 2014, 10:35:36 am
Which printer model are we talking about here ?

and what's the output from:
Code: [Select]
uname -a
Title: Re: I tried to open my downloaded driver but message says dependency not satisfied
Post by: susan365 on September 05, 2014, 02:58:44 pm
susan@st779 ~ $ uname -a
Linux st779 3.13.0-30-generic #55-Ubuntu SMP Fri Jul 4 21:43:42 UTC 2014 i686 i686 i686 GNU/Linux

Epson Stylus NX430
Title: Re: I tried to open my downloaded driver but message says dependency not satisfied
Post by: PCNetSpec on September 05, 2014, 06:47:18 pm
I've uploaded the drivers you'll require to my dropbox because it's hard to directly link to them on the Epson website.

Open a terminal and run these commands in sequence:
Code: [Select]
mkdir ~/Epson-Drivers
then
Code: [Select]
cd ~/Epson-Drivers
then
Code: [Select]
wget https://dl.dropboxusercontent.com/u/11876059/NX430.tar.gz
then
Code: [Select]
tar xvf NX430.tar.gz
then
Code: [Select]
cd ~/Epson-Drivers/NX430
then
Code: [Select]
sudo dpkg -i epson-inkjet-printer-201105w_1.0.0-1lsb3.2_i386.deb
When that's done, go to

menu > System Tools > Printers

and click the "+Add" button

Hopefully your printer will be detected.

When asked to select a driver, select

Espon >  NX430 TX435 > Epson NX430 TX435 Series - epson-inkjet-printer 1.0.0-1lsb3.2 (Seiko blah blah blah)




Keep those drivers (as I'll probably remove them from my dropbox eventually) and let me know if you need further assistance .. such as for the scanner.



For reference, the archive in my dropbox contains these packages:-

epson-inkjet-printer-escpr_1.4.1-1lsb3.2_i386.deb
epson-inkjet-printer-201105w_1.0.0-1lsb3.2_i386.deb
iscan_2.29.3-1~usb0.1.ltdl7_i386.deb
iscan-data_1.29.0-2_all.deb
iscan-network-nt_1.1.1-1_i386.deb


The above instructions only install the one in red .. the others are there "just in case".
Title: Re: I tried to open my downloaded driver but message says dependency not satisfied
Post by: susan365 on September 06, 2014, 07:26:36 am
Thanks so much for your help

I got this far then another error message popped up

susan@st779 ~/Epson-Drivers/NX430 $ sudo dpkg -i epson-inkjet-printer-201105w_1.0.0-1lsb3.2_i386.deb
[sudo] password for susan:
Selecting previously unselected package epson-inkjet-printer-201105w.
(Reading database ... 188966 files and directories currently installed.)
Preparing to unpack epson-inkjet-printer-201105w_1.0.0-1lsb3.2_i386.deb ...
Unpacking epson-inkjet-printer-201105w (1.0.0-1lsb3.2) ...
dpkg: dependency problems prevent configuration of epson-inkjet-printer-201105w:
 epson-inkjet-printer-201105w depends on lsb (>= 3.2); however:
  Package lsb is not installed.

dpkg: error processing package epson-inkjet-printer-201105w (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 epson-inkjet-printer-201105w
Title: Re: I tried to open my downloaded driver but message says dependency not satisfied
Post by: PCNetSpec on September 06, 2014, 07:43:14 am
OK,let's try manually installing lsb first
Code: [Select]
sudo apt install lsb
If that runs without error, run:
Code: [Select]
pcmanfm ~/Epson-Drivers/NX430
and in the resulting file manager window .. double-click the "epson-inkjet-printer-201105w_1.0.0-1lsb3.2_i386.deb" file to install.

Any errors post them here.
Title: Re: I tried to open my downloaded driver but message says dependency not satisfied
Post by: susan365 on September 06, 2014, 08:10:36 am
This what I get:

susan@st779 ~/Epson-Drivers/NX430 $ sudo apt install lsb
[sudo] password for susan:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package lsb is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'lsb' has no installation candidate
Title: Re: I tried to open my downloaded driver but message says dependency not satisfied
Post by: PCNetSpec on September 06, 2014, 08:17:59 am
Run:
Code: [Select]
sudo apt update
then try again with:
Code: [Select]
sudo apt install lsb
if that works, run:
Code: [Select]
sudo dpkg --configure -a
if it doesn't work, run:
Code: [Select]
gedit /etc/apt/sources.list
and post the contents of the file that opens
Title: Re: I tried to open my downloaded driver but message says dependency not satisfied
Post by: susan365 on September 06, 2014, 10:36:23 am
it did not work so here is the post from gedit

# deb cdrom:[Peppermint 5 _Five_ - Release i386 (20140617.2)]/ trusty main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://us.archive.ubuntu.com/ubuntu/ trusty restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty universe
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ trusty-backports restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-backports restricted universe multiverse

deb http://security.ubuntu.com/ubuntu trusty-security restricted
deb-src http://security.ubuntu.com/ubuntu trusty-security restricted
deb http://security.ubuntu.com/ubuntu trusty-security universe
deb-src http://security.ubuntu.com/ubuntu trusty-security universe
deb http://security.ubuntu.com/ubuntu trusty-security multiverse
deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu trusty partner
# deb-src http://archive.canonical.com/ubuntu trusty partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu trusty main
deb-src http://extras.ubuntu.com/ubuntu trusty main
Title: Re: I tried to open my downloaded driver but message says dependency not satisfied
Post by: PCNetSpec on September 06, 2014, 11:27:29 am
Well that's just plain odd .. you're sources list is missing the "main" section from 6 lines

First let's backup your sources.list:
Code: [Select]
sudo cp -v /etc/apt/sources.list /etc/apt/sources.list.bak
now open sources.list for editing:
Code: [Select]
sudo gedit /etc/apt/sources.list
and add in the 6 "main" entries I've highlighted below:-

Quote
# deb cdrom:[Peppermint 5 _Five_ - Release i386 (20140617.2)]/ trusty main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://us.archive.ubuntu.com/ubuntu/ trusty main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty universe
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ trusty-backports restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-backports restricted universe multiverse

deb http://security.ubuntu.com/ubuntu trusty-security main restricted
deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
deb http://security.ubuntu.com/ubuntu trusty-security universe
deb-src http://security.ubuntu.com/ubuntu trusty-security universe
deb http://security.ubuntu.com/ubuntu trusty-security multiverse
deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu trusty partner
# deb-src http://archive.canonical.com/ubuntu trusty partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu trusty main
deb-src http://extras.ubuntu.com/ubuntu trusty main

Once added, SAVE the file and exit gedit.

Back in the terminal run:
Code: [Select]
sudo apt update
and if there are any errors, post them here.

If there are no errors, run:
Code: [Select]
sudo apt install lsb
did it work this time ?
Title: Re: I tried to open my downloaded driver but message says dependency not satisfied
Post by: susan365 on September 06, 2014, 01:11:22 pm
it said it was a read only file
Title: Re: I tried to open my downloaded driver but message says dependency not satisfied
Post by: PCNetSpec on September 06, 2014, 01:25:37 pm
Sorry, I missed "gedit" out of the second command .. fixed above now  :-[
(that command will open it in gedit with read/write privileges)
Title: Re: I tried to open my downloaded driver but message says dependency not satisfied
Post by: susan365 on September 06, 2014, 01:39:57 pm
I did the update and got this message

susan@st779 ~ $ sudo apt install lsb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 lsb : Depends: lsb-core (>= 4.1+Debian11ubuntu6) but it is not going to be installed
       Depends: lsb-graphics (>= 4.1+Debian11ubuntu6) but it is not going to be installed
       Depends: lsb-cxx (>= 4.1+Debian11ubuntu6) but it is not going to be installed
       Depends: lsb-desktop (>= 4.1+Debian11ubuntu6) but it is not going to be installed
       Depends: lsb-printing (>= 4.1+Debian11ubuntu6) but it is not going to be installed
       Depends: lsb-languages (>= 4.1+Debian11ubuntu6) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Title: Re: I tried to open my downloaded driver but message says dependency not satisfied
Post by: PCNetSpec on September 06, 2014, 02:18:35 pm
run:
Code: [Select]
sudo apt-get -f install
then if that comletes without error .. try installing the printer driver by double-clicking the epson-inkjet-printer-201105w_1.0.0-1lsb3.2_i386.deb file.
Title: Re: I tried to open my downloaded driver but message says dependency not satisfied
Post by: susan365 on September 06, 2014, 02:39:41 pm
SUCCESS !!! :D

Thank you, Thank you, Thank you

Susan
Title: Re: I tried to open my downloaded driver,message dependency not satisfied [SOLVED]
Post by: PCNetSpec on September 06, 2014, 03:18:45 pm
You're most welcome :)

Thanks for marking the topic solved.