Peppermint OS Community Forum

Support => Networking => Topic started by: fufu930 on November 23, 2019, 01:30:40 am

Title: Report - Devices woudn't connect to a Hotspot
Post by: fufu930 on November 23, 2019, 01:30:40 am
I always have to install dnsmasq to make my hotspot working

Otherwise all my devices get stuck on obtaining IP address

(Latest peppermint)
Title: Re: Report - Devices woudn't connect to a Hotspot
Post by: Slim.Fatz on November 23, 2019, 07:49:41 am
Hi fufu930,

Is this a tip for others to use, or an issue that you need resolved?  :-\

Regards,

-- Slim
Title: Re: Report - Devices woudn't connect to a Hotspot
Post by: PCNetSpec on November 23, 2019, 09:25:31 am
Hi fufu930, and welcome to the forum :)

Are you using the Peppermint PC **as** the hotspot .. or connecting the Peppermint PC **to** a hotspot ?
(I'm guessing the former, but just wanna be sure)

You are right, dnsmasq-utils and dnamasq-base are packages we remove in Peppermint (that are default OOTB in Ubuntu) to keep the footprint small .. most people won't use them, and it seemes a bit inefficient to be constantly running a DNS proxy and DHCP/TFTP server when most people wouldn't require it ;)
(IIRC Lubuntu also removes those packages)

Sure, we could have all the services Ubuntu has running OOTB, but then we'd be pretty much as resource heavy .. so we trim the ones (that will be run as a service/daemon) that very few people will ever use .. it's all part of the Peppermint 'secret sauce' ;)

Thanks for the note though .. it may be helpful to others wanting to set up their Peppermint PC as a hotspot :)
Title: Re: Report - Devices woudn't connect to a Hotspot
Post by: fufu930 on January 21, 2020, 07:11:52 am
Hello,

I use my Peppermint PC  as the hotspot

It`s a tip, because it`s fine after installing the package

I understand. Thanks!
Title: Re: Report - Devices woudn't connect to a Hotspot
Post by: Slim.Fatz on January 21, 2020, 01:51:48 pm
Hi fufu930,

Thanks for the clarification! This could be useful to know for others having your initial issue. In fact, it might have been better to have posted this in the forum section titled User Submitted Tutorials. Perhaps you could go back to your initial post and edit the Subject line to read: Tip: when devices do not connect to a Hotspot.  ;)


Regards,

-- Slim