Peppermint OS Community Forum

Support => Installation => Topic started by: alynur on November 15, 2019, 10:11:02 am

Title: Unable to boot after using Systemback(SOLVED)
Post by: alynur on November 15, 2019, 10:11:02 am
Hello Peppermint people, I used systemback to make a live image of my P 9 installation on my laptop. The live image was too big to make an iso file but I was able to write it to a usb memory. My intentions are to replace an upgraded P 10 system on my desktop that isn't working very good with no known solutions, I'm talking about nemo lag and freezing. The usb memory boots up fine into the live image, which is a duplicate of my laptop system, pretty cool, but there's no way of installing from it so I had to reboot the usb and select boot into live image installer. That works good, chose the partition P 10 was installed on, deleted it, reselected the partition to make new and it all went very nicely. I booted up into the Ubuntu that is controlling boot and ran sudo update-grub, alls well. rebooted into the new installation and it doesn't boot. I get this,

(https://i.imgur.com/Lwrl7tV.jpg)

blkid shows this,

Code: [Select]
albert@albert-desktop ~ $ blkid
/dev/sda1: UUID="776dba26-93d1-4d68-9cca-e7773642ee82" TYPE="ext4" PARTUUID="a67c2459-9394-427d-9c72-93872332500d"
/dev/sda2: UUID="3572D87968E542C1" TYPE="ntfs" PTTYPE="dos" PARTUUID="b620e0c9-e426-42c4-9e29-952d328d9c9a"
/dev/sdb1: UUID="AE4E-959E" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="a214246a-8542-4466-9c4a-1df2c816f958"
/dev/sdb2: LABEL="SB@" UUID="f4a64468-2bd4-450b-b573-3a1dd9ded925" TYPE="ext4" PARTUUID="693e6e4e-7542-42cf-8f12-016a74d95cc7"
/dev/sdb3: UUID="edd0242f-a8d8-4387-940d-226af5ff8f1c" TYPE="ext4" PARTLABEL="Ubuntu MATE" PARTUUID="009c32e5-2b58-433f-be02-07bc4c7a99d1"
/dev/sdb4: UUID="ec363331-1864-4320-8998-df762df7e905" TYPE="ext4" PARTUUID="082c684e-bea9-472b-a123-ce1380b4d599"
/dev/sdb5: UUID="b982ea7f-26e9-4dfb-b97a-ab9a8c86f66f" TYPE="swap" PARTUUID="7a49a2b9-0572-48f2-90e6-e0665bd90026"
/dev/sdb6: UUID="4c7dfcba-b030-4b6b-87f4-7b1e7466b05b" TYPE="ext4" PARTLABEL="Mint" PARTUUID="831b96ce-95b1-4c0c-a536-67ff1fbabeaf"
/dev/sdb7: UUID="530dfd1e-5d45-460e-9c95-b4b1f292a241" TYPE="ext4" PARTLABEL="kubuntu" PARTUUID="2bffbc02-e806-4d40-a0de-412cbd124a26"
/dev/sdb8: UUID="e7723a02-d9bc-463c-a012-07ddff2cb9a3" TYPE="ext4" PARTLABEL="feren" PARTUUID="70cc89e5-6a94-48b1-8bc4-0b3ae56e6bc5"
/dev/sdb9: UUID="d3cf32d0-fbfc-4ea4-94b3-fd73148c5090" TYPE="ext4" PARTLABEL="peppermint 10" PARTUUID="bbd40eb2-85cb-4e4a-877e-3a15f0f5122e"
/dev/sdb10: UUID="640eb672-bdbc-4d71-b7d6-5956dd0bb367" TYPE="ext4" PARTLABEL="Xubuntu" PARTUUID="97dcbb4b-ab07-42d7-9f41-9af74060a6f3"

The fstab of the installation shows this

Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda9 during installation
UUID=f4a64468-2bd4-450b-b573-3a1dd9ded925   /   ext4   noatime,errors=remount-ro   0   1

I think the UUID that is being shown as not existing was from the first attempt to install without deleting the partition and just selecting it to install into?

The UUID of the prior P 10 installation was

Code: [Select]
/dev/sdb2: UUID="b4054ac1-50c6-4114-8cd2-cc8384f1d361" TYPE="ext4" PARTLABEL="peppermint" PARTUUID="57ec59fa-6ea7-4c2f-bd07-a8494e062af7"

Any ideas on how to fix this?   :-\
Title: Re: Unable to boot after using Systemback
Post by: murraymint on November 15, 2019, 10:37:54 am
It's looking for a swap partition that's no longer there, I think. Comment out the swap partition in the /etc/fstab and it might boot OK.

Actually maybe if you could chroot into it and update the grub it would pick up the right partition UUID.
Title: Re: Unable to boot after using Systemback
Post by: PCNetSpec on November 15, 2019, 05:32:04 pm
If you want Peppermint to control GRUB, boot the LiveUSB and run these commands in sequence:
Code: [Select]
sudo mount /dev/sdb9 /mnt
then
Code: [Select]
gksudo xed /mnt/etc/fstab
when fstab opens make it read
Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# /
UUID=d3cf32d0-fbfc-4ea4-94b3-fd73148c5090   /   ext4   noatime,errors=remount-ro   0   1
SAVE the file and exit the text editor.

Back in the terminal run:
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
then
Code: [Select]
sudo chroot /mnt
then
Code: [Select]
grub-install /dev/sdb
then
Code: [Select]
update-grub
then hit Ctrl+D (to exit the chroot environment)

and finally reboot without the LiveUSB (after setting sdb as the primary boot device in the BIOS).
Title: Re: Unable to boot after using Systemback
Post by: alynur on November 15, 2019, 07:15:20 pm
Okay, I should have been a little more clear, I was trying to boot the new install of my Peppermint system into sdb2. The fstab was as listed, appears to be correct, but when I tried to boot sdb2 I got the message in the photo. Perhaps attempting to reinstall grub would have fixed it but I was perplexed by the alert about the UUID  not existing. What is the missing module that's being indicated?
Title: Re: Unable to boot after using Systemback
Post by: PCNetSpec on November 15, 2019, 08:01:51 pm
Okay if Peppermint is on /dev/sdb2 (and you want it to control GRUB)

Boot the LiveUSB and run these commands in sequence:
Code: [Select]
sudo mount /dev/sdb2 /mnt
then
Code: [Select]
gksudo xed /mnt/etc/fstab
when fstab opens make it read
Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb2 during installation
UUID=f4a64468-2bd4-450b-b573-3a1dd9ded925   /   ext4   noatime,errors=remount-ro   0   1
SAVE the file and exit the text editor.

Back in the terminal run:
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
then
Code: [Select]
sudo chroot /mnt
then
Code: [Select]
grub-install /dev/sdb
then
Code: [Select]
update-grub
then hit Ctrl+D (to exit the chroot environment)

and finally reboot without the LiveUSB (after setting sdb as the primary boot device in the BIOS).



The problem is the grub.cfg of whichever distro is currently still controlling GRUB is expecting sdb2 to have a UUID of b4054ac1-50c6-4114-8cd2-cc8384f1d361"

But I don't know which distro if currently controlling GRUB .. so now the UUID of sdb2 has changed it's easier to just make the new Peppermint control GRUB than to fix whatever is currently controlling it.
Title: Re: Unable to boot after using Systemback
Post by: alynur on November 16, 2019, 10:50:07 am
Thanks PCNetSpec, I would have tried to fix this using your commands, but prior to your posting I got impatient and reinstalled P 9 from P 9's iso and went with apt-clone to get the majority of my packages installed. So at this point I'm not sure if the systemback method without an iso file works. That would be pretty cool if it did because it is a clone of the original system. Maybe I'll get ambitious and try it again so I can say it works and solved for others to know your recovery method works. Yeah, why not!  ;D
Title: Re: Unable to boot after using Systemback
Post by: alynur on November 16, 2019, 01:43:03 pm
Okay, I reinstalled the Systemback live image into sdb2, I left the boot manager control on sdb9, P 10, changed the fstab of sdb2 to reflect the correct uuid and also the automount of my DATA partition. I booted up into P 10 and ran sudo update-grub and attempted to boot into sdb2 which failed. So I tried to install bootmanager of sdb2 into sdb and this is what I got.

Code: [Select]
peppermint@peppermint ~ $ sudo mount /dev/sdb2 /mnt
peppermint@peppermint ~ $ for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
peppermint@peppermint ~ $ sudo chroot /mnt
root@peppermint / # grub-install /dev/sdb
Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.
   

Could it be I was supposed to install grub in sdb1? Looks like I have a missing EFI directory somewhere.
Title: Re: Unable to boot after using Systemback
Post by: alynur on November 16, 2019, 02:20:05 pm
Usually when I want to change the distro that is controlling bootloader I run these commands and it works,


Code: [Select]
sudo mount /dev/sdXXX /mnt
sudo mount /dev/sdXX /mnt/boot/efi
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
sudo chroot /mnt
grub-install /dev/sdX
update-grub 
Note : sdX = disk | sdXX = efi partition | sdXXX = system partition

and that's how I got the missing EFI directory. Could I copy the directory from another distro installed on my harddrive, like P 10 and copy it into sdb2?
Title: Re: Unable to boot after using Systemback
Post by: PCNetSpec on November 16, 2019, 02:29:04 pm
Sorry, I missed the EFI partition :-[

Boot the LiveUSB and run these commands in sequence:
Code: [Select]
sudo mount /dev/sdb2 /mnt
then
Code: [Select]
sudo mount /dev/sdb1 /mnt/boot/efi
then
Code: [Select]
gksudo xed /mnt/etc/fstab
when fstab opens make it read
Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb2 during installation
UUID=f4a64468-2bd4-450b-b573-3a1dd9ded925   /   ext4   noatime,errors=remount-ro   0   1
SAVE the file and exit the text editor.

Back in the terminal run:
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
then
Code: [Select]
sudo chroot /mnt
then
Code: [Select]
grub-install /dev/sdb
then
Code: [Select]
update-grub
then hit Ctrl+D (to exit the chroot environment)

and finally reboot without the LiveUSB (after setting sdb as the primary boot device in the BIOS).
Title: Re: Unable to boot after using Systemback
Post by: alynur on November 16, 2019, 02:57:43 pm
Sorry, I missed the EFI partition :-[

Boot the LiveUSB and run these commands in sequence:
Code: [Select]
sudo mount /dev/sdb2 /mnt
then
Code: [Select]
sudo mount /dev/sdb1 /mnt/boot/efi
then
Code: [Select]
gksudo xed /mnt/etc/fstab
when fstab opens make it read
Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb2 during installation
UUID=f4a64468-2bd4-450b-b573-3a1dd9ded925   /   ext4   noatime,errors=remount-ro   0   1
SAVE the file and exit the text editor.

Back in the terminal run:
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
then
Code: [Select]
sudo chroot /mnt
then
Code: [Select]
grub-install /dev/sdb
then
Code: [Select]
update-grub
then hit Ctrl+D (to exit the chroot environment)

and finally reboot without the LiveUSB (after setting sdb as the primary boot device in the BIOS).

I caught that after trying with your original instructions. I ran it the correct way and I still get the EFI directory missing, appears to be no efi directory in sdb2. Can I copy one over?
Title: Re: Unable to boot after using Systemback
Post by: PCNetSpec on November 16, 2019, 03:20:05 pm
There won't be an efif directory in sdb2 .. that's mounted as /

the efi directory is sdb1

have you actually tried running the above commands now ?



Let's see if the efi partition has any bootloaders in it

Boot the LiveUSB and run these commands in sequence:
Code: [Select]
sudo mount /dev/sdb2 /mnt
then
Code: [Select]
sudo mount /dev/sdb1 /mnt/boot/efi
now what's the output from
Code: [Select]
sudo ls /mnt/boot/efi/EFI
Title: Re: Unable to boot after using Systemback
Post by: alynur on November 16, 2019, 03:28:29 pm
yup

Code: [Select]
albert@albert-desktop ~ $ sudo mount /dev/sdb2 /mnt
[sudo] password for albert:
albert@albert-desktop ~ $ sudo mount /dev/sdb1 /mnt/boot/efi
mount: /mnt/boot/efi: mount point does not exist.
albert@albert-desktop ~ $ for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
albert@albert-desktop ~ $ sudo chroot /mnt
root@albert-desktop / # grub-install /dev/sdb
Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.
root@albert-desktop / # update-grub
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/50_peppermint.cfg'
Generating grub configuration file ...
Found background image: grub-background.png
Found linux image: /boot/vmlinuz-5.3.0-23-generic
Found initrd image: /boot/initrd.img-5.3.0-23-generic
Found linux image: /boot/vmlinuz-5.3.0-22-generic
Found initrd image: /boot/initrd.img-5.3.0-22-generic
Found linux image: /boot/vmlinuz-5.0.0-23-generic
Found initrd image: /boot/initrd.img-5.0.0-23-generic
Found linux image: /boot/vmlinuz-4.15.0-70-generic
Found initrd image: /boot/initrd.img-4.15.0-70-generic
Found Ubuntu 18.04.3 LTS (18.04) on /dev/sdb10
Found Ubuntu 19.04 (19.04) on /dev/sdb3
Found Linux Mint 19.2 Tina (19.2) on /dev/sdb6
Found Ubuntu 18.04.3 LTS (18.04) on /dev/sdb7
Found Feren OS (18.04) on /dev/sdb8
Found Peppermint 10 Ten (10) on /dev/sdb9
Adding boot menu entry for EFI firmware configuration
done
Title: Re: Unable to boot after using Systemback
Post by: PCNetSpec on November 16, 2019, 03:32:45 pm
Let's see if the efi partition has any bootloaders in it

Boot the LiveUSB and run these commands in sequence:
Code: [Select]
sudo mount /dev/sdb2 /mnt
then
Code: [Select]
sudo mount /dev/sdb1 /mnt/boot/efi
now what's the output from
Code: [Select]
sudo ls /mnt/boot/efi/EFI
Title: Re: Unable to boot after using Systemback
Post by: PCNetSpec on November 16, 2019, 03:48:58 pm
What happens if you try this:-

Boot the LiveUSB and run these commands in sequence:
Code: [Select]
sudo mount /dev/sdb2 /mnt
then
Code: [Select]
sudo mount /dev/sdb1 /mnt/boot/efi
then
Code: [Select]
gksudo xed /mnt/etc/fstab
when fstab opens make it read
Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb2 during installation
UUID=f4a64468-2bd4-450b-b573-3a1dd9ded925   /   ext4   noatime,errors=remount-ro   0   1
SAVE the file and exit the text editor.

Back in the terminal run:
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
then
Code: [Select]
sudo chroot /mnt
then
Code: [Select]
grub-install --efi-directory=/mnt/boot/efi
then
Code: [Select]
update-grub
then hit Ctrl+D (to exit the chroot environment)

and finally reboot without the LiveUSB (after setting sdb as the primary boot device in the BIOS).
Title: Re: Unable to boot after using Systemback
Post by: alynur on November 16, 2019, 05:21:01 pm
Let's see if the efi partition has any bootloaders in it

Boot the LiveUSB and run these commands in sequence:
Code: [Select]
sudo mount /dev/sdb2 /mnt
then
Code: [Select]
sudo mount /dev/sdb1 /mnt/boot/efi
now what's the output from
Code: [Select]
sudo ls /mnt/boot/efi/EFI



This happens 

Code: [Select]
peppermint@peppermint ~ $ sudo mount /dev/sdb2 /mnt
peppermint@peppermint ~ $ sudo mount /dev/sdb1 /mnt/boot/efi
mount: /mnt/boot/efi: mount point does not exist.
peppermint@peppermint ~ $ sudo ls /mnt/boot/efi/EFI
ls: cannot access '/mnt/boot/efi/EFI': No such file or directory
peppermint@peppermint ~ $
Title: Re: Unable to boot after using Systemback(SOLVED)
Post by: alynur on November 16, 2019, 05:28:26 pm
What happens if you try this:-

Boot the LiveUSB and run these commands in sequence:
Code: [Select]
sudo mount /dev/sdb2 /mnt
then
Code: [Select]
sudo mount /dev/sdb1 /mnt/boot/efi
then
Code: [Select]
gksudo xed /mnt/etc/fstab
when fstab opens make it read
Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb2 during installation
UUID=f4a64468-2bd4-450b-b573-3a1dd9ded925   /   ext4   noatime,errors=remount-ro   0   1
SAVE the file and exit the text editor.

Back in the terminal run:
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
then
Code: [Select]
sudo chroot /mnt
then
Code: [Select]
grub-install --efi-directory=/mnt/boot/efi
then
Code: [Select]
update-grub
then hit Ctrl+D (to exit the chroot environment)

and finally reboot without the LiveUSB (after setting sdb as the primary boot device in the BIOS).

This happens,


Code: [Select]
peppermint@peppermint ~ $ sudo mount /dev/sdb2 /mnt
peppermint@peppermint ~ $ sudo mount /dev/sdb1 /mnt/boot/efi
mount: /mnt/boot/efi: mount point does not exist.
peppermint@peppermint ~ $ sudo ls /mnt/boot/efi/EFI
ls: cannot access '/mnt/boot/efi/EFI': No such file or directory
peppermint@peppermint ~ $ for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
peppermint@peppermint ~ $ sudo chroot /mnt
root@peppermint / # grub-install --efi-directory=/mnt/boot/efi
Installing for x86_64-efi platform.
grub-install: error: failed to get canonical path of `/mnt/boot/efi'.
root@peppermint / # exit
peppermint@peppermint ~ $

To me this is showing that there is no efi directory in sdb2 /boot. I looked in my installed version of P 10 and it has an efi directory in /boot. That-s why I asked if we could copy it over some way. I was able to copy the directory to my Documents.
Title: Re: Unable to boot after using Systemback
Post by: murraymint on November 16, 2019, 05:34:51 pm
Make sure your BIOS is set to only boot in UEFI mode, not UEFI/Legacy.
Title: Re: Unable to boot after using Systemback
Post by: alynur on November 16, 2019, 05:44:51 pm
Make sure your BIOS is set to only boot in UEFI mode, not UEFI/Legacy.


Hi murraymint, I haven't been into my bios in a while, it could very well be set for UEFI/Legacy and the usb memory with the Systemback live image is just randomly booting into Legacy. I'll check that out now.
Title: Re: Unable to boot after using Systemback
Post by: alynur on November 16, 2019, 07:03:04 pm
Yup that was it, my bios was set up for UEFI/Legacy. I switched it to UEFI only and the usb memory doesn't show up. Apparently Systemback is too old for UEFI, just like Unitbooten for installing from one partition into another. I took a Timeshift snapshot of the P 9 install I had just finished the last touches on, so we'll see if it will boot up after the snapshot is finished restoring. At least we know we can't recommend Systemback for a UEFI clone.  :'(
Title: Re: Unable to boot after using Systemback
Post by: clatterfordslim on November 16, 2019, 07:39:13 pm
Unfortunately Systemback only goes up to 4.4GB in ISO and for the life of me I could not get it going with Pep 10 only Pep 9 then upgraded to Pep 10 through PCNetSpec's upgrade tutorial.
Title: Re: Unable to boot after using Systemback
Post by: alynur on November 16, 2019, 10:56:10 pm
Unfortunately Systemback only goes up to 4.4GB in ISO and for the life of me I could not get it going with Pep 10 only Pep 9 then upgraded to Pep 10 through PCNetSpec's upgrade tutorial.

I see where Systemback could be a real winner for cloning a not-too-big system that is going to be installed into a blank harddrive with an MBR file system. My live image was about 7.3g and would have had a better chance of working if it wasn't getting installed into a GPT file system. I was able to salvage the installation by restoring the last Timeshift snapshot I had taken of my laptop and then while still booted in P 10, mounting the systemback partition in nemo and changing the fstab to have the correct UUID numbers, including my DATA partition. When I rebooted, it booted right up, albeit a few seconds slower than before but that's no biggie. Everything is there, or here, I'm in it, P 9, now. I did have to rename my computer and host name and reestablish my symlinks for my home folders but the DATA partition was already there and ready to go. I'm especially happy because the nemo file system crawl that I was experiencing in the upgraded version of P 10, is not present. Yay! Bye the way, my fresh install of P 10 in sdb9 is starting to experience the nemo crawl and is getting worse.
I'll go ahead and mark this as solved since I accomplished what I was trying to do with a little bit of a work around. Thanks PCNetSpec and murraymint for your help, you guys pointed my thinking in the right direction. Peppermint people are the best!   :-*
Title: Re: Unable to boot after using Systemback
Post by: PCNetSpec on November 16, 2019, 11:10:50 pm
Glad you got it sorted alynur, but I think murraymint deserves all the kudos for this one :)
Title: Re: Unable to boot after using Systemback
Post by: alynur on November 16, 2019, 11:19:22 pm
Glad you got it sorted alynur, but I think murraymint deserves all the kudos for this one :)


Indeed he does, but you put some effort into it also.  ;)
Title: Re: Unable to boot after using Systemback
Post by: PCNetSpec on November 16, 2019, 11:29:37 pm
Effort, but no cigar :))
Title: Re: Unable to boot after using Systemback(SOLVED)
Post by: alynur on November 24, 2019, 09:39:55 pm
As I had mentioned, before trying to boot into the systemback system, I changed the fstab file to reflect the proper UUID's of my hard drive and that bootup time was a few seconds slower. Well, it was actually about 40 seconds slower and that was starting to bother me, normal bootup was about 20 seconds. So I did a search for slow bootup in the forum search box and one of the listed posts was of the P 9 beta test by andymokum. In that it was discovered that not only in the fstab file did the correct UUID numbers have to be changed but also in the   
Code: [Select]
initramfs-tools/conf.d/resume
  file. so I ran the code

Code: [Select]
sudo xed /etc/initramfs-tools/conf.d/resume
and made the necessary changes and then ran

Code: [Select]
sudo update-initramfs -uk all

Now my bootup is back to around 20 seconds. I am a happy camper!     :)
Title: Re: Unable to boot after using Systemback(SOLVED)
Post by: PCNetSpec on November 24, 2019, 10:20:50 pm
Glad you found the solution alynur .. that's what the forum is here for, a permanent repository of previously discovered solutions :)