Peppermint OS

Support => Networking => Topic started by: acer on November 13, 2019, 12:52:37 am

Title: SOLVED : Ehernet connection drop-outs
Post by: acer on November 13, 2019, 12:52:37 am
Hi all,
Old time peppermint user looking for help for a new issue.
Network drop-outs whilst connected to the internet (ADSL using ethernet).
Tried a Windoze device on same connection, no issues, so assumed it must be an update issue as prior to updates everything was fine.

Below are details of the system and most recent updates applied prior to drop outs.

Code: [Select]
$ inxi -Fz

System:    Host: x86 Kernel: 4.15.0-69-generic i686 bits: 32 Desktop: N/A
           Distro: Peppermint Nine
Machine:   Device: laptop System: Acer product: AO533 v: V1.17 serial: N/A
           Mobo: Acer model: AO533 v: V1.17 serial: N/A
           BIOS: Acer v: V1.17 date: 05/19/2011
Battery    BAT0: charge: 59.4 Wh 100.0% condition: 59.4/62.6 Wh (95%)
CPU:       Single core Intel Atom N455 (-MT-) cache: 512 KB
           clock speeds: max: 1666 MHz 1: 1229 MHz 2: 1199 MHz
Graphics:  Card: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
           Display Server: x11 (X.Org 1.19.6 )
           drivers: intel (unloaded: modesetting,fbdev,vesa)
           Resolution: 1024x600@60.08hz
           OpenGL: renderer: Mesa DRI Intel Pineview M x86/MMX/SSE2
           version: 1.4 Mesa 19.0.8
Audio:     Card Intel NM10/ICH7 Family High Def. Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-69-generic
Network:   Card-1: Qualcomm Atheros AR8152 v1.1 Fast Ethernet driver: atl1c
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Broadcom and subsidiaries BCM4313 802.11bgn Wireless Network Adapter
           driver: bcma-pci-bridge
           IF: wlp2s0b1 state: down mac: <filter>
Drives:    HDD Total Size: 32.0GB (18.0% used)
           ID-1: /dev/sda model: SanDisk_SDSSDRC0 size: 32.0GB
Partition: ID-1: / size: 30G used: 5.4G (20%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 45.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 145 Uptime: 55 min Memory: 194.7/1937.1MB
           Client: Shell (bash) inxi: 2.3.56

last upgrades prior to ethernet/internet dropouts.

Upgraded the following packages:
gir1.2-javascriptcoregtk-4.0 (2.26.1-0ubuntu0.18.04.1) to 2.26.2-0ubuntu0.18.04.1
gir1.2-webkit2-4.0 (2.26.1-0ubuntu0.18.04.1) to 2.26.2-0ubuntu0.18.04.1
intel-microcode (3.20190618.0ubuntu0.18.04.1) to 3.20191112-0ubuntu0.18.04.2
libjavascriptcoregtk-4.0-18 (2.26.1-0ubuntu0.18.04.1) to 2.26.2-0ubuntu0.18.04.1
libsgutils2-2 (1.42-2ubuntu1) to 1.42-2ubuntu1.18.04.1
libwebkit2gtk-4.0-37 (2.26.1-0ubuntu0.18.04.1) to 2.26.2-0ubuntu0.18.04.1
linux-generic ( to
linux-headers-generic ( to
linux-image-generic ( to
linux-libc-dev (4.15.0-66.75) to 4.15.0-69.78

Installed the following packages:
linux-headers-4.15.0-69 (4.15.0-69.78)
linux-headers-4.15.0-69-generic (4.15.0-69.78)
linux-image-4.15.0-69-generic (4.15.0-69.78)
linux-modules-4.15.0-69-generic (4.15.0-69.78)
linux-modules-extra-4.15.0-69-generic (4.15.0-69.78)

Code: [Select]
$ sudo lshw -C network
       description: Ethernet interface
       product: AR8152 v1.1 Fast Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: enp1s0
       version: c1
       serial: 88:ae:1d:97:03:e6
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion= duplex=full ip=xxxxxxx latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:27 memory:97000000-9703ffff ioport:5000(size=128)

One thing I have noticed is, if I physically unplug/ replace the the ethernet cable from the device port once a drop out hits, the internet connection is available and works until the next loss of connection a short time later. Cable is fine and have tried reverting back to previous kernel to no avail, still encountering ethernet drop outs.
Any ideas on how to rectify this?
Thanks in advance :)
Title: Re: Ehernet connection drop-outs
Post by: acer on November 13, 2019, 02:57:35 am
fugetaboutit...problem was the netbook ethernet port,  now fixed  :-[
Title: Re: SOLVED : Ehernet connection drop-outs
Post by: PCNetSpec on November 13, 2019, 06:53:35 am
Great news acer, glad you figured it out :)