Peppermint OS Community Forum

Support => Hardware => Topic started by: rkw on June 14, 2019, 09:33:12 am

Title: Lost HDMI monitor on HP Envy x360 Laptop [SOLVED]
Post by: rkw on June 14, 2019, 09:33:12 am
I'm a pretty new Linux desktop & Peppermint user (a few months).  I have past experience with Linux on servers and am moderately skilled at the command line...

I have been loving Peppermint (finally ditched Windows 10).  I have an external monitor (Acer, K2 series, 27").  I have a work laptop (Windows 7) and a personal laptop (Peppermint).  I have the Windows 7 laptop connected via VGA and the Peppermint laptop connected via HDMI.  I toggle back and forth on the monitor between the two.  This has been working great for months but after I unplugged my Peppermint laptop 1 or 2 days ago, I can no longer get the HDMI to connect.

I moved the Windows 7 laptop over to HDMI to verify it was not the monitor or the cable and it  worked fine.  Unfortunately, my Peppermint laptop does not have a VGA port to try the opposite test.

Can someone please help?

You may want inxi -Fxz:

System:    Host: rkw-HP-ENVY-x360 Kernel: 4.15.0-43-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: N/A Distro: Peppermint Nine
Machine:   Device: laptop System: Hewlett-Packard product: HP ENVY x360 Convertible v: Type1ProductConfigId serial: N/A
           Mobo: Hewlett-Packard model: 8113 v: 07.07 serial: N/A
           UEFI [Legacy]: Insyde v: F.01 date: 03/26/2015
Battery    BAT0: charge: 20.8 Wh 71.2% condition: 29.2/29.2 Wh (100%)
           model: Hewlett-Packard Primary status: Charging
CPU:       Dual core Intel Core i7-5500U (-MT-MCP-)
           arch: Broadwell rev.4 cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9578
           clock speeds: max: 3000 MHz 1: 1000 MHz 2: 953 MHz 3: 1431 MHz
           4: 1212 MHz
Graphics:  Card: Intel HD Graphics 5500 bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1600x900@59.99hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
           version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio:     Card-1 Intel Broadwell-U Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Card-2 Intel Wildcat Point-LP High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-43-generic
Network:   Card-1: Intel Wireless 3160 driver: iwlwifi bus-ID: 03:00.0
           IF: wlo1 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 04:00.0
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 480.1GB (5.0% used)
           ID-1: /dev/sda model: SATA_SSD size: 480.1GB
Partition: ID-1: / size: 439G used: 22G (6%) fs: ext4 dev: /dev/dm-0
           ID-2: swap-1 size: 1.02GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 41.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 201 Uptime: 26 min Memory: 1292.6/15969.8MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56
Title: Re: Lost HDMI monitor on HP Envy x360 Laptop
Post by: rkw on June 14, 2019, 09:36:49 am
I tried try a couple of reboots...  When I started with Peppermint, I had the problem where I would unplug the HDMI monitor while running and plug it back in later.  It did not recognize that I plugged back in until I posted here and someone advised me of a setting to auto reconnect to the display.  At any rate, even rebooting did not help...
Title: Re: Lost HDMI monitor on HP Envy x360 Laptop [SOLVED]
Post by: rkw on June 14, 2019, 10:34:12 am
The good news is, the problem is solved.  The bad news is, I am not quite sure how.

I have an Easy2Boot USB with several Linux distro ISOs.  I tried booting into Kubuntu 18.04 Live/Install ISO.  No luck - I did not see the HDMI.
I think the next thing was I rebooted into the BIOS.  I did not make any changes, but I did Save and Reboot.
I think the next thing was I tried booting into Ubuntu MATE 18.04 Live/Install ISO.  Surprised - the HDMI monitor was detected!
Finally, I booted back to Peppermint (on the SDD) and I am good.

I would love it if anyone has any thoughts on this so that I might learn from the experience ... but I am happy to have my monitor back!