Peppermint OS Community Forum

Support => New Users => Topic started by: ssybesma on April 17, 2019, 10:29:17 pm

Title: rdp host for Peppermint
Post by: ssybesma on April 17, 2019, 10:29:17 pm
I'm looking for an rdp host for Peppermint 9 that allows me to remote into the device from a Windows 10 machine.

Was not able to get xrdp working. I don't have complete instructions for Peppermint.

I've been using TeamViewer, but it crashes sometimes and would like something with a smaller memory footprint.
Title: Re: rdp host for Peppermint
Post by: PCNetSpec on April 18, 2019, 06:55:36 am
I doubt this'll make any difference because SMBv1 and RDP are separate protocols, but you never know...

Here's a post I made about how the disabling of SMBv1 has caused some issues:-

I had to set up some mapped network drives on a bunch of Windows 10 workstations yesterday .. to automount some shares from some older NAS's.

Well I spent half a day trying to figure out why one single Windows 10 machine flatly refused to allow me to browse the network. It turns out that

a) The NAS's were using SMB v1

b) If you install Windows 10 >= 1709 SMB v1 isn't installed

c) If you Installed an earlier version of Win10 where SMB v1 was installed, then applied the "Fall Creators" update .. the update would uninstall SMB v1 after 15 days if it didn't detect it had been used in that time.

Now IIRC we've had some questions previously on the forum from people saying stuff like "PM9 screwed up my network shares, they worked in PM8" or "PM9 can't see my Win10 PC", etc.

So if this comes up again, probably the easiest solution would be to make sure SMB v1 is installed/enabled in both Windows 10 .. AND .. Peppermint 9

Instructions for enabling SMB v1 in Peppermint 9 can be found here:,7086.msg72516.html#msg72516

Instructions for making sure SMB v1 is installed in Windows 10:-
(it's important that you REBOOT Windows because it does that very 'Windowy' thing where it's installed as part of the shutdown and bootup process)

As additional info, it turns out there was a firmware update available for the NAS's in question that enabled a later version of SMB (3 I think) .. but even after updating the firmware and enabling the later SMB .. then rebooting EVERYTHING .. Windows STILL couldn't see the NAS's.

So it looks like SMB >= v2 is a bit hit and miss in both Windows and Linux at the moment .. hence this post.

Maybe just using something like NoMachine would be a solution ?
Title: Re: rdp host for Peppermint
Post by: ssybesma on April 18, 2019, 12:53:43 pm
I'll check SMB on Peppermint.  SMB was already enabled and is working on Windows 10.

Nomachine appears to be several times bulkier than TeamViewer which is what I'm currently using but want to get away from.

I have 1GB of  RAM on this Intel Compute Stick with no way to increase, so I'm confined to that limit.

My goal is the leanest & meanest remote desktop app I can find.  It doesn't have to have all the bells and whistles, just allow me basic remote control using a GUI interface.
Title: Re: rdp host for Peppermint
Post by: ssybesma on April 18, 2019, 03:53:33 pm
No difference at all.  Still black screen when I try to connect on rdp (with xrdp installed on Peppermint 9 target machine).

I'm  using the XORG option. I tried others in the dropdown which don't work either.

In order to share folders, I used Samba and the filesystems are fully accessible in Windows now.

What I am able to do is at the blank screen, I can do a Ctrl+Alt+T and that does bring up Terminal so I can run my  CLI app (called mprime).

Also, that same app (my primary reason for having the Intel Compute Sticks with Peppermint installed) remains running in the terminal window after I exit  XRDP.

When I go back in the terminal window is still there and the mprime CLI app is still running, which is perfect.
Title: Re: rdp host for Peppermint
Post by: Slim.Fatz on April 20, 2019, 03:31:43 am
Hi ssybesma,

So just to make things more clear: has your issue been resolved?  :-\ If the answer is yes, please go back to your first post and modify the Subject: line by adding the word (SOLVED) so that others notice it before reading the entire thread.  ;)


-- Slim