Peppermint OS Community Forum

Support => Networking => Topic started by: AZgl1500 on August 19, 2018, 02:54:43 am

Title: Peppermint is not showing me any of the Network devices on my WiFi
Post by: AZgl1500 on August 19, 2018, 02:54:43 am
There are 2 WiFi printers, 1 Win7 PC, 4 laptops, 2 on Windows, 2 on Linux.

I need to log into the Win7 PC server to access a Shared Folder that is dedicated to this laptop to use, as a host for files.  This laptop is dual boot with Win10. Secure Boot is turned off.

Grub has been set to default to Windows Boot manager if the up/dn arrow is not used to select Linux....

This laptop is used for a home based business for my daughter, it is critical that I make it easy for her to learn Linux, Peppermint's ICE is what drew me to this OS for her, as she must have access to MS Office natively, not thru a crutch.... she knows nothing of Linux, so I have to make the path easy for her.

I need to put a Network icon on the Desktop linked to her Shared Folder on my Win7 Desktop.
I use Linux Mint 18.3 Cinnamon for my daily driver laptop... and when I saw Peppermint, I knew it was the way to go for my daughter.

She is very much upset with Microsoft's constant intrusion on her life, and constant updates that take her PC away from here when she needs it the most.

Code: [Select]
peppermint@peppermint ~ $ inxi -Fd
System:    Host: peppermint Kernel: 4.15.0-23-generic x86_64 bits: 64 Desktop: N/A
           Distro: Peppermint Nine
Machine:   Device: laptop System: Acer product: Aspire E5-774G v: V1.18 serial: N/A
           Mobo: Acer model: Hulk_SK v: V1.18 serial: N/A
           UEFI [Legacy]: Insyde v: V1.18 date: 10/21/2016
Battery    BAT1: charge: 31.0 Wh 100.0% condition: 31.0/41.4 Wh (75%)
           hidpp__0: charge: N/A condition: NA/NA Wh
CPU:       Dual core Intel Core i5-7200U (-MT-MCP-) cache: 3072 KB
           clock speeds: max: 3100 MHz 1: 1123 MHz 2: 752 MHz 3: 741 MHz 4: 749 MHz
Graphics:  Card-1: Intel HD Graphics 620
           Card-2: NVIDIA Device 179c
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting,nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.03hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2)
           version: 4.5 Mesa 18.0.0-rc5
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-23-generic
Network:   Card-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
           driver: ath10k_pci
           IF: wlp3s0 state: up mac: 58:00:e3:6f:07:23
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169
           IF: enp4s0f1 state: down mac: a8:1e:84:18:18:53
Drives:    HDD Total Size: 271.7GB (1.4% used)
           ID-1: /dev/sda model: KINGSTON_RBU size: 256.1GB
           ID-2: USB /dev/sdb model: Cruzer_Glide size: 15.7GB
           Optical: No optical drives detected.
Partition: ID-1: / size: 3.9G used: 249M (7%) fs: overlay dev: N/A
           ID-2: swap-1 size: 1.03GB used: 0.00GB (0%) fs: swap dev: /dev/zram0
           ID-3: swap-2 size: 1.03GB used: 0.00GB (0%) fs: swap dev: /dev/zram1
           ID-4: swap-3 size: 1.03GB used: 0.00GB (0%) fs: swap dev: /dev/zram2
           ID-5: swap-4 size: 1.03GB used: 0.00GB (0%) fs: swap dev: /dev/zram3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 38.0C mobo: N/A gpu: 31.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 193 Uptime: 12 min Memory: 474.8/7845.7MB
           Client: Shell (bash) inxi: 2.3.56
peppermint@peppermint ~ $
Title: Re: Peppermint is not showing me any of the Network devices on my WiFi
Post by: PCNetSpec on August 19, 2018, 05:23:00 am
Try this tutorial by TonyBronze
https://forum.peppermintos.com/index.php/topic,7086.msg72516.html#msg72516

Is wireless working at all .. I mean are you able to connect to the internet wirelessly ? .. if not, can you also include the output from the commands listed here:
https://forum.peppermintos.com/index.php/topic,6713.0.html
in your next response.
Title: Re: Peppermint is not showing me any of the Network devices on my WiFi
Post by: AZgl1500 on August 19, 2018, 12:31:57 pm
Just back to the forum, been a long night, dental surgery aftermath keeping me awake. :(
I will be following up those tutorials after this post.

I now have my daughter's laptop showing some network items, it is logged into the WiFi and can browse the internet, that is not an issue.

here is what her Acer sees when I click on Network from NEMO.

(https://imgur.com/cc7qSztl.png)

When I click on "Windows Network", it does not show anything there at all.
Might be related to Permissions?  I am brand new to Peppermint, but been using LM18.3 for a couple years, so know my way around.

From my own Linux Mint laptop, this is what I see when click on Network.

(https://i.imgur.com/YEd3bqO.png)

and that is exactly what I should be seeing from Peppermint, and I don't know why it is not seeing that list of devices.... the TP500L is my ASUS Linux Mint laptop that I am typing on right now.

JOHN-PC is my Win7 Desktop in the office, we should be able to click on that and drill down into the sub-folders and finally reach a dedicated folder there that I named CYNDI.

that is for her Home Business related files.... I wanted her to be able to share files between all 3 of her personal laptops, each of which has a different purpose, one is for Graphix Design where she lays out stuff for the business, the other is her Mail Central and business laptop, where she shuffles lots of paperwork around....

I just don't understand, why it is not showing the Win7 PC in my office?  if I could access that, and then place the sub=folder on her desktop, I would be finished with her setup.

Title: Re: Peppermint is not showing me any of the Network devices on my WiFi
Post by: PCNetSpec on August 19, 2018, 01:25:29 pm
Let us know if the first tutorial makes any difference.
Title: Re: Peppermint is not showing me any of the Network devices on my WiFi
Post by: TonyBronze on August 19, 2018, 03:20:48 pm
 AZgl1500, the version of Mint you are using is based on Ubuntu 16.04 where Samba and networking behaved as you illustrate..  Peppermint 9 is based on Ubuntu 18.04 which made changes to how networking behaves.  You need to make a change to the Samba config file as per the tutorial to make it behave the same way as it did with Ubuntu 16.04
Title: Re: Peppermint is not showing me any of the Network devices on my WiFi
Post by: dan-d on August 30, 2018, 06:19:47 pm
Hello Tony,

I am having the exact same problem as AZgl1500.  When I double-click on the Windows Network icon it opens up and says 0 items.  I modified the smb.conf file per the instructions in your tutorial, saved it and rebooted my PC.  But it made no difference.  It is still showing none of the shared folders on my Windows PCs.  Any suggestions as to what I should do next to resolve the issue?  Thanks for any and all help you can give.  Am new to Peppermint and other than this, am really liking the OS so far.
Title: Re: Peppermint is not showing me any of the Network devices on my WiFi
Post by: PCNetSpec on August 30, 2018, 07:00:51 pm
Which version(s) of Windows ?

And which workgroup do they belong to ?
Title: Re: Peppermint is not showing me any of the Network devices on my WiFi
Post by: dan-d on August 30, 2018, 11:16:35 pm
Windows 10 and the workgroup is WORKGROUP.
Title: Re: Peppermint is not showing me any of the Network devices on my WiFi
Post by: PCNetSpec on September 01, 2018, 09:11:06 am
Have you turned on

Network Discovery
and
File and Printer Sharing

in Windows 10 ?
Title: Re: Peppermint is not showing me any of the Network devices on my WiFi
Post by: TonyBronze on September 01, 2018, 09:31:03 am
Also check that you are allowing access through any fire walls on the computers and router.
Title: Re: Peppermint is not showing me any of the Network devices on my WiFi
Post by: dan-d on September 01, 2018, 01:24:24 pm
Thanks for the replies. Appreciate your help and suggestions.  I double-checked my firewall and network discovery settings in Windows 10. Network discovery is turned on and the firewall is set to allow incoming connections on the same network. So, I'm not sure why I can't see my Windows shares on Peppermint.  I can see them from other Windows PCs.  So will keep looking online for any solutions I can find.  If you have any other ideas, please do share them.  Thanks again.