Peppermint OS

Support => Installation => Topic started by: kloos on July 27, 2018, 10:28:06 am

Title: Very slow boot time for Latitude D630
Post by: kloos on July 27, 2018, 10:28:06 am
Just got a second hand Dell Latitude D630.  4gb ram and 1.8ghz.
It takes nearly 5 minutes to Peppermint to boot.  I've tried re-booting a few times but the same.  I get a textured screen in the background for ages and then the logo pops up and then back to the blank screen.  Even after logging in it take ages to finish.

Any ideas???
Title: Re: Very slow boot time for Latitude D630
Post by: pin on July 27, 2018, 10:33:59 am
Please have a look through this topic and see if it helps  ;)
https://forum.peppermintos.com/index.php/topic,7186.0.html
Title: Re: Very slow boot time for Latitude D630
Post by: kloos on July 27, 2018, 10:37:41 am
Thanks Pin.  I ran systemd-analyze blame and the top ones are as follows:

1min 30.177s nmbd.service
         34.243s plymouth-start.service
         31.781s lightdm.service
         31.773s plymouth-quit-wait.service
         12.330s dev-sda1.device
         12.181s keyboard-setup.service
Title: Re: Very slow boot time for Latitude D630
Post by: pin on July 27, 2018, 10:52:02 am
If you read through the whole thread...
Are you willing to try a different kernel?
What version of Peppermint are you running and what's the output of
Code: [Select]
uname -a
Title: Re: Very slow boot time for Latitude D630
Post by: TonyBronze on July 27, 2018, 12:26:24 pm
Thanks Pin.  I ran systemd-analyze blame and the top ones are as follows:

1min 30.177s nmbd.service
         34.243s plymouth-start.service
         31.781s lightdm.service
         31.773s plymouth-quit-wait.service
         12.330s dev-sda1.device
         12.181s keyboard-setup.service

Hi Kloos
nmbd is the Samba Service, can you post the result of:

Code: [Select]
systemctl status nmbd.service
plymouth-start.service is responsible for logging errors during boot (amongst other things).  Most likely reason why it is taking so long is that it is busy logging errors so we need to find out what errors are being logged.  Can you post the result of:

Code: [Select]
sudo dmesg | grep -i "error\|warn\|fail"
and finally, we need to know a bit more about the hardware in your laptop to help identify if there are any known bugs that could be affecting performance so can you post the output of

Code: [Select]
inxi -Fz
I have a similar laptop, a Dell 631 which has AMD opposed to Intel like yours and it is one of my favourite laptops.  I'm sure with a little bit of tweaking, you will have a very capable laptop.
Title: Re: Very slow boot time for Latitude D630
Post by: kloos on July 28, 2018, 11:31:11 pm
If you read through the whole thread...
Are you willing to try a different kernel?
What version of Peppermint are you running and what's the output of
Code: [Select]
uname -a
I guess i might have to try a different one.

Linux martin-Latitude-D630 4.15.0-29-generic #31-Ubuntu SMP Tue Jul 17 15:39:52 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
Title: Re: Very slow boot time for Latitude D630
Post by: kloos on July 28, 2018, 11:32:39 pm
 nmbd.service - Samba NMB Daemon
   Loaded: loaded (/lib/systemd/system/nmbd.service; enabled; vendor preset: enabled)
   Active: failed (Result: timeout) since Sun 2018-07-29 07:26:24 BST; 5min ago
     Docs: man:nmbd(8)
           man:samba(7)
           man:smb.conf(5)
  Process: 747 ExecStart=/usr/sbin/nmbd --foreground --no-process-group $NMBDOPTIONS (
 Main PID: 747 (code=killed, signal=TERM)
   Status: "nmbd: No local IPv4 non-loopback interfaces available, waiting for interfa

Jul 29 07:24:54 martin-Latitude-D630 systemd[1]: Starting Samba NMB Daemon...
Jul 29 07:26:24 martin-Latitude-D630 systemd[1]: nmbd.service: Start operation timed o
Jul 29 07:26:24 martin-Latitude-D630 systemd[1]: nmbd.service: Failed with result 'tim
Jul 29 07:26:24 martin-Latitude-D630 systemd[1]: Failed to start Samba NMB Daemon.
Title: Re: Very slow boot time for Latitude D630
Post by: kloos on July 28, 2018, 11:33:49 pm
Wow lots of errors

[    0.220125] acpi PNP0A03:00: _OSC failed (AE_NOT_FOUND); disabling ASPM
[    0.353556] pci 0000:03:01.0: BAR 15: failed to assign [mem size 0x04000000 pref]
[    0.353570] pci 0000:03:01.0: BAR 16: failed to assign [mem size 0x04000000]
[    0.353597] pci 0000:03:01.0: BAR 16: failed to assign [mem size 0x04000000]
[    0.353612] pci 0000:03:01.0: BAR 15: failed to assign [mem size 0x04000000 pref]
[    1.928369] RAS: Correctable Errors collector initialized.
[    3.216220] ata4.01: failed to resume link (SControl 0)
[   14.048243] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:34:pipe A] flip_done timed out
[   14.152289] WARNING: CPU: 0 PID: 96 at /build/linux-60XibS/linux-4.15.0/drivers/gpu/drm/drm_vblank.c:1073 drm_wait_one_vblank+0x181/0x190 [drm]
[   24.288231] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:34:pipe A] flip_done timed out
[   34.528232] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:plane A] flip_done timed out
[   40.420863] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[   51.519053] leds dell::kbd_backlight: Setting an LED's brightness failed (-5)
[   63.968255] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:34:pipe A] flip_done timed out
[   64.072322] WARNING: CPU: 0 PID: 512 at /build/linux-60XibS/linux-4.15.0/drivers/gpu/drm/drm_vblank.c:1073 drm_wait_one_vblank+0x181/0x190 [drm]
[   74.208244] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:34:pipe A] flip_done timed out
[   84.448247] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:plane A] flip_done timed out
[  101.856275] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  101.960363] WARNING: CPU: 0 PID: 512 at /build/linux-60XibS/linux-4.15.0/drivers/gpu/drm/drm_vblank.c:1073 drm_wait_one_vblank+0x181/0x190 [drm]
[  112.096235] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  122.336239] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
[  133.344287] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  133.447905] WARNING: CPU: 1 PID: 759 at /build/linux-60XibS/linux-4.15.0/drivers/gpu/drm/drm_vblank.c:1073 drm_wait_one_vblank+0x181/0x190 [drm]
[  143.584291] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  153.824273] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
[  164.064256] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  164.168351] WARNING: CPU: 0 PID: 759 at /build/linux-60XibS/linux-4.15.0/drivers/gpu/drm/drm_vblank.c:1073 drm_wait_one_vblank+0x181/0x190 [drm]
[  174.304262] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  184.544253] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
[  207.072083] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  207.176181] WARNING: CPU: 1 PID: 759 at /build/linux-60XibS/linux-4.15.0/drivers/gpu/drm/drm_vblank.c:1073 drm_wait_one_vblank+0x181/0x190 [drm]
[  217.314137] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  227.552716] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
[  238.816239] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  238.920230] WARNING: CPU: 0 PID: 759 at /build/linux-60XibS/linux-4.15.0/drivers/gpu/drm/drm_vblank.c:1073 drm_wait_one_vblank+0x181/0x190 [drm]
[  249.056228] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  254.707726] xdg-desktop-por[1247]: segfault at 8 ip 000055bf587147c8 sp 00007fff77028e00 error 4 in xdg-desktop-portal[55bf58701000+7c000]
[  259.296241] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
Title: Re: Very slow boot time for Latitude D630
Post by: kloos on July 28, 2018, 11:35:54 pm
System:    Host: martin-Latitude-D630 Kernel: 4.15.0-29-generic x86_64 bits: 64
           Desktop: N/A Distro: Peppermint Nine
Machine:   Device: portable System: Dell product: Latitude D630 serial: N/A
           Mobo: Dell model: 0KU184 serial: N/A BIOS: Dell v: A17 date: 01/04/2010
Battery    BAT0: charge: 30.6 Wh 86.5% condition: 35.3/57.7 Wh (61%)
CPU:       Dual core Intel Core2 Duo T7100 (-MCP-) cache: 2048 KB
           clock speeds: max: 1801 MHz 1: 1131 MHz 2: 1132 MHz
Graphics:  Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1280x800@60.04hz
           OpenGL: renderer: Mesa DRI Intel 965GM version: 2.1 Mesa 18.0.5
Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-29-generic
Network:   Card-1: Broadcom Limited NetXtreme BCM5755M Gigabit Ethernet PCIE
           driver: tg3
           IF: enp9s0 state: down mac: <filter>
           Card-2: Intel PRO/Wireless 3945ABG [Golan] Network Connection
           driver: iwl3945
           IF: wlp12s0 state: up mac: <filter>
Drives:    HDD Total Size: 120.0GB (7.1% used)
           ID-1: /dev/sda model: ST9120411ASG size: 120.0GB
Partition: ID-1: / size: 110G used: 8.0G (8%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 47.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 155 Uptime: 11 min Memory: 1037.3/3935.8MB
           Client: Shell (bash) inxi: 2.3.56
Title: Re: Very slow boot time for Latitude D630
Post by: kloos on July 28, 2018, 11:36:58 pm
btw sorry for the slow response I was away yesterday.  back with it today and thanks for your help :-)
Title: Re: Very slow boot time for Latitude D630
Post by: kloos on July 29, 2018, 01:10:06 am
Interesting.  I've tried (just out of interest) about 5 other distro's booted from USB and have the same slow times and errors booting with all of them.  Except Elementary which showed an error but zoomed past it rather than hanging like all of the others did.  As it happens I don't like to look or feel of Elementary.
Title: Re: Very slow boot time for Latitude D630
Post by: pin on July 29, 2018, 01:23:12 am
What kernel is present in the elementary OS live-usb?
Code: [Select]
uname -a
EDIT: Just checked it on distrowatch. Unless you are trying the 5.0-beta release, which runs the 4.15 kernel, it should be the 4.8!
Title: Re: Very slow boot time for Latitude D630
Post by: kloos on July 29, 2018, 02:52:34 am
What kernel is present in the elementary OS live-usb?
Code: [Select]
uname -a
EDIT: Just checked it on distrowatch. Unless you are trying the 5.0-beta release, which runs the 4.15 kernel, it should be the 4.8!
Linux elementart 4.13.0-32-generic #35~16.04.1-Ububtu SMP Thu Jan 24 10:13:43 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
Title: Re: Very slow boot time for Latitude D630
Post by: TonyBronze on July 29, 2018, 03:16:42 am
Before changing kernels can you try:

Code: [Select]
sudo xed /etc/default/grubLook for the line that contains quiet splash then add the kernel boot parameter: video=SVIDEO-1:d

Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"
save and exit then

Code: [Select]
sudo update-grub
then reboot and see if it boots any quicker.
Title: Re: Very slow boot time for Latitude D630
Post by: kloos on July 29, 2018, 03:51:20 am
Hi TonyBronze.
That is amazing.  Not quite as fast as it used to be on my old laptop but from 5 minutes to 1.5 minutes is a huge improvement. Thank you so much.

Martin
Title: Re: Very slow boot time for Latitude D630
Post by: TonyBronze on July 29, 2018, 04:09:05 am
Not finished yet :)

Samba was also slowing things down.  Maybe an idea to disable it.  There are other ways to file share if you need to such as Nitro Share.

To disable it copy/paste:

Code: [Select]
sudo apt remove samba
Title: Re: Very slow boot time for Latitude D630
Post by: kloos on July 29, 2018, 04:16:47 am
 8)
That's done.  We're down to 1 minute 12 seconds.  I only use the laptop for libre office, email and browsing so dont need filesharing.  Files are saved on dropbox.
Title: Re: Very slow boot time for Latitude D630
Post by: pin on July 29, 2018, 04:34:39 am
You could try removing apparmor and btrfs to see if you gain a few more seconds.

Skickat från min SM-G900F via Tapatalk
Title: Re: Very slow boot time for Latitude D630
Post by: kloos on July 29, 2018, 08:04:29 am
Thanks Pin, I removed those but it didn't make any difference to log in time.

5 seconds for the bios
44 seconds of black screen before you see the logo
57 seconds to to the log in screen
1 min 14 to backdrop.

Title: Re: Very slow boot time for Latitude D630
Post by: TonyBronze on July 29, 2018, 08:16:09 am
Can you post output from
Code: [Select]
systemd-analyze blame to see if there is anything else we can blame :)
Title: Re: Very slow boot time for Latitude D630
Post by: kloos on July 29, 2018, 10:18:54 am
Can you post output from
Code: [Select]
systemd-analyze blame to see if there is anything else we can blame :)

Thin pickings now, but loving all of your help.

         14.518s dev-sda1.device
         13.446s systemd-journal-flush.service
         12.906s keyboard-setup.service
         10.588s systemd-tmpfiles-setup-dev.service
          7.470s systemd-sysctl.service
          6.439s NetworkManager-wait-online.service
          4.166s plymouth-start.service
          3.294s systemd-modules-load.service
          3.108s NetworkManager.service
          2.939s networkd-dispatcher.service
          2.813s mintsystem.service
          2.148s ModemManager.service
          1.766s udisks2.service
          1.399s accounts-daemon.service
          1.231s wpa_supplicant.service
          1.129s run-rpc_pipefs.mount
          1.118s lightdm.service
          1.113s plymouth-quit-wait.service
          1.108s systemd-rfkill.service
Title: Re: Very slow boot time for Latitude D630
Post by: TonyBronze on July 29, 2018, 01:09:20 pm
Doesn't look like there is much more to do there.  Looks about the same as my D631

Only other thing that may help is tweak the set up

Press F2 when you boot.

Under system, Boot Sequence make sure the Internal HDD is at the top of the list
Under Onboard Devices Integrated NIC change to just "enabled"
Internal Modem turn off
Parallel Port turn off (this would only apply if you have a dock)
Under Video Set the video memory size to 128mb
Security - nothing to do there
After security I have performance but it refers to the AMD CPU.  If you have a performance option, make sure it is turned on
Under Wireless, If you are not using internal cellular, then turn it off

I think thats all
Title: Re: Very slow boot time for Latitude D630
Post by: VinDSL on July 29, 2018, 04:49:37 pm
Great ideas, all the way around. Only thing I can add is that I personally find the following command ...

Code: [Select]
systemd-analyze critical-chain... more useful than ...

Code: [Select]
systemd-analyze blame
It's a little more 'in your face' so perps standout.  Here's a (positive) example - my 14 year-old, 32-bit Dell 'doorstop' test box.

Peppermint 9 boots in 14 seconds, which is amazing in itself, but in the pic you can see everything is fairly congruous.

I'm used to seeing Network Manager and other pigs taking 30 seconds or more to load in other vers.

Must say, I didn't need to tweak Peppermint 9  much to get low boot times. Hats-off to Mark.  8)

Nothing left to do here ...


(http://vindsl.com/images/VinDSL-Selectionshot_2018-07-29_16:21:34.png)
Title: Re: Very slow boot time for Latitude D630
Post by: VinDSL on July 29, 2018, 04:54:25 pm
BTW, for the sake of conversation, here's my stupid-simple GRUB config ...

Code: [Select]
# If you change this file, run 'update-grub' afterwards to update
GRUB_DEFAULT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="elevator=deadline quiet splash"
GRUB_CMDLINE_LINUX="libata.force=noncq"

That's it - the whole enchilada. LoL  :D
Title: Re: Very slow boot time for Latitude D630
Post by: TonyBronze on July 29, 2018, 05:15:28 pm
The problem here was more to do with the bug that effects some Intel graphic chips caused by the 14.15.0 kernel.  Fortunately disabling S-Video using the grub command cured the main problem but I would be hesitant to make any further changes to the grub config in this case as it could reintroduce the bug again. 
Title: Re: Very slow boot time for Latitude D630
Post by: VinDSL on July 29, 2018, 05:24:29 pm
Agreed.

Good job!  ;)




Title: Re: Very slow boot time for Latitude D630
Post by: kloos on July 30, 2018, 01:25:17 am
Great ideas, all the way around. Only thing I can add is that I personally find the following command ...

Code: [Select]
systemd-analyze critical-chain... more useful than ...

Code: [Select]
systemd-analyze blame
It's a little more 'in your face' so perps standout.  Here's a (positive) example - my 14 year-old, 32-bit Dell 'doorstop' test box.


So I ran  critical-chain and this is what I got...

graphical.target @30.917s
└─multi-user.target @30.917s
  └─hddtemp.service @30.873s +43ms
    └─network-online.target @30.870s
      └─NetworkManager-wait-online.service @24.458s +6.411s
        └─NetworkManager.service @20.796s +3.659s
          └─dbus.service @20.426s
            └─basic.target @20.400s
              └─systemd-ask-password-plymouth.path @20.400s
                └─plymouth-start.service @16.113s +4.196s
                  └─keyboard-setup.service @2.726s +13.384s
                    └─systemd-journald.socket @2.646s
                      └─system.slice @2.646s
                        └─-.slice @2.640s

Very interesting to see what is causing the boot time.  Not that I have a clue how to resolve it.  That's where you guys come in.  Fantastic stuff!

Martin
Title: Re: Very slow boot time for Latitude D630
Post by: VinDSL on July 30, 2018, 07:58:02 am
Interesting.

On face value,it looks like systemd is waiting for your drive(s) to be up and visible to the system.

Never run across this situation before, so not sure how to progress.

Might try booting into 'init' and seeing what happens.
Title: Re: Very slow boot time for Latitude D630
Post by: kloos on July 30, 2018, 08:12:03 am
I would, but i don't know what init is?

Just noted, yay me I'm now a Jnr Member of the forum and not a Newbe anymore  8) :D
Title: Re: Very slow boot time for Latitude D630
Post by: VinDSL on July 30, 2018, 08:29:13 am
Okay, forget that. You're getting there ...  ;D

I did a quick search on your spinner and evidently that series had probs that required a firmware update: https://goo.gl/yXbsMQ

If it was me, I'd start looking for a SSD. I prefer HGST Travelstar SSDs for my portables - I think Mark likes WB Blacks.

For a long time, my Dell D630 ATG (with a cheap SanDisk SSD) was the fastest machine in the house.

Anyway, I'm guessing this will be the upshot. If not, at least you'll have a very fast lappy, once it boots.

Or, maybe somebody will have a better idea. Who knows? It's a crap shoot at this point IMO.
Title: Re: Very slow boot time for Latitude D630
Post by: TonyBronze on July 30, 2018, 08:43:47 am
I have a Dell D631, very similar but with AMD instead of Intel CPU and the disk access time is about the same.  My thoughts too are that it would be a lot quicker with a SSD but its fast enough for me for what I use it for :)

Congrats kloos on becoming a Junior Member  ;D :) 8)
Title: Re: Very slow boot time for Latitude D630
Post by: VinDSL on July 30, 2018, 09:20:49 am
Okay, now you guys did it.

I yanked my D630 ATG off the back of the bench and I'm going to do an update.

Been awhile. Clock is set for New York time, and I haven't been in that timezone in years - probably a business trip to St. Pete (https://www.visitflorida.com/en-us/cities/st-petersburg.html). That's the last time I remember using 'Road Warrior 1".

Better play it safe and do a 'Default' update.  8)
Title: Re: Very slow boot time for Latitude D630
Post by: VinDSL on July 30, 2018, 10:12:59 am
570+ updates. MegaSync download is holding things up  ::)


(http://vindsl.com/images/IMG_20180730_094418234.png)


It's a sickness. What can I tell ya?  ;D


(http://vindsl.com/images/IMG_20180730_094012702_HDR.png)


EDIT

Excuse the grainy pics - used a $49 USD phone - too lazy to go in the other room and get a real camera  ;)
Title: Re: Very slow boot time for Latitude D630.
Post by: VinDSL on July 30, 2018, 11:20:34 am
Guess Fx doesn't get along with Greasemonkey these days - Fx kept welcoming me back, then hardlocking.  ::)

Anyway, apples n' oranges, but here are my D630's stats on P7:

Code: [Select]
vindsl@Gatekeeper ~ $ systemd-analyze time
Startup finished in 2.405s (kernel) + 7.166s (userspace) = 9.571s
vindsl@Gatekeeper ~ $ systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @7.143s
└─multi-user.target @7.143s
  └─smbd.service @6.835s +307ms
    └─nmbd.service @5.525s +1.308s
      └─network-online.target @5.506s
        └─network.target @5.496s
          └─networking.service @5.182s +309ms
            └─apparmor.service @1.085s +3.942s
              └─local-fs.target @1.068s
                └─home.mount @1.051s +13ms
                  └─systemd-fsck@dev-disk-by\x2duuid-2f5f7683\x2d6dc5\x2d4181\x2d8512\x2de9b9a9eaa338.service @1.000s +30ms
                    └─dev-disk-by\x2duuid-2f5f7683\x2d6dc5\x2d4181\x2d8512\x2de9b9a9eaa338.device @999ms
vindsl@Gatekeeper ~ $

And, this is just a run-of-mill 2.6GHz Core 2 Duo AKA Centrino Duo (https://goo.gl/Z3jyH8) with a cheap SanDisk SSD.

Peppermint 9 should be just as fast or faster.

EDIT

On second thought, anybody can claim they're running anything, so here ya go...  :)

Spoiler (click here to view / hide)
[close]
Title: Re: Very slow boot time for Latitude D630
Post by: VinDSL on July 30, 2018, 12:14:51 pm
WoW! I have a totally tweaked and customized Peppermint 5 (EOL 2019) install on this thing.

If I dual-booted it with Peppermint 9 (EOL 2023), I wouldn't need to upgrade for another 5 years.

Isn't Peppermint (and Dell) fun?

Okay, back on topic, I promise...  8)
Title: Re: Very slow boot time for Latitude D630
Post by: kloos on July 31, 2018, 03:53:24 am
Gosh VinDSL that's quite some set up there!

Overall i am happy with P9 on my D630.  It doesn't seem quite as nippy as my old Pavilion running P8 (now defunct) as the programmes take slightly longer to load and that boot time is still slower than the old beastie but a few seconds in my life here and there I can wait.  The only thing I might do is get a higher capacity battery as the current one only lasts a few hours compared to my Toshiba Portege which gets over 5 hours.  Still for £60 I'm not complaining... at least not now that you've all helped with the boot up time  :P
Title: Re: Very slow boot time for Latitude D630
Post by: VinDSL on July 31, 2018, 04:34:16 am
The only thing I might do is get a higher capacity battery as the current one only lasts a few hours compared to my Toshiba Portege which gets over 5 hours.

Oh, hell, yeah! Glad you mentioned that.

I always buy genuine Dell "slice batteries". They have good quality cells inside them - Jap cells are preferable , but Korean are okay too. Stay away from cheap 3rd party batteries with Chinese cells which tend to catch fire and/or explode. I have OEM Dells for my D630 ATG, and E6430.

They aren't cheap, but they're worth their weight in gold!

Without a slice battery, I'm lucky if I get 3-4 hours of battery time, then I'm looking for a 120v electrical outlet. Plus, it means I need to lug a wall charger around all day/night. I prefer to carry an extra (standard) battery with me. It's smaller, and less of a hassle - and leave the damn charger in my hotel room safe.

I can't remember ever running out of battery time with a slice battery. I setup my Dell lappies to "suspend" when I close their lids (no password required to unsuspend). I use my laptops when I need them, then close the lids when I don't. That way, I can go all day/night without recharging them. When I get back to the room, I leave them on the charger overnight - slice batteries take several hours to charge.

Nothing worse than running out of power in an airport concourse - on the plane - at a luncheon - sitting on an airplane or at a convention table. Wall outlets are extremely impractical or impossible to find, in these situations, not to mention embarrassing in certain situations.

Highly recommended  8)




Title: Re: Very slow boot time for Latitude D630
Post by: kloos on July 31, 2018, 05:00:27 am

They aren't cheap, but they're worth their weight in gold!


Just been to Dell website and they'd have to be made of gold for that price  :o.  That's more than I paid for the laptop  :D.  I have used 3rd party before with mixed results so will probably stick with this one until the capacity drops too much.  I tend to use it at lunch time for non-work stuff so in reality only need an hours go-go juice.  I just wanted to be lazy and not have to charge it as often.
Title: Re: Very slow boot time for Latitude D630
Post by: VinDSL on July 31, 2018, 08:26:37 am
I buy my Dell batteries on eBay for pennies on the wholesale dollar. [emoji6]


Sent from my Moto E⁴ via Tapatalk

Title: Re: Very slow boot time for Latitude D630
Post by: VinDSL on July 31, 2018, 03:48:13 pm
BTW, I'm actually running dual batteries in my Dell D630 ATG.

I just did a quick search for a Genuine Dell D630 Secondary Battery (Jap cells) on eBay: https://goo.gl/mMZuny

The combination of this 6-cell secondary battery, along with a 9-cell slice battery gives me 15-cells.

That said, it's probably overkill, if you're just using it during your lunch break.  ;D

Notice: This is for the sake of discussion. I'm not trying to sell anybody anything.
Title: Re: Very slow boot time for Latitude D630
Post by: PCNetSpec on August 01, 2018, 05:29:47 am
So if I said "Hey Mr Dizl, sell me your batteries for $500" you'd now have to say no ? :)
Title: Re: Very slow boot time for Latitude D630
Post by: VinDSL on August 01, 2018, 03:25:20 pm
LoL!  :D