Peppermint OS

Support => Advanced Topics => Topic started by: zebedeeboss on July 26, 2018, 10:06:15 am

Title: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
Post by: zebedeeboss on July 26, 2018, 10:06:15 am
Hi

I am trying to use OBS to capture my ETS2 game play as per usual - however

In Pep 9 with the AMD card I am getting a black window when I tell it to look at the ETS window.

This does not happen in windows 10 and does not happen in Fedora 28

Both Pep and Fedora are using

Code: [Select]
zebedee@i7-peppermint ~ $ glxinfo | grep "OpenGL version"
OpenGL version string: 3.0 Mesa 18.0.5
zebedee@i7-peppermint ~ $

Regards Zeb...

ps I have tried all things I can find in google search

This happens on the 4.15.0-29 kernel and the 4.17.9-041709 kernel
Title: Re: Capture Problems n OBS-Studio with AMD graphics
Post by: TonyBronze on July 26, 2018, 10:15:21 am
Have you tried selecting use alpha less texture format (Mesa Workaround)  Scroll to the bottom of the window properties to find it.
Title: Re: Capture Problems n OBS-Studio with AMD graphics
Post by: zebedeeboss on July 26, 2018, 10:16:55 am
Hiya TB,

Yeah and all I get is a washed out pink affect  :(

Regards Zeb...
Title: Re: Capture Problems n OBS-Studio with AMD graphics
Post by: TonyBronze on July 26, 2018, 10:36:40 am
Hiya Zeb

Bit of a long shot but are you using a Peppermint Theme?  If so can you try using Adwaita-dark to eliminate that it may be a problem.

Reason being, Kdenlive doesn't like the Peppermint themes and gives black boxes for the save as /open file boxes but works fine with Adwaita-Dark.

Tony
Title: Re: Capture Problems n OBS-Studio with AMD graphics
Post by: zebedeeboss on July 26, 2018, 10:43:44 am
Hiya TonyB

Great shout but no luck unfortunately.  A friend of mine DasGeek, also has a Vega 64 card and he says he does not get the issue with xubuntu.  Very odd

Regards Zeb...
Title: Re: Capture Problems n OBS-Studio with AMD graphics
Post by: zebedeeboss on July 26, 2018, 11:00:48 am
When I try and install OBS from the OBS PPA I am getting the following error

Quote
E: /var/cache/apt/archives/obs-studio_21.1.0-0obsproject1~bionic_amd64.deb: trying to overwrite '/usr/share/obs/libobs/bicubic_scale.effect', which is also in package libobs0:amd64 21.0.2+dfsg1-1

and then this
Quote
(Reading database ... 384009 files and directories currently installed.)
Preparing to unpack .../obs-studio_21.1.0-0obsproject1~bionic_amd64.deb ...
Unpacking obs-studio (21.1.0-0obsproject1~bionic) over (21.0.2+dfsg1-1) ...
dpkg: error processing archive /var/cache/apt/archives/obs-studio_21.1.0-0obsproject1~bionic_amd64.deb (--unpack):
 trying to overwrite '/usr/share/obs/libobs/bicubic_scale.effect', which is also in package libobs0:amd64 21.0.2+dfsg1-1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/obs-studio_21.1.0-0obsproject1~bionic_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...

Regards Zeb...

Title: Re: Capture Problems n OBS-Studio with AMD graphics
Post by: TonyBronze on July 26, 2018, 12:15:47 pm
I got the same error with the PPA and ended up using the snap pack
Title: Re: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
Post by: zebedeeboss on July 26, 2018, 01:22:13 pm
Thanks TonyB,

The Snap pack of OBS-Studio worked

Regards Zeb...
Title: Re: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
Post by: PCNetSpec on July 26, 2018, 04:27:15 pm
If you want the PPA version, try running:
Code: [Select]
sudo apt-get remove --purge libobs0then installing the version from the PPA
Title: Re: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
Post by: zebedeeboss on July 27, 2018, 02:46:30 am
Thanks

I will keep those instructions to hand if the Snap version gives me grief.

Regards Zeb...
Title: Re: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
Post by: TonyBronze on July 27, 2018, 02:55:58 am
I have tried it and it worked to install the PPA version.
Title: Re: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
Post by: zebedeeboss on July 27, 2018, 03:32:05 am
Oh this just gets better and better - Sigh!!!

Now the snap OBS does not recognise my video driver...

(https://i.imgur.com/gRjWe5L.png)

Gong to try the ppa version again.

Regards Zeb...
Title: Re: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
Post by: zebedeeboss on July 27, 2018, 03:40:59 am
Happy to report all working AOK now on the OBS PPA

Regards Zeb...
Title: Re: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
Post by: PCNetSpec on July 27, 2018, 04:06:06 am
Nice :)
Title: Re: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
Post by: stevesveryown on July 27, 2018, 06:40:47 am
Zeb,

I don't think this was exclusive to amd. I was getting it on my desktop with nvidia graphics. I was trying to record gimp 2.10, snap version, in obs. I had closed obs and opened again and I was able to find the gimp window. When I do set for desktop recording I do get black screen.

Sent from my SM-T813 using Tapatalk