Peppermint OS

Support => New Users => Topic started by: Cajun_Man0001 on June 22, 2018, 05:24:41 pm

Title: Turn On/Off System Sounds
Post by: Cajun_Man0001 on June 22, 2018, 05:24:41 pm
I remember in Peppermint 8 I turned on System Sounds and after a reboot I was getting sounds on certain things. 

But on Peppermint 9, I installed ubuntu-sounds and activate System Sounds and reboot and so far no sounds from anything.  I know Sound is working as I played a game and watched a youtube video so I know sound is working. 

Under Customize Look and feel in the Other tab, both Play event sounds and play event sounds as feedback to user input are both checked.

Just wondering if there is something else needs to be installed to get it working, or does it work under Pep 9?
Title: Re: Turn On/Off System Sounds
Post by: mac on June 22, 2018, 05:44:12 pm
Try this...
Right click on the speaker icon in your panel and open Properties.  That will open the PulseAudio Panel Plugin window and you will see "Run Audio Mixer."  Open that and check the Playback and the Output Devices tabs and ensure they are properly set & activated. 
Title: Re: Turn On/Off System Sounds
Post by: Cajun_Man0001 on June 22, 2018, 08:36:18 pm
They are both set. Playback is set to 100% and Output device is set to 75%. 
Title: Re: Turn On/Off System Sounds
Post by: AndyInMokum on June 22, 2018, 11:38:38 pm
Hi Cajun_Man0001, welcome to the Peppermint Forum.  It' really nice to meet you  ;).   Try this.  Navigate to:

menu > Favorites > Peppermint Settings Panel > Customise Look and Feel

In the Customise Look and Feel window, select the: Other tab.  Under the subheading: Sound Effect.  Make sure both boxes are checked/ticked.  It might be a good idea to logout and back in.  Do your sound effects now work  ;)?
Title: Re: Turn On/Off System Sounds
Post by: Cajun_Man0001 on June 23, 2018, 08:24:43 am
Nope. 

I went to Customize Look and Feel and opened the other tab, both were checked and logged out and back in, nothing, I even went to tweaks and re-selected On on the Sound effects and logged off and back in and no sound logging in, no sound opening or closing windows.  Nothing, except games and youtube videos make sound.

I seem to remember this working in Peppermint 7, and both 8 and the 8 respin.

But cannot seem to get any system sounds under Peppermint 9.
Title: Re: Turn On/Off System Sounds
Post by: PCNetSpec on June 23, 2018, 04:50:02 pm
Okay I've just pushed an update to peppermint-settings-panel and peppermint-system-sounds that should fix this.

Open a terminal and run:
Code: [Select]
sudo apt-get updatethen
Code: [Select]
sudo apt-get upgradenow go to:-

Menu > Settings > Peppermint Settings Panel

Choose the "Tweaks" tab

select "Turn On/Off System sounds"

enter your password when prompted.

Click the "On" button.

Now log off and on again .. and system sounds should now work.



You can turn them off again in the same place, just click the "Off" button instead of the "On" .. then log off/on.
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 27, 2018, 11:59:27 am
Okay I've just pushed an update to peppermint-settings-panel and peppermint-system-sounds that should fix this.

Open a terminal and run:
Code: [Select]
sudo apt-get updatethen
Code: [Select]
sudo apt-get upgradenow go to:-

Menu > Settings > Peppermint Settings Panel

Choose the "Tweaks" tab

select "Turn On/Off System sounds"

enter your password when prompted.

Click the "On" button.

Now log off and on again .. and system sounds should now work.



You can turn them off again in the same place, just click the "Off" button instead of the "On" .. then log off/on.

Hi,

Looks like I'm in the same situation as Cajunman.   Computer plays if I play videos like on youtube.  But don't hear any system sounds.  For example, when I reboot or shutdown, don't hear any system sounds.

I tried the suggestions.   Still not working  :(.
Title: Re: Turn On/Off System Sounds
Post by: PCNetSpec on June 27, 2018, 01:28:44 pm
You won't get startup and shutdow sounds .. that takes a lot more hacking in LXDE/Xfce

But you should get a "plonk" sound if you right-click a file and select "delete" or "move to trash".

You'll get some more sounds if you install "ubuntu-sounds", but you still won't get startup/shutdown sounds.
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 27, 2018, 02:30:09 pm
Thanks for the clarifications.

Computer still doesn't get a plunk or trash empty noise. 

Oddly, I did get a bonk noise when backspacing into a field that reached the end (forget which field or screen I was on now).

I'm not going to worry about too much though as I actually was kinda admiring how quiet things are before I came upon this thread.
Title: Re: Turn On/Off System Sounds
Post by: PCNetSpec on June 27, 2018, 03:06:26 pm
Yeah system sounds are a gimmick that wear thin pretty quickly IMHO :)
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 27, 2018, 04:05:43 pm
As a quick follow up, I found out where that "bonk" noise was coming from.  I had installed ubuntu-sounds  to give that a try.

Decided to remove ubuntu-sounds though as that was just a test.
Title: Re: Turn On/Off System Sounds
Post by: PCNetSpec on June 27, 2018, 07:09:17 pm
Well at least it proves system sounds are working, if nothing else :)

I'll try looking into this when I get tiem, because now system sounds should behave the same in PM8 and PM9 :-\
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 28, 2018, 06:14:04 pm
Decided to do some (hopefully) process of elimination. 

I installed Pep OS 8 on the laptop to see if I could get any system sounds.  Nope.  I wonder now might my no system sound thing be hardware related?   What I may try next is to try installing OS 9 on an different brand laptop to see if I get any system sounds that way.

At least I do have some spare, empty hard drives to test with  :).
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 28, 2018, 07:12:22 pm
Okay.  Installed Pep OS 9 on another brand laptop.  Still no systems sounds for me.
Title: Re: Turn On/Off System Sounds
Post by: PCNetSpec on June 29, 2018, 04:16:57 pm
I think you might be expecting too much...

By default there are only a few sounds .. such as the one where you right-click a file and select delete .. you should get a system sound when the "Are you sure" dialog appears.
Title: Re: Turn On/Off System Sounds
Post by: PCNetSpec on June 29, 2018, 05:13:54 pm
Try installing gnome-session-canberra and sox
Code: [Select]
sudo apt-get install gnome-session-canberra sox ubuntu-soundsthen logging off/on

Did that make any differences ?
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 29, 2018, 06:04:29 pm
Okay, I won't worry about it.  Probably just suffering from FOMO (fear of missing out)  :(
Title: Re: Turn On/Off System Sounds
Post by: PCNetSpec on June 29, 2018, 06:10:03 pm
Did you try the fix in my last post ?

It's weird .. on one of my PC's (23bit Peppermint 9). like you very few system sounds were working (just the one you mentioned when backspacing a text filed until it was empty) .. I installed sox and still only the one system sound .. then I installed gnome-session-canberra .. logged off/on and they all started to work.

Purged gnome-session-canberra .. and they stayed working, even after a reboot .. go figure :-\
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 29, 2018, 06:40:46 pm
Tried the fix on your last post.    Didn't fix.

Laptop has the same as only sound when backspacing end of box, but no sound when trying to delete or empty trash.
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 29, 2018, 06:46:44 pm
Did you try the fix in my last post ?

It's weird .. on one of my PC's (23bit Peppermint 9). like you very few system sounds were working (just the one you mentioned when backspacing a text filed until it was empty) .. I installed sox and still only the one system sound .. then I installed gnome-session-canberra .. logged off/on and they all started to work.

Purged gnome-session-canberra .. and they stayed working, even after a reboot .. go figure :-\

When you mention Purged  gnome-session-canberra , did you do a command to purge?  I didn't do that.
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 29, 2018, 06:57:41 pm
Don't know if it makes a difference or not, but I'm on 64 bit.
Title: Re: Turn On/Off System Sounds
Post by: PCNetSpec on June 29, 2018, 07:20:30 pm
The odd thing is, once they start to work, no amount of undoing what you just did stops them from working again :-\
(wonder if caching is somehow playing a role)

So figuring out what the fix was is proving to be difficult .. I'm going to have to reinstall a fresh copy of PM9 and make changes one at a time until I 'suss' what's going on.

No I doubt it's anything to do with  64bit .. they just worked on my 64bit machines so this is turning out to be some kinda weird voodoo majick
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 29, 2018, 07:25:59 pm
Okay. 

I appreciate your attempts.  But like I said in an earlier post, not that important.  As, I can easily visually see when the "delete" prompt appears or when the trash gets emptied.  But it sounds like you are similar to me in that wanting to know why something works or does not work.

Title: Re: Turn On/Off System Sounds
Post by: PCNetSpec on June 29, 2018, 07:33:12 pm
Can you try this for me...

run:
Code: [Select]
sudo apt-get install libcanberra-gtk-module libcanberra-gtk0 libcanberra-gtk3-0 libcanberra-gtk3-module libcanberra0 gnome-session-canberra soxthen:
Code: [Select]
sudo xed /etc/X11/Xsession.d/52libcanberra-gtk-module_add-to-gtk-modulesand make sure the file reads:-
Code: [Select]
# This file is sourced by Xsession(5), not executed.

if [ -z "$GTK_MODULES" ] ; then
GTK_MODULES="canberra-gtk-module"
else
GTK_MODULES="$GTK_MODULES:canberra-gtk-module"
fi

export GTK_MODULES
then run:
Code: [Select]
sudo xed /etc/X11/Xsession.d/52libcanberra-gtk3-module_add-to-gtk-modulesand make the file read
Code: [Select]
# This file is sourced by Xsession(5), not executed.

if [ -z "$GTK_MODULES" ] ; then
GTK_MODULES="canberra-gtk-module"
else
GTK_MODULES="$GTK_MODULES:canberra-gtk-module"
fi

export GTK_MODULES
Then log off/on before testing.

I'm DEFINITELY the type that wants to know why it doesn't work .. because it reflects badly on Peppermint when something we include doesn't work ;)



After testing this, if you wanna give up, just delete
Code: [Select]
sudo rm -v /etc/X11/Xsession.d/52libcanberra-gtk3-module_add-to-gtk-modulesand
Code: [Select]
sudo rm -v /etc/X11/Xsession.d/52libcanberra-gtk-module_add-to-gtk-modules
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 29, 2018, 08:12:02 pm
OK. I will try tomorrow and get back to you.
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 30, 2018, 05:44:16 am
I ran the steps suggested.   Didn't seem to have any effect.

Here is copy of terminal session:

wally@wally-Latitude-D620 ~ $ sudo apt-get install lincanberra-gtk-module libcanberra-gtk0 libcanberra-gtk3-0 libcanberra-gtk3-module libcanberra0 gnome-session-canberra sox
[sudo] password for wally:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package lincanberra-gtk-module
wally@wally-Latitude-D620 ~ $ sudo xed /etc/X11/Xsession.d/52libcanberra-gtk-module_add-to-gtk-modules
wally@wally-Latitude-D620 ~ $ sudo xed /etc/X11/Xsession.d/52libcanberra-gtk3-module_add-to-gtk-modules
wally@wally-Latitude-D620 ~ $

After each xed command, a screen popped up and I copied, pasted and save the GTK code you listed.

I don't my trying more test to try to figure out why no system sounds for me.
Title: Re: Turn On/Off System Sounds
Post by: murraymint on June 30, 2018, 06:58:48 am
That was a typo, it should be "libcanberra-gtk-module" not lin...
Title: Re: Turn On/Off System Sounds
Post by: PCNetSpec on June 30, 2018, 07:43:25 am
fixed above. :-[
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 30, 2018, 08:58:34 am
That was a typo, it should be "libcanberra-gtk-module" not lin...

Thanks for spotting that.
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 30, 2018, 09:00:46 am
The suggested test  fixed my sound issue  8).

A "PLUNK" never sounded so fine  :D.   Thanks!
Title: Re: Turn On/Off System Sounds
Post by: PCNetSpec on June 30, 2018, 09:57:12 am
Thanks MyOwnPepper .. I'll make the necessary changes to the peppermint-system-sounds package and push it as an update :)
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 30, 2018, 10:02:56 am
Thanks MyOwnPepper .. I'll make the necessary changes to the peppermint-system-sounds package and push it as an update :)

Looks like I spoke a bit too soon  :-\.  I have sound now, but just tested to see if I can turn system sound off by toggling the Tweaks setting off/on and can't.

As of now, sound stays on all the time  :-\.
Title: Re: Turn On/Off System Sounds
Post by: PCNetSpec on June 30, 2018, 10:12:03 am
You won't be able to until I push the update.

You'd need to turn off system sounds AND delete
Code: [Select]
sudo rm /etc/X11/Xsession.d/52libcanberra-gtk3-module_add-to-gtk-modules
This will all be automatics once I push the update.
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 30, 2018, 10:16:14 am
Ok.  Great  :)
Title: Re: Turn On/Off System Sounds
Post by: PCNetSpec on June 30, 2018, 10:56:19 am
Okay update released (peppermint-system-sounds_9.0.0.2)...

To install, run:
Code: [Select]
sudo apt-get updatethen
Code: [Select]
sudo apt-get dist-upgrade(or simply update via the update manager in the normal way)

The "Turn On/Of System Sounds" applet in the settings panel should now work.

Remember, when you make a change in that applet, the sounds won't be enabled/disabled until you log off/on.

And installing
Code: [Select]
sudo apt-get install ubuntu-soundswill give you MANY more event sounds.
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 30, 2018, 11:50:57 am
Made the update.  Works great!  :D

Thanks.
Title: Re: Turn On/Off System Sounds
Post by: PCNetSpec on June 30, 2018, 11:58:45 am
If you've installed ubuntu-sounds, and you find disabling system sounds still leaves you with just that backspace sound .. you can either uninstall ubuntu-sounds, or mute system sounds in PulseAudio Volume Control.

At least until I figure out where that single sound is coming from and how to disable it  :-\
Title: Re: Turn On/Off System Sounds
Post by: MyOwnPepper on June 30, 2018, 03:33:41 pm
Thanks for the tip. 

I decided to uninstall ubuntu-sounds and just keep the default system sounds and I like the "Plunk" sounds before deleting but do not need the extra ones of ubuntu-sounds.    Working great .