Peppermint OS Community Forum

Resources => User Submitted Tutorials => Topic started by: alynur on May 05, 2018, 03:02:15 am

Title: How to adjust mouse sensitivity in Peppermint 8
Post by: alynur on May 05, 2018, 03:02:15 am
Hello Peppermint people. I ran across this problem and figured it would make a good tutorial.
In order to change your mouse’s sensitivity, you will first have to identify your mouse, then you will have to experiment with different values to insure your mouse is acting like you want it to. Once you are satisfied, you will need to create a config file and include it in Autostart so the new configuration will be in effect every time you log on.
1. So first, open a terminal and enter
Code: [Select]
xinput --list –short
This will give you your mouse ID, in my case, it is “Logitech USB Optical Mouse                 id=8   [slave  pointer  (2)”.  You may then want to know your mouse’s default properties to get an idea of what value to change. Run
Code: [Select]
xinput --list-props "YourMouseID"
note; there is a space between props and “. Mine looked like this:
“Device Accel Constant Deceleration (273):   4.000000”  I slowed my mouse down by changing this from 1.000000.
2. To change the value, run
Code: [Select]
xinput --set-prop "YourMouseID" "Device Accel Constant Deceleration" 1.5(change this)
3. Once you are satisfied, create your autostart config file, run
Code: [Select]
sudo xed ~/.config/autostart/MouseConfig.desktop(or what ever you want to name it)
In the newly opened file, add:
[code][Desktop Entry]
Comment=Configure YourMouse sensitivity
Exec=sh -c 'xinput --set-prop "Your Mouse ID" "Device Accel Constant Deceleration" Your value'
Now save the file and close the terminal. Autostart the file by entering Menu/Preferences/Default applications for LXSessions/Autostart and enter the name of your new config file in the add box and click on the + to add it. That’s it! Now reboot to check functionality.
Title: Re: How to adjust mouse sensitivity in Peppermint 8
Post by: alynur on May 05, 2018, 03:03:46 am
Hmm, I wonder why the color selection didn't work.