Peppermint OS

Support => Installation => Topic started by: jlanep30 on June 05, 2017, 03:36:11 pm

Title: Grub install failed
Post by: jlanep30 on June 05, 2017, 03:36:11 pm
Having a problem installing Peppermint 8 64 bit on a Dell Inspiron 11 3000 (3148) I get a error message "the grub-efi amd64-signed  package failed to install" I'm trying to run it beside windows 10 an, Also my wifi doesn't work when running Peppermint on USB. Thanks!!
Title: Re: Grub install failed
Post by: PCNetSpec on June 05, 2017, 06:17:19 pm
have you tried disabling Secureboot in the BIOS ?
Title: Re: Grub install failed
Post by: jlanep30 on June 05, 2017, 09:16:36 pm
Boot Mode is set to: UEFI with Legacy OPROM; Secure Boot: OFF

The other options I have is:

"Legacy Boot Mode, Secure Boot Off"

"UEFI Boot Mode, Secure Boot On"

Title: Re: Grub install failed
Post by: zebedeeboss on June 05, 2017, 10:24:54 pm
Hi JLanep30,

Have you made sure windows "Fast startup" is also turned off.

https://www.howtogeek.com/243901/the-pros-and-cons-of-windows-10s-fast-startup-mode/ (https://www.howtogeek.com/243901/the-pros-and-cons-of-windows-10s-fast-startup-mode/)  <<<  instructions on how to turn off are here, a little further down the article.

Regards Zeb...

Title: Re: Grub install failed
Post by: PCNetSpec on June 06, 2017, 04:39:58 am
After making sure Windows fast boot/startup is disabled (see zebs post above), can you boot to the LiveUSB and post the output from:
Code: [Select]
sudo fdisk -l
Title: Re: Grub install failed
Post by: jlanep30 on June 06, 2017, 07:42:46 pm
Thanks Guys! I'm out of town till tomorrow and going to try this when I get back....
Title: Re: Grub install failed
Post by: jlanep30 on June 07, 2017, 03:43:46 pm
I tired to turn fast boot off but does t give me the option to turn on or off..
Title: Re: Grub install failed
Post by: jlanep30 on June 07, 2017, 03:51:08 pm
I also read where you had to enable hibernation through command prompt which I tried but I get a "unable to perform operation. An unexpected error(0x65b) has occurred: function failed during execution."
Title: Re: Grub install failed
Post by: PCNetSpec on June 07, 2017, 07:44:42 pm
can you boot to the LiveUSB and post the output from:
Code: [Select]
sudo fdisk -l
Title: Re: Grub install failed
Post by: jlanep30 on June 07, 2017, 09:42:53 pm
sudo fdisk -l
[close]
Title: Re: Grub install failed
Post by: PCNetSpec on June 08, 2017, 07:51:44 am
Can you boot to the LiveUSB and post the output from:
Code: [Select]
sudo blkidand
Code: [Select]
sudo ls -l /boot/efi/EFIand
Code: [Select]
efibootmgr -v
Title: Re: Grub install failed
Post by: jlanep30 on June 08, 2017, 10:41:01 am
Code: [Select]
sudo blkid
/dev/sda1: LABEL="ESP" UUID="8E75-1983" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="bf8a8512-dbce-49fa-8e3f-333a1966b829"
/dev/sda10: UUID="3a7a1797-b268-46ae-a552-f923d6658473" TYPE="ext4" PARTUUID="6ca7ec7e-7cd6-4fd5-aa17-cef252facf8d"
/dev/sda2: LABEL="DIAGS" UUID="2AE0-428D" TYPE="vfat" PARTLABEL="Basic data partition" PARTUUID="2af63dca-1da4-4694-882b-a08c54a98487"
/dev/sda4: LABEL="WINRETOOLS" UUID="9080E24680E23300" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="c1cf646f-48b2-4489-9836-db48f841fa90"
/dev/sda5: LABEL="OS" UUID="A640E92040E8F7C7" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="b406be57-d66c-41d8-bcef-8d7f8797cbb9"
/dev/sda6: UUID="CC1AC49B1AC48444" TYPE="ntfs" PARTUUID="4b9d6cb4-7aaa-49d5-b85e-81166354756e"
/dev/sda7: LABEL="PBR Image" UUID="BEE4EDBFE4ED79D3" TYPE="ntfs" PARTLABEL="Microsoft recovery partition" PARTUUID="99ebe311-7ed6-460d-8b37-d248de3b9203"
/dev/sda8: UUID="37a7166f-84b1-4174-bb46-5789f45f0c0b" TYPE="ext4" PARTUUID="280bd5ee-612a-4321-a357-755c84ead70c"
/dev/sdb1: LABEL="PEPPERMINT" UUID="1D0F-0D3F" TYPE="vfat" PARTUUID="000318f8-01"
/dev/loop0: TYPE="squashfs"
/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="8090f495-85cc-4841-b664-a38b7adcf753"
/dev/sda9: UUID="830380dd-22af-4875-b4bb-d47e4c75c38e" TYPE="swap" PARTUUID="1e248b32-b376-4236-a146-13fb7cbb66e9"
/dev/zram0: UUID="149329a0-ee49-4b54-9724-f96392b3db3f" TYPE="swap"
/dev/zram1: UUID="681a285c-5460-46d8-be01-195c87e81dd8" TYPE="swap"
/dev/zram2: UUID="1dd0618f-7aea-4e24-9119-cd9db858cb5c" TYPE="swap"
/dev/zram3: UUID="e3847659-5e64-40a8-b15b-1b326e3a8d1f" TYPE="swap"

Title: Re: Grub install failed
Post by: jlanep30 on June 08, 2017, 10:41:37 am
Code: [Select]
efibootmgr -v
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0002,2001,0001,0000,2002,2003
Boot0000* USB Storage Device BBS(HD,,0x500)............................................................................A...........................
Boot0001* Hard Drive BBS(HD,,0x500)................-.C.......C.q.....................................N.........A.........................
Boot0002* Windows Boot Manager HD(1,GPT,bf8a8512-dbce-49fa-8e3f-333a1966b829,0x800,0xfa000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...H................
Boot0003* USB1-1 (SanDisk Cruzer Glide) PciRoot(0x0)/Pci(0x1d,0x0)/USB(0,0)/USB(0,0)/HD(1,MBR,0x4294967288,0x800,0x773cd00)RC
Boot2001* EFI USB Device RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC

Title: Re: Grub install failed
Post by: jlanep30 on June 08, 2017, 10:43:24 am
sudo ls -l /boot/efi/EFI    file did not exist!
Title: Re: Grub install failed
Post by: jlanep30 on June 08, 2017, 10:55:08 am
Code: [Select]
peppermint@peppermint ~ $ sudo ls -l /boot/efi/EFI
ls: cannot access '/boot/efi/EFI': No such file or directory
Title: Re: Grub install failed
Post by: PCNetSpec on June 08, 2017, 12:34:30 pm
okay you seem to have 2 Linux partitions:-

Code: [Select]
/dev/sda8  569696256 953544703 383848448   183G Linux filesystem
and
/dev/sda10 334936064 569696255 234760192   112G Linux filesystem

do you know what these are ?
Title: Re: Grub install failed
Post by: jlanep30 on June 08, 2017, 12:43:00 pm
Both were attempts to install Peppermint 8
Title: Re: Grub install failed
Post by: AndyInMokum on June 08, 2017, 02:09:18 pm
Hi jlanep30, for future reference, could you please remember to encapsulate terminal outputs with the Insert, Code # function.  For extra long outputs, please use the Spoiler, Sp function.  If you’re a Chromium Browser and/or a Google Chrome user, please don't combine these functions.  For some reason they don’t work well together with these browsers.  Only use one or the other  ;).  These forum functions preserve the original format of the output.  This makes it easier for future visitors to relate to their own issues.  These functions are found in the forum editor, above the,  :-[ Embarrassed and  the :'( Cry emoticon respectively.  Use the Preview button to check how it'll look in the forum.  This time, I've done it for you - many thanks  ;).
Title: Re: Grub install failed
Post by: jlanep30 on June 08, 2017, 02:51:58 pm
 Sorry about that!  I'm new to linux! I think I know what you are talking about and fixing to play around with it.

Title: Re: Grub install failed
Post by: AndyInMokum on June 08, 2017, 03:43:21 pm
Sorry about that!  I'm new to linux! I think I know what you are talking about and fixing to play around with it.

No problem, you're not expect to know everything right away  :).
Title: Re: Grub install failed
Post by: PCNetSpec on June 08, 2017, 04:12:42 pm
Both were attempts to install Peppermint 8

Okay if they're both Peppermint, we can attempt to fix one of those, or we can remove them both and start again ?

I think we should do both .. see if we can fix one of those, and if it works delete them both and start again .. sound like a plan ?



If so .. Boot to the LiveUSB (and make sure you have an active internet connection) and run these commands in sequence:
Code: [Select]
sudo mount /dev/sda8 /mntthen
Code: [Select]
sudo mount /dev/sda1 /mnt/boot/efithen
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; donethen
Code: [Select]
sudo chroot /mntthen
Code: [Select]
grub-install /dev/sda --target=x86_64-efithen
Code: [Select]
update-grubthen hit Ctrl+D to exit the chroot environment. (the prompt should change back to $)

Close the terminal and shut down the PC

Remove the LiveUSB

Turn ON the PC

Were you offered both Peppermint or Windows ?
Title: Re: Grub install failed
Post by: jlanep30 on June 08, 2017, 05:37:03 pm
If I boot live USB My wifi doesn't work and my computer doesn't have a Ethernet port...
Title: Re: Grub install failed
Post by: jlanep30 on June 08, 2017, 07:10:10 pm
broadcom bcm43142 Network unclaimed:
Title: Re: Grub install failed
Post by: PCNetSpec on June 09, 2017, 05:57:02 am
Okay try it without the internet connection .. and if you get any errors, please report them here.
Title: Re: Grub install failed
Post by: jlanep30 on June 09, 2017, 01:57:24 pm
Code: [Select]
peppermint@peppermint ~ $ sudo mount /dev/sda8 /mnt
peppermint@peppermint ~ $ sudo mount /dev/sda1 /mnt/boot/efi
peppermint@peppermint ~ $ for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
peppermint@peppermint ~ $ sudo chroot /mnt
root@peppermint / # grub-install /dev/sda --target=x86_64-efi
grub-install: error: /usr/lib/grub/x86_64-efi/modinfo.sh doesn't exist. Please specify --target or --directory.
root@peppermint / #
root@peppermint / # grub-install /dev/sda --target=x86_64-efi
grub-install: error: /usr/lib/grub/x86_64-efi/modinfo.sh doesn't exist. Please specify --target or --directory.
root@peppermint / # update-grub
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.8.0-53-generic
Found initrd image: /boot/initrd.img-4.8.0-53-generic
Found Windows Boot Manager on /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi
Found Peppermint 8 Eight (8) on /dev/sda10
Adding boot menu entry for EFI firmware configuration
done
root@peppermint / # exit
peppermint@peppermint ~ $

Title: Re: Grub install failed
Post by: jlanep30 on June 09, 2017, 02:02:11 pm
Did not give me option to boot from peppermint.
Title: Re: Grub install failed
Post by: PCNetSpec on June 09, 2017, 02:22:30 pm
Were there any errors during those commands ?

If not, have you checked to see if anything other than Windows is available in the U/EFI boot manager menu ?
(peppermint will be listed as <ubuntu> in the EFI boot manager menu)

From the LiveUSB, what is the output from:#
Code: [Select]
efibootmgr -vnow ?
Title: Re: Grub install failed
Post by: murraymint on June 09, 2017, 04:01:44 pm
Boot Mode is set to: UEFI with Legacy OPROM; Secure Boot: OFF

The other options I have is:

"Legacy Boot Mode, Secure Boot Off"

"UEFI Boot Mode, Secure Boot On"

Something tells me the boot mode could be the problem. I think one of the other modes might work properly.
Title: Re: Grub install failed
Post by: jlanep30 on June 09, 2017, 09:18:52 pm
Ok I went through all the boot modes and still no change. 
Title: Re: Grub install failed
Post by: jlanep30 on June 09, 2017, 09:34:22 pm
Code: [Select]
peppermint@peppermint ~ $ efibootmgr -v
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0002,2001,0000,0001,2002,2003
Boot0000* Hard Drive BBS(HD,,0x500)................-.C.......C.q...............................................A.........................
Boot0001* USB Storage Device BBS(HD,,0x500)............................................................................A...........................
Boot0002* Windows Boot Manager HD(1,GPT,bf8a8512-dbce-49fa-8e3f-333a1966b829,0x800,0xfa000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...H................
Boot0003* USB1-1 (SanDisk Cruzer Glide) PciRoot(0x0)/Pci(0x1d,0x0)/USB(0,0)/USB(1,0)/HD(1,MBR,0x4294967288,0x800,0x773cd00)RC
Boot2001* EFI USB Device RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC
peppermint@peppermint ~ $

Title: Re: Grub install failed
Post by: PCNetSpec on June 11, 2017, 01:13:55 pm
Are you sure there's no setting in the BIOS that locks the EFI partition ?
Title: Re: Grub install failed
Post by: jlanep30 on June 11, 2017, 02:15:14 pm
I have looked everywhere in the Bios and haven't found anything!  I have tried another distro and had no problem!  Just liked Peppermint..
Title: Re: Grub install failed
Post by: PCNetSpec on June 11, 2017, 02:24:38 pm
Which distro/version did you try ?
Title: Re: Grub install failed
Post by: murraymint on June 11, 2017, 02:25:22 pm
Code: [Select]
root@peppermint / # grub-install /dev/sda --target=x86_64-efi
grub-install: error: /usr/lib/grub/x86_64-efi/modinfo.sh doesn't exist. Please specify --target or --directory.

See comment #1 here:
https://bugzilla.redhat.com/show_bug.cgi?id=1101352#c1

But the solution will apparently not work with secure boot, so I don't know how you can dual boot with Windows that way.
Title: Re: Grub install failed
Post by: jlanep30 on June 11, 2017, 02:45:55 pm
I have secure boot off... Mint was the one I tried and worked. 
Title: Re: Grub install failed
Post by: murraymint on June 11, 2017, 03:21:52 pm
OK. I'm not sure if that applies here, I just wanted to flag up the error you were having with GRUB.
Title: Re: Grub install failed
Post by: PCNetSpec on June 12, 2017, 04:28:25 am
Try using this boot repair disk
https://sourceforge.net/p/boot-repair-cd/home/Home/

and select "Recommended Repair"