Peppermint OS Community Forum

Resources => What are you running Peppermint on? => Topic started by: GEMS on November 04, 2016, 05:27:51 pm

Title: Lost Wireless Icon.
Post by: GEMS on November 04, 2016, 05:27:51 pm
I just installed Peppermint 7 on a Acer Inspire One Cloudbook. After connecting with my wireless router. My Wireless icon disappeared. I am still connected to WiFi no problem. But, how do I get the icon back?

Spoiler (click here to view / hide)
System:    Host: gems-Aspire-one-1-431 Kernel: 4.4.0-45-generic i686 (32 bit)
           Desktop: N/A Distro: Peppermint Seven
Machine:   System: Acer (portable) product: Aspire one 1-431 v: V1.11
           Mobo: Acer model: Oxford v: V1.11
           Bios: Insyde v: V1.11 date: 05/24/2016
CPU:       Dual core Intel Celeron N3050 (-MCP-) cache: 1024 KB
           clock speeds: max: 2160 MHz 1: 1913 MHz 2: 1794 MHz
Graphics:  Card: Intel Device 22b1
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.06hz
           GLX Renderer: Mesa DRI Intel HD Graphics (Cherryview) x86/MMX/SSE2
           GLX Version: 3.0 Mesa 11.2.0
Audio:     Card Intel Device 2284 driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-45-generic
Network:   Card: Intel Wireless 3160 driver: iwlwifi
           IF: wlp2s0 state: up mac: <filter>
Drives:    HDD Total Size: NA (-) ID-1: /dev/mmcblk0 model: N/A size: 31.3GB
Partition: ID-1: / size: 27G used: 6.2G (25%) fs: ext4 dev: /dev/mmcblk0p1
           ID-2: swap-1 size: 2.06GB used: 0.00GB (0%) fs: swap dev: /dev/mmcblk0p5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 42.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 177 Uptime: 27 min Memory: 463.4/1932.7MB
           Client: Shell (bash) inxi: 2.2.35
[close]

Thanks.
GEMS.
Title: Re: Lost Wireless Icon.
Post by: PCNetSpec on November 04, 2016, 05:36:32 pm
was it replaced by anything (wired icon) or just disappeared ?
Title: Re: Lost Wireless Icon.
Post by: Admiral_Smith on November 21, 2016, 03:32:33 pm
I just installed Peppermint 7 on a Acer Inspire One Cloudbook. After connecting with my wireless router. My Wireless icon disappeared. I am still connected to WiFi no problem. But, how do I get the icon back?

Spoiler (click here to view / hide)
System:    Host: gems-Aspire-one-1-431 Kernel: 4.4.0-45-generic i686 (32 bit)
           Desktop: N/A Distro: Peppermint Seven
Machine:   System: Acer (portable) product: Aspire one 1-431 v: V1.11
           Mobo: Acer model: Oxford v: V1.11
           Bios: Insyde v: V1.11 date: 05/24/2016
CPU:       Dual core Intel Celeron N3050 (-MCP-) cache: 1024 KB
           clock speeds: max: 2160 MHz 1: 1913 MHz 2: 1794 MHz
Graphics:  Card: Intel Device 22b1
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.06hz
           GLX Renderer: Mesa DRI Intel HD Graphics (Cherryview) x86/MMX/SSE2
           GLX Version: 3.0 Mesa 11.2.0
Audio:     Card Intel Device 2284 driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-45-generic
Network:   Card: Intel Wireless 3160 driver: iwlwifi
           IF: wlp2s0 state: up mac: <filter>
Drives:    HDD Total Size: NA (-) ID-1: /dev/mmcblk0 model: N/A size: 31.3GB
Partition: ID-1: / size: 27G used: 6.2G (25%) fs: ext4 dev: /dev/mmcblk0p1
           ID-2: swap-1 size: 2.06GB used: 0.00GB (0%) fs: swap dev: /dev/mmcblk0p5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 42.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 177 Uptime: 27 min Memory: 463.4/1932.7MB
           Client: Shell (bash) inxi: 2.2.35
[close]

Thanks.
GEMS.

On a macro level, it looks like your wifi is not active anymore.  I would check the device to see if it is functioning and if it is then check to see the status of the firmware driver that runs it.  I would even go and inspect the permissions on your wireless firmware driver to see if it has enough permissions to run.
Title: Re: Lost Wireless Icon.
Post by: PCNetSpec on November 21, 2016, 05:19:08 pm
the inxi output seems to suggest wireless IS working

Quote
Network:   Card: Intel Wireless 3160 driver: iwlwifi
           IF: wlp2s0 state: up mac: <filter>

So I'm wondering if it's just the tray icon that's missing (or just displaying the wired icon instead).