Peppermint OS Community Forum

Support => Advanced Topics => Topic started by: acer on August 11, 2016, 07:05:10 am

Title: TCP/IP networking issue to be concerned about?
Post by: acer on August 11, 2016, 07:05:10 am
Was at my daily reading website and was quite alarmed at this article:

http://www.theregister.co.uk/2016/08/10/linux_tor_users_open_corrupted_communications/ (http://www.theregister.co.uk/2016/08/10/linux_tor_users_open_corrupted_communications/)

Does this affect PM7 and or other PM versions?
Title: Re: TCP/IP networking issue to be concerned about?
Post by: PCNetSpec on August 11, 2016, 08:16:31 am
It does currently affect Peppermint 3, 5, 6, and 7 (and pretty much ALL currently supported distros using kernels < 4.7).
https://people.canonical.com/~ubuntu-security/cve/2016/CVE-2016-5696.html

but expect a patch (via regular updates) soon.

I'll post further info as it becomes available.
Title: Kernel flaw discovered
Post by: supercat on August 12, 2016, 06:56:08 am
Could the Peppermint devs please comment on this flaw:

http://www.theregister.co.uk/2016/08/10/linux_tor_users_open_corrupted_communications/ (http://www.theregister.co.uk/2016/08/10/linux_tor_users_open_corrupted_communications/)

 >:(
Title: Re: Kernel flaw discovered
Post by: VinDSL on August 12, 2016, 07:13:28 am
Yup !   8)

Merged messages ...
Title: Re: TCP/IP networking issue to be concerned about?
Post by: PCNetSpec on August 30, 2016, 06:28:19 am
This (along with 7 other security flaws) is now patched in the 4.4.0-36 kernel .. so UPDATE NOW via the normal route (update manager)

You can check if you have the 4.4.0-36 kernel with
Code: [Select]
uname -a

More info including links to all 8 CVE's) here:
http://www.ubuntu.com/usn/usn-3070-1/
Title: Re: TCP/IP networking issue to be concerned about?
Post by: acer on August 31, 2016, 01:52:08 pm
Thanks PCNETSPEC.  :)