Peppermint OS

Support => Networking => Topic started by: Shamgar on December 01, 2015, 12:23:11 am

Title: Network disabled (Solved)
Post by: Shamgar on December 01, 2015, 12:23:11 am
Hi!

I use Peppermint 6 32bit on my old EEEPC and it worked fine until i disabled network by mistake. Now it works only by cable but I can't see nor connect to any wireless connection. How can I do?

Thanks!
Title: Re: Network disabled
Post by: PCNetSpec on December 01, 2015, 11:39:55 am
What's the output from:
Code: [Select]
rfkill list?
Title: Re: Network disabled
Post by: Shamgar on December 03, 2015, 12:21:39 am
Code: [Select]
0: eeepc-wlan: Wireless LAN
Soft blocked: yes
Hard blocked: no
1: eeepc-bluetooth: Bluetooth
Soft blocked: yes
Hard blocked: no
Title: Re: Network disabled
Post by: AndyInMokum on December 03, 2015, 12:36:51 am
Hi Shamgar, how's it going?  When you post an output to the forum.  Could you please remember to encapsulate it with either the, # Insert Code function or the, Sp Spoiler function if it very long.  This preserves the original format of the output and makes it easier for future visitors to relate to.  These functions are found above the,  :-[ Embarrassed and  :'( Cry emoticon respectively in the forum editor.  I've done this for you this time - many thanks  ;).
Title: Re: Network disabled
Post by: PCNetSpec on December 03, 2015, 07:34:19 am
Try running
Code: [Select]
sudo rfkill unblock alldid that unblock it ?
Title: Re: Network disabled
Post by: Shamgar on December 04, 2015, 01:44:39 am
@AndyInmokum

Thanks for your help :)

@PCNetSpec

I did that command, now if I do "rfkill list" it shows:

Code: [Select]
0: eeepc-wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
1: eeepc-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
3: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

Despite of this, Wi-Fi doesn't work. If I click to the connection icon in the status bar I see "disconnected" under name of the wirless card


Title: Re: Network disabled
Post by: PCNetSpec on December 04, 2015, 08:59:26 am
Try deleting the wireless connection in network manager, then recreating it.

If that doesn't work, post the output from:
Code: [Select]
lsmod
Title: Re: Network disabled
Post by: Shamgar on December 05, 2015, 02:26:10 am
Code: [Select]
Module                  Size  Used by
rndis_host             14097  0
cdc_ether              13977  1 rndis_host
usbnet                 37860  2 rndis_host,cdc_ether
mii                    13654  1 usbnet
coretemp               13201  0
joydev                 17113  0
snd_hda_codec_realtek    70553  1
snd_hda_codec_generic    62931  1 snd_hda_codec_realtek
i915                  808675  4
serio_raw              13251  0
uvcvideo               71465  0
videobuf2_vmalloc      13048  1 uvcvideo
videobuf2_memops       13170  1 videobuf2_vmalloc
videobuf2_core         48344  1 uvcvideo
drm_kms_helper         55007  1 i915
v4l2_common            15132  1 videobuf2_core
rfcomm                 58045  8
snd_hda_intel          29285  3
snd_hda_controller     29252  1 snd_hda_intel
snd_hda_codec         120400  4 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep              13272  1 snd_hda_codec
videodev              131265  3 uvcvideo,v4l2_common,videobuf2_core
bnep                   18895  2
snd_pcm                87194  3 snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_seq_midi           13324  0
snd_seq_midi_event     14475  1 snd_seq_midi
media                  20899  2 uvcvideo,videodev
drm                   255469  6 i915,drm_kms_helper
binfmt_misc            13140  1
btusb                  27649  0
lpc_ich                16877  0
snd_rawmidi            25722  1 snd_seq_midi
bluetooth             391253  22 bnep,btusb,rfcomm
6lowpan_iphc           18262  1 bluetooth
snd_seq                56592  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         14137  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              28648  2 snd_pcm,snd_seq
snd                    66670  16 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
i2c_algo_bit           13197  1 i915
shpchp                 32143  0
soundcore              14599  2 snd,snd_hda_codec
parport_pc             32021  0
ppdev                  17391  0
eeepc_laptop           19133  0
video                  19475  1 i915
lp                     13299  0
parport                40836  3 lp,ppdev,parport_pc
mac_hid                13059  0
sparse_keymap          13708  1 eeepc_laptop
btrfs                 884344  0
xor                    26221  1 btrfs
hid_generic            12503  0
raid6_pq               97455  1 btrfs
usbhid                 47035  0
hid                    95946  2 hid_generic,usbhid
uas                    22631  0
usb_storage            56817  1 uas
psmouse                99602  0
pata_acpi              12901  0
atl1e                  33010  0
Title: Re: Network disabled
Post by: PCNetSpec on December 05, 2015, 07:46:21 am
OK I can see no wireless drivers loaded .., can you post the output from:
Code: [Select]
sudo lshw -C networkand
Code: [Select]
lspci -vnn | grep -iA2 netand
Code: [Select]
iwconfigand
Code: [Select]
iwlist scan
Title: Re: Network disabled
Post by: Shamgar on December 08, 2015, 11:00:01 pm
sudo lshw -C network

Code: [Select]
*-network               
       description: Ethernet interface
       product: AR8121/AR8113/AR8114 Gigabit or Fast Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: b0
       serial: 00:23:54:72:87:ee
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=ATL1E driverversion=1.0.0.7-NAPI firmware=L1e latency=0 link=no multicast=yes port=twisted pair
       resources: irq:17 memory:fbfc0000-fbffffff ioport:ec00(size=128)
  *-network
       description: Ethernet interface
       physical id: 1
       logical name: usb0
       serial: 02:68:0a:73:04:00
       capabilities: ethernet physical
       configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.21 link=yes multicast=yes

lspci -vnn | grep -iA2 net

Code: [Select]
03:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8121/AR8113/AR8114 Gigabit or Fast Ethernet [1969:1026] (rev b0)
Subsystem: ASUSTeK Computer Inc. Device [1043:8324]
Flags: bus master, fast devsel, latency 0, IRQ 17

iwconfig
Code: [Select]
lo        no wireless extensions.

eth0      no wireless extensions.

usb0      no wireless extensions.

iwlist scan
Code: [Select]
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

usb0      Interface doesn't support scanning.
Title: Re: Network disabled
Post by: PCNetSpec on December 09, 2015, 05:38:31 am
I'm seeing no wireless hardware :-\

Are you sure wireless inst disable by a hardware switch, or maybe in the BIOS ?

and can you post the contents of:
Code: [Select]
gedit /etc/udev/rules.d/70-persistent-net.rules
Title: Re: Network disabled
Post by: Shamgar on December 10, 2015, 11:24:10 pm
I noticed a strange thing: in BIOS network device was set to "disabled", so I switched it to "enabled" then I do "Save & Exit", but when Peppermint boot some error messages appeared on the screen, then the OS starts but wi-fi doesn't work.

Then when I reboot the network device option in BIOS is set again to "disabled"

Code: [Select]
# PCI device 0x1969:0x1026 (ATL1E)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:23:54:72:87:ee", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x1814:0x0781 (rt2800pci)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:22:43:4b:88:a5", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
Title: Re: Network disabled
Post by: PCNetSpec on December 11, 2015, 04:58:36 am
I can't see how Peppermint could disable the wireless adapter in the BIOS :-\ .. so I'm thinking the internal wireless card has either died or has a bad connection, so the BIOS can't see it as present so lists it as disabled.

So just to check if it's the hardware itself, and nothing to do with Peppermint .. can you re-enable the wireless in the BIOS and save/exit, then without booting Peppermint immediately re-enter the BIOS and see if it's listed as disabled again.

After doing that, can you boot Peppermint and run:
Code: [Select]
dmesg > ~/Desktop/dmesg.txtyou'll then find a file on your desktop called "dmesg.txt" .. can you find somewhere to host that file online, and post a link to it.

Also post any output from:
Code: [Select]
lspci -vnn | grep 1814


[EDIT]

I should also mention this .. I have a few Acer Aspire One netbooks, and occasionally (usually if I accidentally hit the physical switch on the front to disable the network adapter) the network adapter will "disappear" from the system.
The only way to re-enable it is to turn off the netbook, remove the power lead, remove the battery (so there's now NO power the netbook at all), then press the power button (to discharge any power remaining in the motherboard capacitors), then to add back the battery and power lead, then turn on the netbook .. and the wireless adapter magically re-appears :)

Worth a shot......
Title: Re: Network disabled
Post by: Shamgar on December 11, 2015, 11:09:18 pm
As you said I enabled wirless card in BIOS, i rebooted then I came back to BIOS and wireless card was still on "enabled". I also tried to boot Windows 7 and wireless adapter correctly works, but when I boot Peppermint it's always disconnected. So it's not a hardware problem  :'(

I also tried to remove battery, but it's the same

I tried to launch the command you told me but it says that file or directory doesn't exist
Title: Re: Network disabled
Post by: PCNetSpec on December 12, 2015, 05:40:52 am
It's good that it's not hardware .. at least that means it's fixable .. though I'm still baffled how an OS can change a BIOS setting  :-\

Erm, the above TWO command SHOULD work .. try again copy/pasting the commands (one at a time).

and if they error, post back the EXACT output, and which command caused that output.



I'm also confused as to what this is

Quote
  *-network
       description: Ethernet interface
       physical id: 1
       logical name: usb0
       serial: 02:68:0a:73:04:00
       capabilities: ethernet physical
       configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.21 link=yes multicast=yes

are you tethering a phone, or have some other kind of USB network device ?
Title: Re: Network disabled
Post by: Shamgar on December 14, 2015, 11:20:02 pm
dmesg > ~/Desktop/dmesg.txt (I did it without the ">" symbol and it works, is it right?)

https://www.dropbox.com/s/lthegpwnuxk3nfa/dmesg.txt?dl=0 (https://www.dropbox.com/s/lthegpwnuxk3nfa/dmesg.txt?dl=0)

lspci -vnn | grep 1814 (nothing happens after I do it)

The Netbook is usually connected to internet via tethering on the phone
Title: Re: Network disabled
Post by: Slim.Fatz on December 15, 2015, 01:04:53 am
dmesg > ~/Desktop/dmesg.txt (I did it without the ">" symbol and it works, is it right?)

Hi Shamgar,

No, it does not work (at least not on my computers). Using the correct syntax will produce a text file named dmesg.txt containing the output. That only works if you have the > symbol inserted. Otherwise the output should say that the directory or file does not exist. If you already have a file of the same name then the output will still not go into that file but will just appear in the terminal. Now it is not clear whether your posted file is the output of the recently run command or an output that is perhaps much older and therefore possibly incorrect for the current situation.

Why did you not follow the instructions? You are only making things more difficult.  ::)

Regards,

-- Slim
Title: Re: Network disabled
Post by: AndyInMokum on December 15, 2015, 05:17:03 am
Hi Shamgar, this may help you with copying commands into the terminal.  The forum is set up to make this very simple to do.  Linux is case sensitive.  To reduce the possibility of typographical errors, please left click the Code: [Select] function that is directly above the line with the command to highlight the contents.  Click on the centre mouse button/wheel while the cursor is in the terminal window to paste the contents  ;).
Title: Re: Network disabled
Post by: PCNetSpec on December 15, 2015, 06:00:35 am
This appears to be the relevant section:-
Code: [Select]
[   19.076351] eeepc_laptop: Eee PC Hotkey Driver
[   19.076378] eeepc_laptop: Hotkey init flags 0x41
[   19.112810] eeepc_laptop: TYPE (2000000) not reported by BIOS, enabling anyway
[   19.142755] eeepc_laptop: PANELPOWER (4000000) not reported by BIOS, enabling anyway
[   19.142775] eeepc_laptop: Get control methods supported: 0x6101713
[   19.143397] ppdev: user-space parallel port driver
[   19.211294] input: Asus EeePC extra buttons as /devices/platform/eeepc/input/input9
[   19.613187] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[   19.893836] Bluetooth: Core ver 2.19
[   19.893988] NET: Registered protocol family 31
[   19.893995] Bluetooth: HCI device and connection manager initialized
[   19.894015] Bluetooth: HCI socket layer initialized
[   19.894029] Bluetooth: L2CAP socket layer initialized
[   19.894066] Bluetooth: SCO socket layer initialized
[   19.899503] [drm] Initialized drm 1.1.0 20060810
[   20.119814] intel_rng: FWH not detected
[   20.162889] ACPI Warning: SystemIO range 0x0000000000000828-0x000000000000082F conflicts with OpRegion 0x0000000000000800-0x000000000000087F (\PMIO) (20140424/utaddress-254)
[   20.162917] ACPI Warning: SystemIO range 0x0000000000000828-0x000000000000082F conflicts with OpRegion 0x0000000000000800-0x000000000000087F (\_SB_.PCI0.SBRG.PMS0) (20140424/utaddress-254)
[   20.162935] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   20.162946] ACPI Warning: SystemIO range 0x00000000000004B0-0x00000000000004BF conflicts with OpRegion 0x0000000000000480-0x00000000000004BF (\_SB_.PCI0.SBRG.GPBX) (20140424/utaddress-254)
[   20.162964] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   20.162972] ACPI Warning: SystemIO range 0x0000000000000480-0x00000000000004AF conflicts with OpRegion 0x0000000000000480-0x00000000000004BF (\_SB_.PCI0.SBRG.GPBX) (20140424/utaddress-254)
[   20.162991] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   20.162997] lpc_ich: Resource conflict(s) found affecting gpio_ich
[   20.372140] leds_ss4200: no LED devices found
[   20.508372] pci 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[   20.508394] lpc_ich 0000:00:1f.0: BAR 13: [io  0x0800-0x087f] has bogus alignment
[   20.508408] pci 0000:00:1e.0: PCI bridge to [bus 05]
[   20.568269] audit: type=1400 audit(1450162545.769:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/sbin/dhclient" pid=447 comm="apparmor_parser"
[   20.568297] audit: type=1400 audit(1450162545.769:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=447 comm="apparmor_parser"
[   20.568321] audit: type=1400 audit(1450162545.769:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=447 comm="apparmor_parser"
[   20.570395] audit: type=1400 audit(1450162545.769:5): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=447 comm="apparmor_parser"
[   20.570434] audit: type=1400 audit(1450162545.769:6): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=447 comm="apparmor_parser"
[   20.571520] audit: type=1400 audit(1450162545.769:7): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=447 comm="apparmor_parser"
[   20.612923] pci 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[   20.612945] lpc_ich 0000:00:1f.0: BAR 13: [io  0x0800-0x087f] has bogus alignment
[   20.612960] pci 0000:00:1e.0: PCI bridge to [bus 05]
[   20.620515] audit: type=1400 audit(1450162545.821:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/ntpd" pid=450 comm="apparmor_parser"
[   20.647054] eeepc_laptop: BIOS says wireless lan is blocked, but the pci device is present
[   20.647065] eeepc_laptop: skipped wireless hotplug as probably inappropriate for this model
[   20.647476] eeepc_laptop: Unable to find port
What does
Code: [Select]
rfkill listoutput now ?

and are you SURE there isn't either a physical switch, or key combo to enable/disable wireless ?
Title: Re: Network disabled
Post by: Shamgar on December 16, 2015, 01:01:39 am
@ Slim.Fatz
I tried to follow the istructions but it didn't work, that's why I tried to do the command without the ">". I'm clearly a linux newbye and I'm here to learn, so be patient  :) I really appreciate the help PcNetSpec is giving me to solve my problem  :)

@AndyinMokum
Many thanks for the advice, surely it will help  :)

@PCNetSpec
rfkill list
Code: [Select]
0: eeepc-wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
1: eeepc-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
7: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
8: phy4: Wireless LAN
Soft blocked: no
Hard blocked: no

Asus 1000h doesn't have any physical switch for Wi-Fi. I don't know if there is any key combo for this
Title: Re: Network disabled
Post by: PCNetSpec on December 16, 2015, 02:30:53 am
On the EeePC 1000HAG the wireless key combo is

Fn+F2

You'll see a little wireless symbol on the F2 key (in blue, which means you also have to hit the Function key Fn)

Does that make a difference ? .. you may have to hit it the key combo once or twice .. if I remember correctly it cycles through both off - wireless on - both wireless and bluetooth on - just bluetooth on - and back to both off

(http://library.uvm.edu/news/wp-content/uploads/2009/04/12065572121317625675no_hope_wireless_access_pointsvgmed.png)
Title: Re: Network disabled
Post by: Shamgar on December 17, 2015, 03:53:58 am
I knew the key combo but when I hit it wirless turn from on to off, but even if it's enabled if I click on the icon on status bar I can't see any wi-fi net to connect  :'(
Title: Re: Network disabled
Post by: PCNetSpec on December 17, 2015, 05:31:23 am
Can you post the output from:
Code: [Select]
lsmod
Title: Re: Network disabled
Post by: Shamgar on December 18, 2015, 05:42:15 am
Code: [Select]
Module                  Size  Used by
rndis_host             14097  0
cdc_ether              13977  1 rndis_host
usbnet                 37860  2 rndis_host,cdc_ether
mii                    13654  1 usbnet
hid_generic            12503  0
snd_hda_codec_realtek    70553  1
snd_hda_codec_generic    62931  1 snd_hda_codec_realtek
snd_hda_intel          29285  3
snd_hda_controller     29252  1 snd_hda_intel
coretemp               13201  0
rfcomm                 58045  8
snd_hda_codec         120400  4 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep              13272  1 snd_hda_codec
bnep                   18895  2
snd_pcm                87194  3 snd_hda_codec,snd_hda_intel,snd_hda_controller
joydev                 17113  0
snd_seq_midi           13324  0
snd_seq_midi_event     14475  1 snd_seq_midi
serio_raw              13251  0
snd_rawmidi            25722  1 snd_seq_midi
uvcvideo               71465  0
snd_seq                56592  2 snd_seq_midi_event,snd_seq_midi
videobuf2_vmalloc      13048  1 uvcvideo
videobuf2_memops       13170  1 videobuf2_vmalloc
videobuf2_core         48344  1 uvcvideo
usbhid                 47035  0
snd_seq_device         14137  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              28648  2 snd_pcm,snd_seq
v4l2_common            15132  1 videobuf2_core
hid                    95946  2 hid_generic,usbhid
videodev              131265  3 uvcvideo,v4l2_common,videobuf2_core
binfmt_misc            13140  1
i915                  808675  5
lpc_ich                16877  0
media                  20899  2 uvcvideo,videodev
btusb                  27649  0
snd                    66670  16 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
bluetooth             391253  22 bnep,btusb,rfcomm
drm_kms_helper         55007  1 i915
6lowpan_iphc           18262  1 bluetooth
drm                   255469  7 i915,drm_kms_helper
shpchp                 32143  0
soundcore              14599  2 snd,snd_hda_codec
i2c_algo_bit           13197  1 i915
video                  19475  1 i915
eeepc_laptop           19133  0
parport_pc             32021  0
mac_hid                13059  0
sparse_keymap          13708  1 eeepc_laptop
ppdev                  17391  0
lp                     13299  0
parport                40836  3 lp,ppdev,parport_pc
btrfs                 884344  0
xor                    26221  1 btrfs
raid6_pq               97455  1 btrfs
uas                    22631  0
usb_storage            56817  1 uas
psmouse                99602  0
pata_acpi              12901  0
atl1e                  33010  0
Title: Re: Network disabled
Post by: PCNetSpec on December 19, 2015, 09:46:32 am
Does wireless spring to life if you make sure the wireless switch is set to ON .. then run:
Code: [Select]
sudo modprobe rt2800pci
Title: Re: Network disabled
Post by: Shamgar on December 22, 2015, 06:01:17 am
Nothing happened  :'(
Title: Re: Network disabled
Post by: PCNetSpec on December 22, 2015, 08:23:53 am
run:
Code: [Select]
sudo modprobe rt2800pcithen post the output from:
Code: [Select]
iwlist scan
Title: Re: Network disabled
Post by: PCNetSpec on December 22, 2015, 09:21:42 am
Try this

Shut down the PC and remove the network cable

Leaving the ethernet cable unplugged, switch on the PC, and enter the BIOS .. enable wireless in the BIOS .. save the BIOS setting, and still without the ethernet cable plugged in boot normally.

once booted with no ethernet cable, does wireless work ? .. if not, see if Fn+F2 will enable wireless ?



Does loading the eeepc-wmi module make any difference
Code: [Select]
sudo modprobe eeepc-wmi
Title: Re: Network disabled
Post by: Shamgar on December 29, 2015, 02:13:59 am
iwlist scan:

Code: [Select]
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

usb0      Interface doesn't support scanning.

I tried what you suggested but nothing happened.

I noticed everytime I turn wireless on in BIOS then some error messages appear during Peppermint boot

Title: Re: Network disabled
Post by: darthlukan on December 29, 2015, 05:43:40 am
Try this:

While booted into Peppermint, press the key combination that enables your wifi card. Then run the following precisely as you see it (copy and paste each line if you have to):

Code: [Select]
sudo service networking stop
sudo modprobe eeepc-wmi
sudo modprobe rt2800pci
sudo service networking start

Here's what each command does:

1. Turn off the networking services, this will disconnect you from the internet and any networking software will be disabled because the required services are stopped.
2. Load the eeepc module
3. Load the realtek pci module
4. Start all of the networking software and services again, taking into account the new modules and the hardware being turned on.

Essentially what the above commands do is save you from having to restart your system in order to restart the networking interfaces with the new modules.  If this works, then we know that we need to auto-load those modules (we can walk you through setting those as defaults).

If at any time you get an error with the above commands, please copy and paste the output into a post here.
Title: Re: Network disabled
Post by: Shamgar on December 30, 2015, 10:56:23 pm
Code: [Select]
shamgar@Pungolo ~ $ sudo service networking stop
[sudo] password for shamgar:
stop: Job failed while stopping
shamgar@Pungolo ~ $ sudo modprobe eeepc-wmi
modprobe: ERROR: could not insert 'eeepc_wmi': No such device
shamgar@Pungolo ~ $ sudo modprobe rt2800pci
shamgar@Pungolo ~ $ sudo service networking start
start: Job is already running: networking

by the way now, for some reason I can't explain, there are no more error messages during the boot, and in the boot itself the wireless option now stay one even if I reboot.
Title: Re: Network disabled
Post by: darthlukan on December 31, 2015, 12:36:44 am
Chances are it was the hardware switch being glitchy. Now that you've got the module loaded at least once and the hardware switch is on, the setting should survive reboots (since the kernel will auto-load the module when it sees the hardware switch is "on" before the network service is started).

One thing you can do to make sure the module is loaded no matter what, is to perform the following:

Code: [Select]
$ sudo touch /etc/modprobe.d/10_custom.conf
$ sudo echo rt2800pci >> /etc/modules.d/10_custom.conf

The first command creates a custom config file for module loading if it doesn't already exist. The second command adds the module name to that file (if the file already exists, the ">>" will append rather than overwrite previous entries) so that it is automatically picked up by the kernel module loader on bootup. The reason for placing "10_" in the filename like that is because the module loader parses the number and will load that file before any others that might be in the same directory. For example, 10_custom.conf will load before 40_display.conf. By default, peppermint doesn't use numeric prefixes, so the loader loads in alphabetical order. Using the numeric prefix in this case will make that file load before the default peppermint files.
Title: Re: Network disabled
Post by: Shamgar on January 05, 2016, 01:50:16 am
When I do the second command:

Code: [Select]
shamgar@Pungolo ~ $ sudo echo rt2800pci >> /etc/modules.d/10_custom.conf
bash: /etc/modules.d/10_custom.conf: File o directory non esistente

translated it says "file or directory don't exist"
Title: Re: Network disabled
Post by: PCNetSpec on January 05, 2016, 09:39:44 am
try:
Code: [Select]
echo "rt2800pci" | sudo tee -a /etc/modprobe.d/10_custom.conf
Title: Re: Network disabled
Post by: Shamgar on January 11, 2016, 12:11:29 am
I did it. Now?  :)
Title: Re: Network disabled
Post by: PCNetSpec on January 11, 2016, 02:09:55 pm
I did it. Now?  :)

Is that a question ?
Title: Re: Network disabled
Post by: Shamgar on January 14, 2016, 11:02:28 pm
Yes it was a question. I followed the instructions, but the problem remain...  :'(

Even if wireless card is turned on I still can't see any wi-fi connections



Title: Re: Network disabled
Post by: PCNetSpec on January 15, 2016, 03:30:50 am
So the problem isn't that the driver isn't loading, but that it doesn't connect ?

Next time it won't display any networks, open a terminal and copy the output from the following commands to a text file .. so you can post them later.
Code: [Select]
lsmod | grep 2800and
Code: [Select]
rfkill listand
Code: [Select]
iwlist scan
Title: Re: Network disabled
Post by: Shamgar on January 15, 2016, 11:01:51 pm
Code: [Select]
shamgar@Pungolo ~ $ lsmod | grep 2800
rt2800pci              13398  0
rt2800mmio             16189  1 rt2800pci
rt2800lib              83150  2 rt2800pci,rt2800mmio
rt2x00pci              13111  1 rt2800pci
rt2x00mmio             13395  2 rt2800pci,rt2800mmio
rt2x00lib              48886  5 rt2x00pci,rt2800lib,rt2800pci,rt2800mmio,rt2x00mmio
mac80211              563196  3 rt2x00lib,rt2x00pci,rt2800lib
eeprom_93cx6           13168  1 rt2800pci
crc_ccitt              12627  1 rt2800lib
shamgar@Pungolo ~ $ rfkill list
0: eeepc-wlan: Wireless LAN
Soft blocked: yes
Hard blocked: no
1: eeepc-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
shamgar@Pungolo ~ $ iwlist scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

usb0      Interface doesn't support scanning.
Title: Re: Network disabled
Post by: PCNetSpec on January 16, 2016, 03:01:47 am
Next time it happens, can you check if running
Code: [Select]
rfkill unblock allor
Code: [Select]
sudo rfkill unblock allmakes wireless start working again ?
Title: Re: Network disabled
Post by: Shamgar on January 18, 2016, 03:09:53 am
I Did it. I also did "rfkill list":

Code: [Select]
shamgar@Pungolo ~ $ rfkill list
0: eeepc-wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
1: eeepc-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
5: phy2: Wireless LAN
Soft blocked: no
Hard blocked: no

So Wirless LAN Soft blocked turned to "no" after I did "sudo rfkill unblock all", but if I click in the status bar icon I read "wi-fi" disabled. I also tried to turn on wi-fi with the key shortcut (Fn+F2), and when I do again "rfkill list" Wirless Lan Soft blocked turned to "yes"
Title: Re: Network disabled
Post by: PCNetSpec on January 18, 2016, 10:29:48 am
I'd expect Fn+F2 to toggle the rfkill between softblocked and not softblocked depending on how many times you hit it.

But does both making sure it says it's NOT softblocked, and right-clicking the networkmanager icon and selecting "Enable Wi-Fi" allow wireless to start working ?

If so, which is the one that appears to be changing itself ?
Title: Re: Network disabled
Post by: Shamgar on January 20, 2016, 11:02:21 pm
PCNetSpec and you all people that helped me, this is a great day for us all  :D

I did
Code: [Select]
sudo rfkill unblock all
then I did
Code: [Select]
rfkill listto be sure everthing is unblocked

So in the end I right clicked on the network icon and I noticed the option "wi-fi enabled". I clicked and now, after two months, my old netbook is again connected via wi-fi to the rest of the world

Thank you very much for your patience, kindness and support  :)
Title: Re: Network disabled (Solved)
Post by: PCNetSpec on January 21, 2016, 10:57:55 am
Great stuff .. happy it's now working :)