Peppermint OS Community Forum

Support => Hardware => Topic started by: paulus on October 19, 2015, 06:35:28 am

Title: USB-drive not seen in GParted and not able to format
Post by: paulus on October 19, 2015, 06:35:28 am
Hi all,


I wanted to install Peppermint OS 6 to an USB-stick, but now the drive, 64 GB is not seen, recognized any longer in GParted. This is what I did:
Facts:
Listing of lsusb (first without the meant USB-drive, second with it):
Code: [Select]
paul@paul-ESPRIMO-P3521 ~ $ lsusb
Bus 001 Device 003: ID 04a9:1909 Canon, Inc. CanoScan LiDE 110
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 04e8:3292 Samsung Electronics Co., Ltd ML-1640 Series Laser Printer
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
paul@paul-ESPRIMO-P3521 ~ $ lsusb
Bus 001 Device 005: ID 058f:1234 Alcor Micro Corp. Flash Drive
Bus 001 Device 003: ID 04a9:1909 Canon, Inc. CanoScan LiDE 110
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 04e8:3292 Samsung Electronics Co., Ltd ML-1640 Series Laser Printer
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
paul@paul-ESPRIMO-P3521 ~ $

So the drive is the first one in the listing:
Code: [Select]
Bus 001 Device 005: ID 058f:1234 Alcor Micro Corp. Flash Drive

So my questions are:
Thanks for helping!

paulus
Title: Re: USB-drive not seen in GParted and not able to format
Post by: PCNetSpec on October 19, 2015, 03:31:52 pm
Boot a Peppermint 6 LiveUSB, then use the
menu > System Tools > USB Stick Formatter
or "Disks" utility to format the USB stick.

then don't pre partition the USB stick .. let the installer do that during the Peppermint installation.
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 19, 2015, 04:31:54 pm
Hi PCNetSpec,

Thanks for helping!

It didn't work out: that matches with the fact that the USB-stick cannot be seen in GParted: it is much more grave than you think it is. The disk must be approached from the deepest level possible. The problem is: I don't know how to do that!

Thank you for the answer on the second question: if/when the drive has been revived again, I should do nothing with it for preperation, but let the Peppermint Installer do the work! :P

So again: how to approach the USB-drive at the deepest level possible in Peppermint OS, or Ubuntu, or even Windows, if there should no way to do it in Linux? >:(
Title: Re: USB-drive not seen in GParted and not able to format
Post by: AndyInMokum on October 19, 2015, 04:55:45 pm
Hi paulus, you could try wiping the MBR with dd and fill it with zeros.  You could then then create a new msdos partition table in GParted or fdisk.  It's brutal and it will have catastrophic consequences if you accidentally apply it to the wrong drive.  My advice is to wait to see if there's another way that's more forgiving.  We can always come back to this if no one has a better plan  ;).
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 19, 2015, 05:01:52 pm
Hi AndyInMokum,

Thank you for helping as well!

I'm afraid that is the only way to be able to revive the USB-drive.
How could I do that? How could I ever do something with a drive that is not approachable in any way? :-\


What do you mean by dd?
Title: Re: USB-drive not seen in GParted and not able to format
Post by: AndyInMokum on October 19, 2015, 05:05:20 pm
Hi paulus, with the usb drive plugged in.  What's the output from:
Code: [Select]
sudo fdisk -l
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 19, 2015, 05:14:29 pm
Output of fdisk -l:
Code: [Select]
paul@paul-ESPRIMO-P3521 ~ $ sudo fdisk -l
[sudo] password for paul:


Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 koppen, 63 sectoren/spoor, 30401 cilinders, totaal 488397168 sectoren
Eenheid = sectoren van 1 * 512 = 512 bytes
Sectorgrootte (logischl/fysiek): 512 bytes / 512 bytes
in-/uitvoergrootte (minimaal/optimaal): 512 bytes / 512 bytes
Schijf-ID: 0x000a9663


 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sda1   *        2048    81344069    40671011   83  Linux
/dev/sda2        81344510   488396799   203526145    5  uitgebreid
/dev/sda5       471885824   488396799     8255488   82  Linux wisselgeheugen
/dev/sda6        81344512   471885823   195270656   83  Linux


Partitietabel-items liggen niet in schijfvolgorde.
paul@paul-ESPRIMO-P3521 ~ $

Title: Re: USB-drive not seen in GParted and not able to format
Post by: AndyInMokum on October 19, 2015, 05:23:30 pm
Output of fdisk -l:
Code: [Select]
paul@paul-ESPRIMO-P3521 ~ $ sudo fdisk -l
[sudo] password for paul:


Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 koppen, 63 sectoren/spoor, 30401 cilinders, totaal 488397168 sectoren
Eenheid = sectoren van 1 * 512 = 512 bytes
Sectorgrootte (logischl/fysiek): 512 bytes / 512 bytes
in-/uitvoergrootte (minimaal/optimaal): 512 bytes / 512 bytes
Schijf-ID: 0x000a9663


 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sda1   *        2048    81344069    40671011   83  Linux
/dev/sda2        81344510   488396799   203526145    5  uitgebreid
/dev/sda5       471885824   488396799     8255488   82  Linux wisselgeheugen
/dev/sda6        81344512   471885823   195270656   83  Linux


Partitietabel-items liggen niet in schijfvolgorde.
paul@paul-ESPRIMO-P3521 ~ $

I see what you mean.  The drive isn't being recognised at all  :-\.  That's my idea out of the window.  I think you'll have to wait for PCNetSpec to give you his verdict.  I really hope you get it resolved - good luck neighbour  ;).
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 19, 2015, 05:30:31 pm
I will wait for PCNetSpec.


But what did you mean by dd? Is it a kind of program? Or could even "dd" do nothing, as the drive isn't recognized in any way? :'( :o


Great to meet you here again, neighbor! :)
Title: Re: USB-drive not seen in GParted and not able to format
Post by: PCNetSpec on October 19, 2015, 05:43:12 pm
Boot to Linux

once you're at the desktop insert the USB stick, then post the output from:
Code: [Select]
dmesg | tail -n 40

if you booted with the USB already inserted, unplug the USB stick, wait 10 seconds, reinsert the USB stick, THEN run:
Code: [Select]
dmesg | tail -n 40
and post the output
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 19, 2015, 05:55:02 pm
Output:
[/code]
Code: [Select]
[font=verdana][size=0.7em]peppermint@peppermint ~ $ dmesg | tail -n 40[/size][/font]
[font=verdana][size=0.7em][   62.304068] device-mapper: multipath: version 1.7.0 loaded[/size][/font]
[font=verdana][size=0.7em][   62.925890] usblp 2-1:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04E8 pid 0x3292[/size][/font]
[font=verdana][size=0.7em][   62.925951] usbcore: registered new interface driver usblp[/size][/font]
[font=verdana][size=0.7em][   64.175827] gpio_ich: GPIO from 206 to 255 on gpio_ich[/size][/font]
[font=verdana][size=0.7em][   64.246670] snd_hda_intel 0000:00:1b.0: irq 45 for MSI/MSI-X[/size][/font]
[font=verdana][size=0.7em][   65.737486] sound hdaudioC0D2: autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line[/size][/font]
[font=verdana][size=0.7em][   65.737490] sound hdaudioC0D2:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)[/size][/font]
[font=verdana][size=0.7em][   65.737492] sound hdaudioC0D2:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)[/size][/font]
[font=verdana][size=0.7em][   65.737493] sound hdaudioC0D2:    mono: mono_out=0x0[/size][/font]
[font=verdana][size=0.7em][   65.737495] sound hdaudioC0D2:    inputs:[/size][/font]
[font=verdana][size=0.7em][   65.737497] sound hdaudioC0D2:      Front Mic=0x19[/size][/font]
[font=verdana][size=0.7em][   65.737499] sound hdaudioC0D2:      Rear Mic=0x18[/size][/font]
[font=verdana][size=0.7em][   65.737501] sound hdaudioC0D2:      Line=0x1a[/size][/font]
[font=verdana][size=0.7em][   65.785262] input: HDA Intel HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input5[/size][/font]
[font=verdana][size=0.7em][   65.785328] input: HDA Intel Front Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input6[/size][/font]
[font=verdana][size=0.7em][   65.785390] input: HDA Intel Rear Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input7[/size][/font]
[font=verdana][size=0.7em][   65.785452] input: HDA Intel Line as /devices/pci0000:00/0000:00:1b.0/sound/card0/input8[/size][/font]
[font=verdana][size=0.7em][   65.785515] input: HDA Intel Line Out as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9[/size][/font]
[font=verdana][size=0.7em][   65.785578] input: HDA Intel Front Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10[/size][/font]
[font=verdana][size=0.7em][   65.837550] init: failsafe main process (1243) killed by TERM signal[/size][/font]
[font=verdana][size=0.7em][   76.377305] r8169 0000:03:00.0 eth0: link down[/size][/font]
[font=verdana][size=0.7em][   76.377316] r8169 0000:03:00.0 eth0: link down[/size][/font]
[font=verdana][size=0.7em][   76.377348] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready[/size][/font]
[font=verdana][size=0.7em][   78.099643] r8169 0000:03:00.0 eth0: link up[/size][/font]
[font=verdana][size=0.7em][   78.099653] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready[/size][/font]
[font=verdana][size=0.7em][   79.081963] init: alsa-restore main process (1656) terminated with status 99[/size][/font]
[font=verdana][size=0.7em][   87.404869] init: plymouth-upstart-bridge main process ended, respawning[/size][/font]
[font=verdana][size=0.7em][   87.410326] init: plymouth-upstart-bridge main process ended, respawning[/size][/font]
[font=verdana][size=0.7em][  235.180044] usb 1-5: new high-speed USB device number 4 using ehci-pci[/size][/font]
[font=verdana][size=0.7em][  235.781693] usb 1-5: New USB device found, idVendor=058f, idProduct=1234[/size][/font]
[font=verdana][size=0.7em][  235.781699] usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=0[/size][/font]
[font=verdana][size=0.7em][  235.781702] usb 1-5: Product: Mass Storage Device[/size][/font]
[font=verdana][size=0.7em][  235.781706] usb 1-5: Manufacturer: Alcor Micro[/size][/font]
[font=verdana][size=0.7em][  237.543084] usb-storage 1-5:1.0: USB Mass Storage device detected[/size][/font]
[font=verdana][size=0.7em][  237.543399] scsi2 : usb-storage 1-5:1.0[/size][/font]
[font=verdana][size=0.7em][  237.543484] usbcore: registered new interface driver usb-storage[/size][/font]
[font=verdana][size=0.7em][  237.617597] usbcore: registered new interface driver uas[/size][/font]
[font=verdana][size=0.7em][  238.540838] scsi 2:0:0:0: Direct-Access     Generic  USB Flash Disk   7.76 PQ: 0 ANSI: 4[/size][/font]
[font=verdana][size=0.7em][  238.541225] sd 2:0:0:0: Attached scsi generic sg2 type 0[/size][/font]
[font=verdana][size=0.7em][  238.549545] sd 2:0:0:0: [sdb] Attached SCSI removable disk[/size][/font]
[font=verdana][size=0.7em]peppermint@peppermint ~ $ [/size][/font]

Title: Re: USB-drive not seen in GParted and not able to format
Post by: AndyInMokum on October 19, 2015, 05:55:38 pm
I will wait for PCNetSpec.


But what did you mean by dd? Is it a kind of program? Or could even "dd" do nothing, as the drive isn't recognized in any way? :'( :o


Great to meet you here again, neighbor! :)
This may help you understand the dd utility: https://nl.wikipedia.org/wiki/Dd_(Unix) (https://nl.wikipedia.org/wiki/Dd_(Unix)).  I say the dd stands for Data  Destroyer because it's really brutal if you get it wrong.  It works when used correctly though.  Unfortunately, you need to be able to see the drive to use it.

English Wikipedia: https://en.wikipedia.org/wiki/Dd_(Unix) (https://en.wikipedia.org/wiki/Dd_(Unix)).
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 19, 2015, 05:58:20 pm
I will wait for PCNetSpec.


But what did you mean by dd? Is it a kind of program? Or could even "dd" do nothing, as the drive isn't recognized in any way? :'( :o


Great to meet you here again, neighbor! :)
This may help you understand the dd utility: https://nl.wikipedia.org/wiki/Dd_(Unix) (https://nl.wikipedia.org/wiki/Dd_(Unix)).  I say the dd stands for Data  Destroyer because it's really brutal if you get it wrong.  It works when used correctly though.  Unfortunately, you need to be able to see the drive to use it.

English Wikipedia: https://en.wikipedia.org/wiki/Dd_(Unix) (https://en.wikipedia.org/wiki/Dd_(Unix)).


Thank you very much, AnyInMokum!


For the moment I will follow the instructions of PCNetSpec.
Title: Re: USB-drive not seen in GParted and not able to format
Post by: AndyInMokum on October 19, 2015, 06:09:14 pm
Quote
...For the moment I will follow the instructions of PCNetSpec:- paulus
A very wise idea  ;).
Title: Re: USB-drive not seen in GParted and not able to format
Post by: PCNetSpec on October 19, 2015, 06:13:37 pm
Quote
[  238.549545] sd 2:0:0:0: [sdb] Attached SCSI removable disk

suggests it's being given a device node /dev/sdb

First make 100% sure sdb isn't your hard drive or any other drive you don't want wiped

Then what happens if you run:
Code: [Select]
sudo fdisk /dev/sdb
then hit then
o
then
w
key to create a new empty DOS partition table, then write a new partition table.

then see if gparted /disks / USB formatter will see the drive



Or to COMPLETELY erase /dev/sdb
Code: [Select]
sudo dd if=/dev/zero of=/dev/sdb bs=1M
then see if gparted /disks / USB formatter will see the drive
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 19, 2015, 06:21:15 pm
This is the output - BTW it is dev/sdc right now, as before I booted from a cd, and in the meantime I made a bootable USB-drive, and so the not-recognized drive changed from sdb to sdc, so please, don't worry, it's alright!
Output:
[/code]
Code: [Select]
peppermint@peppermint ~ $ sudo fdisk /dev/sdc
fdisk: unable to open /dev/sdc: No medium found
peppermint@peppermint ~ $ w
 22:17:52 up 7 min,  8 users,  load average: 0.02, 0.27, 0.20
USER     TTY      FROM             LOGIN@   IDLE   JCPU   PCPU WHAT
peppermi tty5                      22:11    6:54   0.06s  0.05s -bash
peppermi tty2                      22:11    6:54   0.04s  0.04s -bash
peppermi tty3                      22:11    6:54   0.05s  0.05s -bash
peppermi tty4                      22:11    6:54   0.04s  0.02s -bash
peppermi tty6                      22:11    6:54   0.02s  0.02s -bash
peppermi tty1                      22:11    6:54   0.02s  0.02s -bash
peppermi :0       :0               22:11   ?xdm?   1:34   0.90s /usr/bin/lxsess
peppermi pts/0    :0               22:17    1.00s  0.04s  0.00s w
peppermint@peppermint ~ $



Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 20, 2015, 10:56:17 am
Quote
[  238.549545] sd 2:0:0:0: [sdb] Attached SCSI removable disk

suggests it's being given a device node /dev/sdb

First make 100% sure sdb isn't your hard drive or any other drive you don't want wiped

Then what happens if you run:
Code: [Select]
sudo fdisk /dev/sdb
then hit then
o
then
w
key to create a new empty DOS partition table, then write a new partition table.

then see if gparted /disks / USB formatter will see the drive



Or to COMPLETELY erase /dev/sdb
Code: [Select]
sudo dd if=/dev/zero of=/dev/sdb bs=1M
then see if gparted /disks / USB formatter will see the drive


To be sure I also tried both your commands again; this is the output:
Code: [Select]
paul@paul-ESPRIMO-P3521 ~ $ sudo fdisk /dev/sdb
[sudo] password for paul:
fdisk: kan /dev/sdb niet openen: Geen medium gevonden
paul@paul-ESPRIMO-P3521 ~ $ sudo dd if=/dev/zero of=/dev/sdb bs=1M
dd: openen van ‘/dev/sdb’ is mislukt: Geen medium gevonden
paul@paul-ESPRIMO-P3521 ~ $

So it is obvious that NO MEDIUM is found. Neither fdisk is able to reach the USB-drive, nor dd, so what is left to try?

Is nobody around who knows something about this matter?

If not in Linux, maybe in Windows? I already tried HP USB Disk Storage Format Tool, but also that Windows tool does not recognize the USB-drive!

Is there anything left that I could try? :(
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 20, 2015, 11:05:50 am
The only tool in which the USB-drive is seen, recognized, is in Drives or Disks:

So again: is there anybody around who is familiar with this??? :-\


(http://s24.postimg.org/mw35xjpth/Schijven_002.png)
Title: Re: USB-drive not seen in GParted and not able to format
Post by: AndyInMokum on October 20, 2015, 04:38:53 pm
Hi paulus, this is just a thought.  Have you tried a different USB port?  With the USB stick inserted in the new port, run the command PCNetSpec gave you earlier:
Code: [Select]
dmesg | tail -n 40
Or just run:
Code: [Select]
sudo fdisk -l
Post back the outputs  ;).
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 20, 2015, 04:45:33 pm
Hi AndyInMokum,

This is the output:
Code: [Select]
paul@paul-ESPRIMO-P3521 ~ $ dmesg | tail -n 40
[20311.643397] audit: type=1400 audit(1445355497.503:57): apparmor="DENIED" operation="open" profile="/usr/bin/evince" name="/etc/xdg/peppermint/applications/defaults.list" pid=11196 comm="evince" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[20336.630919] usblp0: removed
[20346.514101] usblp 2-1:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04E8 pid 0x3292
[20346.514544] usblp0: removed
[20346.624023] usb 2-1: reset full-speed USB device number 2 using uhci_hcd
[20346.779940] usblp 2-1:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04E8 pid 0x3292
[20347.837184] audit: type=1400 audit(1445355533.699:58): apparmor="DENIED" operation="open" profile="/usr/bin/evince" name="/etc/xdg/peppermint/applications/defaults.list" pid=11260 comm="evince" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[20363.343441] audit: type=1400 audit(1445355549.202:59): apparmor="DENIED" operation="open" profile="/usr/bin/evince" name="/etc/xdg/peppermint/applications/defaults.list" pid=11281 comm="evince" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[20378.014386] usblp0: removed
[20387.449693] usblp 2-1:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04E8 pid 0x3292
[20387.449780] usblp0: removed
[20387.560024] usb 2-1: reset full-speed USB device number 2 using uhci_hcd
[20387.715804] usblp 2-1:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04E8 pid 0x3292
[20617.867905] audit: type=1400 audit(1445355803.725:60): apparmor="DENIED" operation="open" profile="/usr/bin/evince" name="/etc/xdg/peppermint/applications/defaults.list" pid=11368 comm="evince" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[22153.633137] audit: type=1400 audit(1445357339.494:61): apparmor="DENIED" operation="open" profile="/usr/bin/evince" name="/etc/xdg/peppermint/applications/defaults.list" pid=11660 comm="evince" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[22738.338123] audit: type=1400 audit(1445357924.198:62): apparmor="DENIED" operation="open" profile="/usr/bin/evince" name="/etc/xdg/peppermint/applications/defaults.list" pid=11774 comm="evince" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[22798.993899] audit: type=1400 audit(1445357984.853:63): apparmor="DENIED" operation="connect" profile="/usr/bin/evince-previewer" name="/run/dbus/system_bus_socket" pid=11812 comm="pool" requested_mask="wr" denied_mask="wr" fsuid=1000 ouid=0
[22798.996782] audit: type=1400 audit(1445357984.857:64): apparmor="DENIED" operation="connect" profile="/usr/bin/evince-previewer" name="/run/dbus/system_bus_socket" pid=11812 comm="pool" requested_mask="wr" denied_mask="wr" fsuid=1000 ouid=0
[22799.032137] usblp0: removed
[22808.185801] usblp 2-1:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04E8 pid 0x3292
[22808.185890] usblp0: removed
[22808.296027] usb 2-1: reset full-speed USB device number 2 using uhci_hcd
[22808.452066] usblp 2-1:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04E8 pid 0x3292
[38398.493270] usb 1-5: USB disconnect, device number 7
[38418.477743] usb 1-2: USB disconnect, device number 3
[38423.340019] usb 1-2: new high-speed USB device number 8 using ehci-pci
[38423.473464] usb 1-2: New USB device found, idVendor=04a9, idProduct=1909
[38423.473469] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[38423.473472] usb 1-2: Product: CanoScan
[38423.473475] usb 1-2: Manufacturer: Canon
[38435.152024] usb 1-4: new high-speed USB device number 9 using ehci-pci
[38435.753624] usb 1-4: New USB device found, idVendor=058f, idProduct=1234
[38435.753630] usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[38435.753634] usb 1-4: Product: Mass Storage Device
[38435.753637] usb 1-4: Manufacturer: Alcor Micro
[38435.753925] usb-storage 1-4:1.0: USB Mass Storage device detected
[38435.754024] scsi4 : usb-storage 1-4:1.0
[38436.752761] scsi 4:0:0:0: Direct-Access     Generic  USB Flash Disk   7.76 PQ: 0 ANSI: 4
[38436.753221] sd 4:0:0:0: Attached scsi generic sg2 type 0
[38436.756881] sd 4:0:0:0: [sdb] Attached SCSI removable disk
paul@paul-ESPRIMO-P3521 ~ $ sudo fdisk -l
[sudo] password for paul:


Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 koppen, 63 sectoren/spoor, 30401 cilinders, totaal 488397168 sectoren
Eenheid = sectoren van 1 * 512 = 512 bytes
Sectorgrootte (logischl/fysiek): 512 bytes / 512 bytes
in-/uitvoergrootte (minimaal/optimaal): 512 bytes / 512 bytes
Schijf-ID: 0x000a9663


 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sda1   *        2048    81344069    40671011   83  Linux
/dev/sda2        81344510   488396799   203526145    5  uitgebreid
/dev/sda5       471885824   488396799     8255488   82  Linux wisselgeheugen
/dev/sda6        81344512   471885823   195270656   83  Linux


Partitietabel-items liggen niet in schijfvolgorde.
paul@paul-ESPRIMO-P3521 ~ $

I changed the USB-stick from a front port to a back port, and executed both commands.

I also checked Drives, with exactly the same content.
Title: Re: USB-drive not seen in GParted and not able to format
Post by: AndyInMokum on October 20, 2015, 05:43:15 pm
Hi paulus, it's still indicating it's: sdb but not showing up in fdisk.  I'm getting the horrible feeling the USB stick is fried.  Let's first try and nuke it again with dd.  First, remove any other attached USB devices and run:
Code: [Select]
dmesg | tail -n 40
Check the drive is still sdbIf it isn't, sdb change it in the command below.  Now run:
Code: [Select]
sudo dd if=/dev/zero of=/dev/sdb bs=1M 
If this works, it will take a long time to complete.  If it looks like nothing is happening, just leave it to complete.  If it goes straight back to the prompt or if there is an error message.  This means it hasn't worked.  Post back the output - good luck  ;)!
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 21, 2015, 06:22:20 am
Hi AndyInMokum,

Thank you!

The output of both commands:
Code: [Select]
paul@paul-ESPRIMO-P3521 ~ $ dmesg | tail -n 40
[   13.784160] sd 3:0:0:0: [sdc] Mode Sense: 43 00 00 00
[   13.785163] sd 3:0:0:0: [sdc] No Caching mode page found
[   13.785193] sd 3:0:0:0: [sdc] Assuming drive cache: write through
[   13.789580] sd 2:0:0:0: [sdb] Attached SCSI removable disk
[   13.790058]  sdc: sdc1 sdc2
[   13.792538] sd 3:0:0:0: [sdc] Attached SCSI removable disk
[   14.261296] r8169 0000:03:00.0 eth0: link down
[   14.261308] r8169 0000:03:00.0 eth0: link down
[   14.261328] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   15.269855] init: nvidia-prime main process (1030) terminated with status 127
[   15.888885] r8169 0000:03:00.0 eth0: link up
[   15.888894] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   15.971722] vboxdrv: module verification failed: signature and/or  required key missing - tainting kernel
[   15.974374] vboxdrv: Found 2 processor cores
[   15.976015] vboxdrv: fAsync=0 offMin=0x1ce offMax=0x11a9
[   16.076132] vboxdrv: TSC mode is Synchronous, tentative frequency 2933309177 Hz
[   16.076135] vboxdrv: Successfully loaded version 5.0.6 (interface 0x00240000)
[   16.279680] VBoxNetFlt: Successfully started.
[   16.286863] VBoxNetAdp: Successfully started.
[   16.288583] VBoxPciLinuxInit
[   16.290867] vboxpci: IOMMU not found (not registered)
[   17.050075] init: plymouth-upstart-bridge main process ended, respawning
[  165.119474] usb 1-5: USB disconnect, device number 5
[  204.656026] usb 1-5: new high-speed USB device number 6 using ehci-pci
[  205.267492] usb 1-5: New USB device found, idVendor=0000, idProduct=0000
[  205.267498] usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  205.267501] usb 1-5: Product: Removable Drive
[  205.267504] usb 1-5: SerialNumber: 22355808090842020041
[  205.268605] usb-storage 1-5:1.0: USB Mass Storage device detected
[  205.268697] scsi4 : usb-storage 1-5:1.0
[  206.269377] scsi 4:0:0:0: Direct-Access                               0    PQ: 0 ANSI: 0 CCS
[  206.269721] sd 4:0:0:0: Attached scsi generic sg3 type 0
[  206.271744] sd 4:0:0:0: [sdc] 7831552 512-byte logical blocks: (4.00 GB/3.73 GiB)
[  206.273259] sd 4:0:0:0: [sdc] Write Protect is off
[  206.273267] sd 4:0:0:0: [sdc] Mode Sense: 43 00 00 00
[  206.274372] sd 4:0:0:0: [sdc] No Caching mode page found
[  206.274378] sd 4:0:0:0: [sdc] Assuming drive cache: write through
[  206.280156]  sdc: sdc1 sdc2
[  206.282866] sd 4:0:0:0: [sdc] Attached SCSI removable disk
[  236.121291] usb 1-5: USB disconnect, device number 6
paul@paul-ESPRIMO-P3521 ~ $ sudo dd if=/dev/zero /dev/sdb bs=1M
[sudo] password for paul:
dd: niet-herkend argument: ‘/dev/sdb’
Typ 'dd --help' voor meer informatie.
paul@paul-ESPRIMO-P3521 ~ $

So still no recognition. Is the only conclusion now that the disk is dead?
:o
Title: Re: USB-drive not seen in GParted and not able to format
Post by: AndyInMokum on October 21, 2015, 07:00:32 am
Hi paulus, for what it's worth, I made a mistake in the dd command with the output file - sorry about that  :-[.  The command should have read:
Code: [Select]
sudo dd if=/dev/zero of=/dev/sdb bs=1M
Try it again, I don't think it'll make any difference.  We need to verify it before we can call it a dead stick  ;).

Very Important: You also didn't notice that the drive location had changed from sdb to sdc.  Please be extremely careful that you get this correct.  Getting it wrong can cause catastrophic damage to your data.  The command in this case should have read:
Code: [Select]
sudo dd if=/dev/zero of=/dev/sdc bs=1M

Note:  Incorrect command in previous post has been corrected.
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 21, 2015, 07:15:41 am
Hi AndyInMokum,

I didn't see any difference in the command, but re-executed it anyway, but with the same result.

So now I have to give up on that USB-stick? :-\
Title: Re: USB-drive not seen in GParted and not able to format
Post by: AndyInMokum on October 21, 2015, 07:52:39 am
Yeah, I think that exhausts all possibilities.  Unless someone knows of another technique, I think your right in calling this a dead USB stick  :(. 
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 21, 2015, 08:06:46 am
Yeah, I think that exhausts all possibilities.  Unless someone knows of another technique, I think your right in calling this a dead USB stick  :( .

Hi AndyInMokum,
Thank you for thinking along and trying to find a solution; much appreciated! :)
So I will leave this thread "open" and hereby invite anyone who has any idea to reflect on this subject and share his or her expertise! 8)

Kind regards,

paulus
Title: Re: USB-drive not seen in GParted and not able to format
Post by: darknet on October 21, 2015, 09:14:38 am
Paulus, maybe have a look at this tutorial: http://www.unixmen.com/how-to-format-usb-drive-in-the-terminal/
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 21, 2015, 02:36:21 pm
Paulus, maybe have a look at this tutorial: http://www.unixmen.com/how-to-format-usb-drive-in-the-terminal/ (http://www.unixmen.com/how-to-format-usb-drive-in-the-terminal/)

Hi drum,

Thanks for helping!

I looked at the tutorial, but it didn't work. The problem is, that the USB-stick isn't recognized. Only in Disks it is seen, and there it is just the same as an empty cd-rom drive: an empty vessel without any contents. So it says: No Media, exactly the same output as for the cd-rom drive!

One could say: analogue to the cd-drive, that CAN be filled with media, also the - now empty - USB-stick could be filled with media. It should be no big deal, so it seems at least.
I am afraid the drive is gone, but I keep hope! :'(
One the other hand: since PCNetSpec does not interfere anymore - and he IS the specialist, I am convinced of that - I fear the worse. >:(
Title: Re: USB-drive not seen in GParted and not able to format
Post by: AndyInMokum on October 21, 2015, 04:34:58 pm
Hi paulus, I forgot to mention this great deal that I found.  The other week, I picked up a PNY-64GB USB-3 thumb drive for €20 at Dixons.  They always have some kind of deal going on.  It' s worth keeping an eye on them.  There's a Dixons on Kruisweg in Hoofddorp  ;).
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 21, 2015, 05:07:22 pm
Hi paulus, I forgot to mention this great deal that I found.  The other week, I picked up a PNY-64GB USB-3 thumb drive for €20 at Dixons.  They always have some kind of deal going on.  It' s worth keeping an eye on them.  There's a Dixons on Kruisweg in Hoofddorp  ;) .

AndyInMokum,

Great that you let me know of this deal! 8)

Unfortunately the shop in Hoofddorp at the Kruisweg has ended. But I could go to Amstelveen, according to their site.

Again: thanks, but hopefully there is someone to make the stick revive again?! :-\
Title: Re: USB-drive not seen in GParted and not able to format
Post by: EdgarTorres on October 22, 2015, 04:58:34 am
Tough works,  ;)
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 22, 2015, 07:49:22 am
Tough works,  ;)

Hi EdgarTorres,

What do you mean by that?
Title: Re: USB-drive not seen in GParted and not able to format
Post by: AndyInMokum on October 22, 2015, 08:44:19 am
Tough works,  ;)

Hi EdgarTorres,

What do you mean by that?
It looks like a lost in translation moment.  Tough luck or bad luck  ;D.
Title: Re: USB-drive not seen in GParted and not able to format
Post by: Midas on October 22, 2015, 12:37:44 pm

Hi....

Just a last minute suggestion: if your pendrive problem still lingers, and you want to establish beyond doubt that it absolutely works (and you can have a go at it from a Windows system) you should Google for the single executable freeware utility called Bootice and use it to examine your USB drive.

(You will find trustworthy download links at portablefreeware.com, for instance)

For a summary explanation, Bootice lets you format pendrives using at least 5 different schemes, it lets you change partition identifiers, and much more. You can't get much more low-level than that...

Tapatalked from my V500
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on October 22, 2015, 02:29:16 pm

Hi....

Just a last minute suggestion: if your pendrive problem still lingers, and you want to establish beyond doubt that it absolutely works (and you can have a go at it from a Windows system) you should Google for the single executable freeware utility called Bootice and use it to examine your USB drive.

(You will find trustworthy download links at portablefreeware.com, for instance)

For a summary explanation, Bootice lets you format pendrives using at least 5 different schemes, it lets you change partition identifiers, and much more. You can't get much more low-level than that...

Tapatalked from my V500


Hi Midas,

Thanks for helping!

In Windows the USB-drive is only recognized as in Drives: it is only an empty vessel, "without a disk", so it says. It is "Removable disk E:" in Windows, but asks for inserting a disk when double clicking on the icon.

I tried to approach it with Bootice, but there it is not seen at all! Nevertheless I tried the command line option, but it didn't help.

Anyway, thanks for sharing: in that way I was able to make another attempt to revive the USB-thumb drive, but unfortunately without success.

So I invite anyone who has any idea to do the same as Midas: share what you think might lead to a solution! :o
Title: Re: USB-drive not seen in GParted and not able to format
Post by: Ralph on November 23, 2015, 02:54:04 pm
It looks like you have access to a Windows Machine. In Windows 7,8 and now 10 they have a command line function called diskpart. It might be available back as far as XP..
You may want to try the diskpart from the command line. It might be worth a try. You can find instructions on this Seagate Website.                                                  http://knowledge.seagate.com/articles/en_US/FAQ/005929en?language=en_US
Here is a site that goes through a step by step approach to trouble shooting a flash with Windows.                            http://www.techspot.com/community/topics/troubleshoot-windows-wont-recognize-usb-hard-drive-fix-unassigned-drive-letter.122125/
It may well be that you have a spent flashdrive. The manufacturer Alcor Micro has a website.                                       http://www.alcormicro.com/en_content/d_contact/contact.html
You may have to contact them for advice and see if they will stand behind their product. I had this trouble with a brand new flashdrive from Adata. They had a tool to check a drive and but it back to factory state. If it passed it was good and if not a RMA was in order. Maybe Alcor has something similar.
Good luck.
BTW. I understand the desire to get that sucker to work but for all the time you have spent on this you could buy an new USB 2.0, 8GB for a couple of bucks.
Title: Re: USB-drive not seen in GParted and not able to format
Post by: paulus on November 24, 2015, 01:23:05 pm
It looks like you have access to a Windows Machine. In Windows 7,8 and now 10 they have a command line function called diskpart. It might be available back as far as XP..
You may want to try the diskpart from the command line. It might be worth a try. You can find instructions on this Seagate Website.                                                  http://knowledge.seagate.com/articles/en_US/FAQ/005929en?language=en_US (http://knowledge.seagate.com/articles/en_US/FAQ/005929en?language=en_US)
Here is a site that goes through a step by step approach to trouble shooting a flash with Windows.                            http://www.techspot.com/community/topics/troubleshoot-windows-wont-recognize-usb-hard-drive-fix-unassigned-drive-letter.122125/ (http://www.techspot.com/community/topics/troubleshoot-windows-wont-recognize-usb-hard-drive-fix-unassigned-drive-letter.122125/)
It may well be that you have a spent flashdrive. The manufacturer Alcor Micro has a website.                                       http://www.alcormicro.com/en_content/d_contact/contact.html (http://www.alcormicro.com/en_content/d_contact/contact.html)
You may have to contact them for advice and see if they will stand behind their product. I had this trouble with a brand new flashdrive from Adata. They had a tool to check a drive and but it back to factory state. If it passed it was good and if not a RMA was in order. Maybe Alcor has something similar.
Good luck.
BTW. I understand the desire to get that sucker to work but for all the time you have spent on this you could buy an new USB 2.0, 8GB for a couple of bucks.


Hi Ralph,
Thanks for trying to help, but I already tried that and it didn't help. But again: thank you for sharing your idea! ;)

paulus