Peppermint OS

Support => Hardware => Topic started by: rajeev2631007 on September 29, 2015, 10:00:42 pm

Title: During typing anything the cursor will jump around
Post by: rajeev2631007 on September 29, 2015, 10:00:42 pm
During typing anything the cursor will jump around and screw up what we’re typing.  :-[ Laptop and OS details as below:-

Dell Inspiron 14R N4110 Notebook
OS Linux Mint 17.2 Cinnoman


Early we think maybe we were touching touch pad during typing that why it happening. It was not that case it is something else which we are not able to identify. :-\  I request you please help me in this any body face such issue in past.

Regards,

Rajeev Gautam   
Title: Re: During typing anything the cursor will jump around
Post by: PCNetSpec on September 30, 2015, 01:47:18 am
Let's see if it is the touchpad by killing it whilst typing....

run
Code: [Select]
syndaemon -i 1 -dwhich will kill the touchpad for 1 second every time you hit a keyboard key.

you can turn this off by either logging off/on, or running:
Code: [Select]
sudo killall syndaemon
Title: Re: During typing anything the cursor will jump around
Post by: rajeev2631007 on September 30, 2015, 07:57:09 am
Hi PCNetSpec,

It's work. This resolve my issue.  8) 8)

Code: [Select]
syndaemon -i 1 -d -t
#       -t     Only disable tapping and  scrolling,  not  mouse  movements,  in
              response to keyboard activity.
     
#        -i <idle-time>
              How many seconds  to  wait  after  the  last  key  press  before
              enabling the touchpad.  (default is 2.0s).

#        -d     Start as a daemon, ie in the background.

And add this into autostart as command.  ;)

Thank You very..............much. You people are awesome.

Regards,

Rajeev Gautam

Title: Re: During typing anything the cursor will jump around
Post by: PCNetSpec on September 30, 2015, 09:54:57 am
You're most welcome :)
Title: Re: During typing anything the cursor will jump around [SOLVED]
Post by: Toshmarple on October 02, 2015, 06:59:28 am
I would like to add my problem to this discussion please.

My keyboard jumps around when typing but as I use a mouse I can disable the touch-pad which I do by un-checking all the boxes via 'Peppermint Control Centre' and then it is fine.  However my laptop does not retain the settings so every time I reboot I have to un-check the boxes again.  I have tried to find a solution to make things permanent but so far without success.  Can somebody please tell me what to do to make the dis-abling permanent.  I guess I should add something to 'Autostart'
Title: Re: During typing anything the cursor will jump around
Post by: PCNetSpec on October 02, 2015, 01:23:15 pm
What's the output from:
Code: [Select]
cat ~/.config/peppermint-control-center/pointerboth before a reboot (touchpad disabled) and immediately after a reboot (when the touchpad has re-enabled itself
Title: Re: During typing anything the cursor will jump around
Post by: Toshmarple on October 03, 2015, 01:22:14 am
This is output after rebooting with touchpad self enabled i.e both mouse and touchpad working with keyboard jumping:

Code: [Select]
carlos@carlos-Inspiron-N5110 ~ $ cat ~/.config/peppermint-control-center/pointer#!/bin/bash
#Autogenerated script - Do not edit
xset m 2 2
xmodmap -e "pointer = 1 2 3"
synclient TouchPadOff=1
synclient VertEdgeScroll=0
synclient HorizEdgeScroll=0
synclient TapButton1=0
synclient VertTwoFingerScroll=0
synclient HorizTwoFingerScroll=0
carlos@carlos-Inspiron-N5110 ~ $

And this is after using PCC to disable touchpad which required the 'touchpad enabled box to be ticked and unticked (all tick boxes show as unchecked):

Code: [Select]
carlos@carlos-Inspiron-N5110 ~ $ cat ~/.config/peppermint-control-center/pointer#!/bin/bash
#Autogenerated script - Do not edit
xset m 2 2
xmodmap -e "pointer = 1 2 3"
synclient TouchPadOff=1
synclient VertEdgeScroll=0
synclient HorizEdgeScroll=0
synclient TapButton1=0
synclient VertTwoFingerScroll=0
synclient HorizTwoFingerScroll=0
carlos@carlos-Inspiron-N5110 ~ $

I may be missing something but I can't see any difference so after saving this as a draft I'm going to repeat the exercise, this time in reverse order: the results  are the same so I'm not repeating the outputs.

Hope you can make something of it all. ???
Title: Re: During typing anything the cursor will jump around
Post by: PCNetSpec on October 03, 2015, 02:31:26 am
OK the TouchPadOff=1 setting *is* being saved and persisting across the reboot, but is obviously not being acted upon.

So can you post the contents of:
Code: [Select]
gedit ~/.config/autostart/peppermint-control-center.desktopand
Code: [Select]
gedit /usr/bin/ppmcc-startupand can you reboot, so the touchpad is enabled, then confirm that running:
Code: [Select]
ppmcc-startupin a terminal disables the touchpad ?
Title: Re: During typing anything the cursor will jump around
Post by: Toshmarple on October 03, 2015, 03:08:54 am
What a fast reply!  Here goes:

Request 1 Output from Notepad:-
Code: [Select]
[Desktop Entry]
Version=1.0
Name=Load Input Settings
Comment=Load Input Settings
Exec=ppmcc-startup
Icon=peppermint-control-center
Type=Application
Encoding=UTF-8
Categories=Application;Settings
NotShowIn=LXDE;

Request 2:-
Code: [Select]
#!/bin/sh
sleep 1 && $HOME/.config/peppermint-control-center/pointer && $HOME/.config/peppermint-control-center/keyboard && $HOME/.config/peppermint-control-center/keyboard_layout &
exit 0

Request 3, run ppmcc-startup:-
Yes it does indeed disable touchpad.

Thanks
Title: Re: During typing anything the cursor will jump around
Post by: PCNetSpec on October 03, 2015, 03:51:52 am
OK, let's see if extending the delay in ppmcc-startup helps....

Please run:
Code: [Select]
sudo gedit /usr/bin/ppmcc-startupFind the section that reads:-

sleep 1

and change it to:-

sleep 5

so the whole thing now reads:
Code: [Select]
#!/bin/sh
sleep 5 && $HOME/.config/peppermint-control-center/pointer && $HOME/.config/peppermint-control-center/keyboard && $HOME/.config/peppermint-control-center/keyboard_layout &
exit
SAVE the file and exit gedit.

Now try logging off/on and see if the touchpad disables after 5 seconds.

it may not work .. we may need to add the delay to the autostart file instead .. but let's try this first.
Title: Re: During typing anything the cursor will jump around
Post by: Toshmarple on October 03, 2015, 04:59:44 am
Unfortunately no it didn't and I have checked the file to ensure it is showing 5 not 1, sorry!
Title: Re: During typing anything the cursor will jump around
Post by: PCNetSpec on October 03, 2015, 05:09:10 am
OK, run:
Code: [Select]
sudo gedit /usr/bin/ppmcc-startupand change it back to "sleep 1" .. SAVE the file and exit gedit.

Back in the terminal run:
Code: [Select]
gedit ~/.config/autostart/peppermint-control-center.desktopand make it read:
Code: [Select]
[Desktop Entry]
Version=1.0
Name=Load Input Settings
Comment=Load Input Settings
Exec=bash -c "sleep 5 ; ppmcc-startup"
Icon=peppermint-control-center
Type=Application
Encoding=UTF-8
Categories=Application;Settings
NotShowIn=LXDE;
SAVE the file and exit gedit.

Log off/on to test the touchpad gets disabled 5 seconds after logging on
Title: Re: During typing anything the cursor will jump around
Post by: Toshmarple on October 03, 2015, 05:37:40 am
I'm really sorry to but the touchpad is still not  disabled.

Thought:  You may remember that I screwed up some time ago after first installing P6 so could it be something is corrupted, perhaps PCC itself.  Could I/should I re-install it and if so how?  I really feel embarrassed as I'm sure it is something I have done.
Title: Re: During typing anything the cursor will jump around
Post by: PCNetSpec on October 03, 2015, 05:46:15 am
OK let's work around the problem.

run:
Code: [Select]
gedit ~/.config/autostart/peppermint-control-center.desktopand put it back to
Code: [Select]
[Desktop Entry]
Version=1.0
Name=Load Input Settings
Comment=Load Input Settings
Exec=ppmcc-startup
Icon=peppermint-control-center
Type=Application
Encoding=UTF-8
Categories=Application;Settings
NotShowIn=LXDE;
SAVE the file and exit gedit.

Now go to:-
menu > Preferences > Default applications for LXsession > Autostart (tab)

in the dialog box next to "Add +" enter:
ppmcc-startup
and click the "Add +" button.

Now log off/on to test.
Title: Re: During typing anything the cursor will jump around
Post by: Toshmarple on October 03, 2015, 06:03:41 am
 :) Hooray, hooray, it's working, did two reboots just to be sure.  Thank you very much. :)

PS - I've marked my first post solved but I did not start the original post so I can't mark it solved.
Title: Re: During typing anything the cursor will jump around
Post by: PCNetSpec on October 03, 2015, 06:56:50 am
That's fine, but next time can you start your own topic .. this is just one of the reasons we prefer things that way :)
Title: Re: During typing anything the cursor will jump around
Post by: Toshmarple on October 03, 2015, 07:20:34 am
Sorry, I thought I was doing the right thing in NOT starting another thread on what I believed to be the same subject.  :-[