Peppermint OS

Support => New Users => Topic started by: chesterton on April 24, 2014, 08:56:11 am

Title: Question about old forum "Is this the answer to my usb wifi"? (Solved)
Post by: chesterton on April 24, 2014, 08:56:11 am
Hi,

I am unable to find this old topic on this new forum, so I'll start a new thread here. I apologize if that's not the correct process.

I am converting two old Toshiba notebook computers from XP to Peppermint. I am using one to try out the steps for the other one (my mother-in-laws). Since she's still using hers, I wanted to limit the downtime. Anyway, for the trial PC, I found that the TP-LINK TL-WN725N wireless USB that I'm going to use for my mother-in-law's machine required some changes to Peppermint that are explained well in the old forum topic "Is this the answer to my usb wifi problem?". Everything went smoothly when I tried out the changes to the trial PC.

But when I tried the same steps on my mother-in-law's laptop, I got an error. All looked good until this step:

cd ~/RTL8188EU/rtl8188eu
make

When I did the make, I got this error:

make: *** /lib/modules/3.8.0-33-generic/build: No such file or directory.  Stop.
make: *** [modules] Error 2

I didn't get this error on the trial machine.
I checked both of the computers, and neither have a file or directory called "/lib/modules/3.8.0-33-generic/build".

Thanks in advance for any help.
Title: Re: Question about old forum "Is this the answer to my usb wifi"?
Post by: PCNetSpec on April 24, 2014, 11:21:47 am
Connect the PC to  your router with an ethernet cable .. then open a terminal and run:
Code: [Select]
sudo apt-get updatethen
Code: [Select]
sudo apt-get upgradethen
Code: [Select]
sudo apt-get dist-upgradethen REBOOT

Once rebooted, run:
Code: [Select]
sudo apt-get install linux-headers-generic build-essentialNow follow the original instructions again.
Title: Re: Question about old forum "Is this the answer to my usb wifi"?
Post by: chesterton on April 24, 2014, 04:02:23 pm
That got it! Wifi's up and working. Thanks so much!
Title: Re: Question about old forum "Is this the answer to my usb wifi"? (Solved)
Post by: PCNetSpec on April 25, 2014, 02:38:09 am
You're welcome .. thanks for marking the topic solved :)