Peppermint OS

Support => Networking => Topic started by: Brotherred on April 30, 2015, 09:16:13 am

Title: changed IP address SOLVED
Post by: Brotherred on April 30, 2015, 09:16:13 am
I made a big mistake I guess. I changed my IP address and now my PC will not connect over Ethernet.

Please help and regards.
Title: Re: changed IP address
Post by: mac on April 30, 2015, 09:58:20 am
Can you elaborate on that a bit Brotherred?  How, exactly, did you change it?
Are you running P4?
Title: Re: changed IP address
Post by: Brotherred on May 01, 2015, 05:02:44 am
I changed it manually in /etc/network/interfaces with:

auto eth0
iface eth0 inet static

I know I should have made the a back up of the original but I didn't. I do not know if I am running P4. I am on the wireless connection now but I appear to need the Ethernet so I can use my wifi only for casting to my TV. Not that the option will improve the lag I am getting in my Chromecasting but I need to try it. The reason I tried to change it is that  for some reason Big Ten Network will not let me sign up for Live streaming on my PC, (I have the necessary subscription(s) and I do not have any reason to think that the OS is the issue. And I know I pissed off someone in their technical department. I told them I am going to consume BTN content where and however I want (Like my Roku) and they are very welcome.
Title: Re: changed IP address
Post by: mac on May 01, 2015, 05:44:39 am
Do you need a static ip address?
If not, try editing your /etc/network/interface like so...
Code: [Select]
sudo gedit /etc/network/interfacesEdit the file to look like this...
Code: [Select]
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
Save, exit gedit and reboot.

Alternatively, you can just install P5, which you really need to do anyway because P4 is no longer supported.  Back up / save your important files & info first, of course.

Or, if you can wait a few weeks, P6 will be available. 

Please post the output from...
Code: [Select]
sudo lshw -C networkand ...
Code: [Select]
inxi -F
Title: Re: changed IP address
Post by: AndyInMokum on May 01, 2015, 06:53:03 am
Hi Brotherred, to find out which version of Peppermint you are running.  Enter the following command into a terminal window:
Code: [Select]
cat /etc/*releasePost the output back to the forum  ;).
Title: Re: changed IP address
Post by: Brotherred on May 02, 2015, 01:31:50 am
Output from sudo lshw -C network

Code: [Select]
       description: Ethernet interface
       product: NetXtreme BCM5782 Gigabit Ethernet
       vendor: Broadcom Corporation
       physical id: 2
       bus info: pci@0000:05:02.0
       logical name: eth1
       version: 03
       serial: 00:40:ca:5e:36:41
       capacity: 1Gbit/s
       width: 64 bits
       clock: 66MHz
       capabilities: pm vpd msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.121 firmware=5782-v3.13 latency=64 link=no mingnt=64 multicast=yes port=twisted pair
       resources: irq:20 memory:f8500000-f850ffff
       description: Ethernet interface
       product: 82557/8/9/0/1 Ethernet Pro 100
       vendor: Intel Corporation
       physical id: 4
       bus info: pci@0000:05:04.0
       logical name: eth0
       version: 04
       serial: 00:a0:c9:af:8b:d0
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.24-k2-NAPI duplex=full firmware=N/A ip= latency=66 link=yes maxlatency=56 mingnt=8 multicast=yes port=MII speed=100Mbit/s
       resources: irq:16 memory:f8900000-f8900fff ioport:1000(size=32) memory:f8400000-f84fffff memory:f8a00000-f8afffff
       description: Wireless interface
       physical id: 1
       bus info: usb@1:6
       logical name: wlan0
       serial: 7c:dd:90:03:f4:28
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rt2800usb driverversion=3.2.0-80-generic firmware=0.29 ip= link=yes multicast=yes wireless=IEEE 802.11bgn

Output from inxi -F

Code: [Select]
$ inxi -F
System:    Host: brotherred-HP-d530-USDT-DG010A Kernel: 3.2.0-80-generic i686 (32 bit)
           Desktop: LXDE (Openbox 3.5.0) Distro: Peppermint Three                       
Machine:   System: Hewlett-Packard product: HP d530 USDT(DG010A)                         
           Mobo: Hewlett-Packard model: 0864h Bios: Hewlett-Packard version: 786B1 v1.14 date: 07/11/2003
CPU:       Single core Intel Pentium 4 CPU (-UP-) cache: 512 KB flags: (sse sse2) clocked at 2792.892 MHz
Graphics:  Card: Intel 82865G Integrated Graphics Controller
           X.Org: 1.11.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1440x900@59.9hz
           GLX Renderer: Mesa DRI Intel 865G x86/MMX/SSE2 GLX Version: 1.3 Mesa 8.0.4
Audio:     Card: Intel 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller driver: snd_intel8x0 Sound: ALSA ver: 1.0.24
Network:   Card-1: Broadcom NetXtreme BCM5782 Gigabit Ethernet driver: tg3
           IF: eth1 state: down mac: 00:40:ca:5e:36:41
           Card-2: Intel 82557/8/9/0/1 Ethernet Pro 100 driver: e100
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:a0:c9:af:8b:d0
           Card-3: Ralink RT2870/RT3070 Wireless Adapter driver: rt2800usb
           IF: wlan0 state: up mac: 7c:dd:90:03:f4:28
Drives:    HDD Total Size: 2040.4GB (17.5% used) 1: /dev/sda WDC_WD400BB 40.0GB
           2: /dev/sdc 003 2000.4GB
Partition: ID: / size: 36G used: 6.6G (20%) fs: ext4 ID: swap-1 size: 1.60GB used: 0.00GB (0%) fs: swap
Sensors:   Error: You do not have the sensors app installed.
Info:      Processes: 126 Uptime: 6 min Memory: 451.3/1499.5MB Client: Shell inxi: 1.7.33

Yep Peppermint 3


Thanx guys. I am definitely not the geek I used to think I would some day be.
Title: Re: changed IP address
Post by: PCNetSpec on May 02, 2015, 12:20:12 pm
So is this working now ?
Title: Re: changed IP address
Post by: Brotherred on May 02, 2015, 12:35:31 pm
Yes it is fixed. Sorry.
Title: Re: changed IP address
Post by: mac on May 02, 2015, 12:36:31 pm
Great!  :)
Title: Re: changed IP address
Post by: Slim.Fatz on May 02, 2015, 01:24:43 pm
Yes it is fixed. Sorry.

Now it would be nice and greatly appreciated if you would please go back to your first message and in the Subject line add [SOLVED].  ;)

Thanks in advance,

-- Slim