Peppermint OS

General => GNU/Linux Discussion => Topic started by: perknh on March 10, 2015, 10:28:12 am

Title: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox [SOLVED]
Post by: perknh on March 10, 2015, 10:28:12 am
Peppermint and Ubuntu users,

I have a friend with an old, old, old HP desktop computer.  It's a computer on which Chrome or Chromium browser won't function at all.  Peppermint 5 had, long ago, proven itself to be a no-go with this computer. (Thank you mac, PCNetSpec, and everyone who tried to help me 11 months ago with that issue.)  So, I eventually put Xubuntu on this old legacy computer.  Now a couple of days ago, I wanted to show one of my dearest of friends, who both owns and uses this computer, a video on YouTube.  And this is where my, and this old computer's, troubles begin.

YouTube in Firefox (the most current version whatever that may be) will not work with Xubuntu 14.04.2, 14.10, or 15.04.  It will not work within Ubuntu MATE 14.04.2 either.  Yes, for a split instant the YouTube video flashes onto the screen, and then, where the video would be, that space becomes empty and white, blending in with the white background of YouTube itself -- with no trace of a video to be seen.

I don't have access to that computer right this moment, but I'm wondering if any of the Firefox users using Peppermint, or any people here, who use any flavor of Ubuntu, have experienced any issue similar as this concerning Firefox and YouTube; and if so, what can I do about it when I get a chance to get back to that old legacy computer?

Thank you,

perknh
Title: Re: Any version of Ubuntu 14.4.2+ That Uses Firefox with YouTube
Post by: rjm65 on March 10, 2015, 11:07:30 am
yes i experienced this and pcnetspec solved it a long while back, it is flash, you don't have i think its sse2 or some type of flag on your processor that the new flash uses, going back to the old flash works on those processors...  :P
Title: Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
Post by: perknh on March 10, 2015, 02:01:13 pm
Thank you, rjm65.

Would you know which thread offers a solution to this problem?

When we installed Xubuntu 14.04, we did not have this problem.

Thank you,

perknh

P.S.

I never dawned on me until now to try Qupzilla or Opera, do you think one of these browsers might offer a simple solution for this problem.  I should mention that I did uninstall and then re-install Flash once through Ubuntu's software manager.  And I also installed Ubuntu-restricted-extras on one of my several installations too;  but none of these efforts helped me with this problem.
Title: Re: Any version of Ubuntu 14.4.2+ That Uses Firefox with YouTube
Post by: rjm65 on March 10, 2015, 03:31:47 pm
I have the text file from the thread on my linux tricks usb stick, here is what fixed it for me.... 
be sure to do the first command and see if your processor has sse2 if it don't then try what he said to try to fix it...  okie dokie???-------------
cat /proc/cpuinfo | grep sse
flags      : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pse36 mmx fxsr sse up

uname -a
Linux gateway9300pro-Solo-9300-Pro 3.2.0-60-generic #91-Ubuntu SMP Wed Feb 19 03:55:18 UTC 2014 i686 i686 i386 GNU/Linux

dpkg -l | grep flash
ii  flashplugin-installer                  11.2.202.341ubuntu0.12.04.1               Adobe Flash Player plugin installer

Code: [Select]
You're right, your CPU doesn't support sse2 so the 11.2.202 version of Adobes flash player won't work.

OK, uninstall flashplugin-installer:
Code:
sudo apt-get remove --purge flashplugin-installer

create the necessary directory for the flashplayer plugin:
Code:
mkdir -p ~/.mozilla/plugins

change directory to that directory:
Code:
cd ~/.mozilla/plugins

download the 32bit 11.1 flashplayer archive from my dropbox:
Code:
wget https://dl.dropboxusercontent.com/u/11876059/flashplayer-11.1-32bit.tar.gz

unpack the archive:
Code:
tar xvf flashplayer-11.1-32bit.tar.gz

now close ALL web browser instances and re-open Chromium

Test Flash
Title: Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
Post by: perknh on March 10, 2015, 03:35:03 pm
Thank you, rjm65! ;)
Title: Re: Any version of Ubuntu 14.4.2+ That Uses Firefox with YouTube
Post by: rjm65 on March 10, 2015, 03:37:22 pm
no problem like i said though check your processor first for sse2 if it has sse2 then you have another issue mine was old and only had sse and not sse2
Title: Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
Post by: perknh on March 10, 2015, 05:04:29 pm
I will check that, rjm65. 

Now I see, at the end of PCNetSpec's instructions, to reopen Chromium.  I suspect the same instructions will apply to Firefox browser too.

A Flash issue is a Flash issue no matter what browser one is using, I hope!

perknh
Title: Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
Post by: PCNetSpec on March 10, 2015, 05:29:00 pm
before you go any further, please post the output from:
Code: [Select]
uname -aand
Code: [Select]
dpkg -l | grep flashand
Code: [Select]
cat /proc/cpuinfo | grep -i flags
Title: Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
Post by: perknh on March 10, 2015, 05:58:49 pm
Hello PCNetSpec and thank you.

I will happily do so when I can return to that house.  I hope to be able to do so within a week.  The computer is in another town, and these folks are on a different schedule than me.

By the way, MATE seems to be a little speedier on that old computer than Xubuntu.

Thank you,

perknh
Title: Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
Post by: PCNetSpec on March 10, 2015, 06:16:33 pm
Okey Dokey pernh .. whenever you're ready :)
Title: Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
Post by: rjm65 on March 11, 2015, 05:40:55 am
I will check that, rjm65. 

Now I see, at the end of PCNetSpec's instructions, to reopen Chromium.  I suspect the same instructions will apply to Firefox browser too.

A Flash issue is a Flash issue no matter what browser one is using, I hope!

perknh
I never used chrome or chromium the first thing i always install is firefox if firefox is not installed by default....
Title: Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
Post by: perknh on March 11, 2015, 08:54:50 am
before you go any further, please post the output from:
Code: [Select]
uname -aand
Code: [Select]
dpkg -l | grep flashand
Code: [Select]
cat /proc/cpuinfo | grep -i flags

PCNetSpec, 

I did switch from MATE to Lubuntu on this old computer.  The computer was freezing up and unable to shut down with MATE.

perknh

Here's the data you asked for:

uname -a
Spoiler (click here to view / hide)
[close]


dpkg -l | grep flash
Spoiler (click here to view / hide)
[close]

cat /proc/cpuinfo | grep -i flags
Spoiler (click here to view / hide)
[close]
Title: Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
Post by: PCNetSpec on March 11, 2015, 09:34:51 am
Yep, as rjm65 suspected you have no sse2 flag so you'll need to downgrade to flashplayer 11.1

Open a terminal and run these commands in sequence
Code: [Select]
sudo apt-get remove --purge flashplugin-installerthen
Code: [Select]
mkdir -p ~/.mozilla/pluginsthen
Code: [Select]
cd ~/.mozilla/pluginsthen
Code: [Select]
wget https://dl.dropboxusercontent.com/u/11876059/flashplayer-11.1-32bit.tar.gzthen
Code: [Select]
tar xvf flashplayer-11.1-32bit.tar.gznow close ALL web browser instances and re-open Firefox

Test Flash
Title: Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
Post by: perknh on March 11, 2015, 09:47:39 am
Thank you, PCNetSpec, we're almost there!

Now I get this message that reads  "Firefox has prevented the outdated plugin "Adobe Flash" from running on www.youtube.com."

I bet rjm65 thinks this computer is an excellent candidate for antiX or MX-14!   ;)
Title: Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
Post by: rjm65 on March 11, 2015, 09:58:38 am
Thank you, PCNetSpec, we're almost there!

Now I get this message that reads  "Firefox has prevented the outdated plugin "Adobe Flash" from running on www.youtube.com."

I bet rjm65 thinks this computer is a good candidate for antiX or MX-14!  :)
Actually I think they use the same plugin so it is not going to matter, I could be wrong though...  :P
Title: Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
Post by: PCNetSpec on March 11, 2015, 10:08:53 am
Yeah in the drop down that says

firefox prevented the outdated "Adobe Flash" from running on <URL>

You'll have to select Allow > Allow and Remember
Title: Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox
Post by: perknh on March 11, 2015, 10:44:13 am
Well, gentlemen, you diagnosed and resolved that troublesome Flash problem.

A thousand thanks from the owner of this old legacy computer and from me.

And here's the song that we were unable to play before, but now can play for the joy of it.

Thank you,

perknh

Code: [Select]
https://www.youtube.com/watch?v=V1bFr2SWP1I or

https://www.youtube.com/watch?v=V1bFr2SWP1I (https://www.youtube.com/watch?v=V1bFr2SWP1I)

P.S.

And a bit about Israel Kamakawiwoʻole (Kah-MAH-kah-VEE-voh-OH-lay) -- the man who sang this song.

Code: [Select]
https://en.wikipedia.org/wiki/Israel_Kamakawiwo%CA%BBoleor

https://en.wikipedia.org/wiki/Israel_Kamakawiwo%CA%BBole (https://en.wikipedia.org/wiki/Israel_Kamakawiwo%CA%BBole)
Title: Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox [SOLVED]
Post by: perknh on March 11, 2015, 01:09:11 pm
I'm home now, and thank you two, rjm65 and PCNetSpec, for your help with Flash on that old computer. 

Since MATE was acting up on that old computer, I installed Lubuntu.  But, boy, did I notice a difference with speed.  Relatively speaking, MATE flew on that old computer, but Lubuntu seems pretty slow.

I wonder why LXDE is slower than MATE-- at least on that old computer.  Of course I'm also wondering why MATE froze on that old computer, so much so that it had to be turned off by a hard shut down.  :-\
Title: Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox [SOLVED]
Post by: rjm65 on March 11, 2015, 01:40:55 pm
I'm home now, and thank you two, rjm65 and PCNetSpec, for your help with Flash on that old computer. 

Since MATE was acting up on that old computer, I installed Lubuntu.  But, boy, did I notice a difference with speed.  Relatively speaking, MATE flew on that old computer, but Lubuntu seems pretty slow.

I wonder why LXDE is slower than MATE-- at least on that old computer.  Of course I'm also wondering why MATE froze on that old computer, so much so that it had to be turned off by a hard shut down.  :-\
Yup certain machines just are slow, I have two machines here a eeepc and a dell and they both have same processor one has 1 gig ram the other 2 gig, now the 2 gig rig flies and the dell is super duper slow...  I asked a while back for ways to speed it up, didn't get any ideas for help, so i left it go and closed the thread.... 
the eeepc flies with mint 17 cinnamon when i had cinnamon on the dell it was so slow it could not be used, i put peppermint 5 on the dell and tweaked everything i could and it is still slow, it's like the dell has something in the system that just does not perform well with any linux....    :(
Title: Re: Any version of Ubuntu 14.4.2+ That Uses YouTube with Firefox [SOLVED]
Post by: perknh on March 11, 2015, 01:59:00 pm
And then MATE was fast but the computer would not boot up by moving the mouse after it had been idle for awhile.  But Lubuntu is proving itself to be very slow.  Hopefully it's a cookie issue, but I believe that is just wishful thinking.

This old computer, by the way, is an HP.

Update:  5 days later, this may be the command that will remedy MATE's freezing problem, which isn't a problem per se of Ubuntu MATE, but apparently of Ubuntu 14.04 in general:

http://itsfoss.com/keyboard-mouse-freeze-suspend/ (http://itsfoss.com/keyboard-mouse-freeze-suspend/)

or

Code: [Select]
http://itsfoss.com/keyboard-mouse-freeze-suspend/