Peppermint OS

Support => Hardware => Topic started by: vynny001 on August 08, 2020, 08:29:19 pm

Title: ISSUE: PeppermintOS 10 Respin and NVidia 8800M GTS NVidia 340.108 (Solved)
Post by: vynny001 on August 08, 2020, 08:29:19 pm
After a long time of trying things I have found all over the internet about installing nVidia drivers on a Gateway P6860FX with the 8800M GTS, I finally stumbled across a site that had the answer. It seems that Ubuntu 18.04 does not install the correct headers for the nVidia 340.108 drivers which caused them not to install correctly.

Install the Correct Headers:
Code: [Select]
sudo apt install linux-image-4.15.0-112-generic linux-headers-4.15.0-112-generic
Code: [Select]
sudo reboot

Install Drivers:
Code: [Select]
sudo add-apt-repository ppa:graphics-drivers/ppa
Code: [Select]
sudo apt-get update
CTL+ALT F1 to get into terminal
Code: [Select]
sudo systemctl stop lightdm
Code: [Select]
ubuntu-drivers devices
Code: [Select]
sudo ubuntu-drivers autoinstall
Code: [Select]
sudo apt-get update
Code: [Select]
sudo nvidia-xconfig
Code: [Select]
sudo reboot

*NOTE: Your first reboot may be to big fonts and flickering. If so, just do a reboot.

To check your system after reboot:
Code: [Select]
sudo lshw -numeric -C display  or 
Code: [Select]
sudo lspci -vnn | grep VGA
Also, I noticed that if I use "Adapative" or "Auto" with the PowerMizer and it drops to the 275/602/550 settings, the display will go black and you have to reboot to get it back. I just set the PowerMizer to "Prefer Maximum Performance" to keep it at the 500/1598/1250 settings.

REF: (

PCNetSpec has a good method on having the PowerMizer set to "Prefer Maximum Performance" each time you start.
REF:,8461.msg86778.html#msg86778 (,8461.msg86778.html#msg86778)

Code: [Select]
System:    Host: P6860FX Kernel: 5.4.0-42-generic x86_64 bits: 64 gcc: 7.5.0
           Desktop: N/A Distro: Peppermint Ten
Machine:   Device: laptop System: Gateway product: P-6860FX v: 1234567 serial: N/A
           Mobo: Gateway model: P-6860FX v: 1234567 serial: N/A
           BIOS: Phoenix v: R01-A1P (94.29.00) date: 03/10/2008
Battery    BAT0: charge: 63.6 Wh 100.0% condition: 63.6/73.3 Wh (87%)
           model: SMP-SDI SAPSSEET status: Full
           hidpp__0: charge: 85% condition: NA/NA Wh
           model: Logitech M570 status: Discharging
CPU:       Dual core Intel Core2 Duo T9300 (-MCP-)
           arch: Penryn rev.6 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 9974
           clock speeds: max: 2501 MHz 1: 1697 MHz 2: 1982 MHz
Graphics:  Card: NVIDIA G92M [GeForce 8800M GTS] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.20.8 ) driver: nvidia
           Resolution: 1440x900@60.00hz
           OpenGL: renderer: GeForce 8800M GTS/PCIe/SSE2
           version: 3.3.0 NVIDIA 340.108 Direct Render: Yes
Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k5.4.0-42-generic
Network:   Card-1: Intel PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
           driver: iwl4965 v: in-tree: bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 port: 4000 bus-ID: 04:00.0
           IF: enp4s0 state: down mac: <filter>
Drives:    HDD Total Size: 878.2GB (6.7% used)
           ID-1: /dev/sdb model: ST750LX003 size: 750.2GB
           ID-2: /dev/sda model: SPCC_Solid_State size: 128.0GB
Partition: ID-1: / size: 39G used: 8.9G (25%) fs: ext4 dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 54.0C mobo: N/A gpu: 0.0:61C
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb bionic main restricted
           deb bionic-updates main restricted
           deb bionic universe
           deb bionic-updates universe
           deb bionic multiverse
           deb bionic-updates multiverse
           deb bionic-backports main restricted universe multiverse
           deb bionic-security main restricted
           deb bionic-security universe
           deb bionic-security multiverse
           Active apt sources in file: /etc/apt/sources.list.d/graphics-drivers-ubuntu-ppa-bionic.list
           deb bionic main
           Active apt sources in file: /etc/apt/sources.list.d/peppermint.list
           deb bionic main
           deb bionic main
Info:      Processes: 202 Uptime: 31 min Memory: 1217.2/3935.1MB
           Init: systemd runlevel: 5 Gcc sys: 7.5.0
           Client: Shell (bash 4.4.201) inxi: 2.3.56
Title: Re: ISSUE: PeppermintOS 10 Respin and NVidia 8800M GTS NVidia 340.108 (Solved)
Post by: straybit on August 09, 2020, 01:22:06 pm
Thanks, Vinny.

I thought this was the solution for my issue of the nouveau driver not waking up on my Compaq laptop.
Spoiler (click here to view / hide)
I got as far as
Code: [Select]
sudo ubuntu-drivers autoinstallwhen it told me that some packages could not be installed.  Sorry, had to hand type this from a photo of the screen.
Code: [Select]
The following packages have unmet dependencies:
 nvidia-304 : Depends: xorg-video-ahi=11 but it is not installable or
                       xorg-video-ahi=12 but it is not installable or
                       xorg-video-ahi=13 but it is not installable or
                       xorg-video-ahi=14 but it is not installable or
                       xorg-video-ahi=15 but it is not installable or
                       xorg-video-ahi=18 but it is not installable or
                       xorg-video-ahi=19 but it is not installable or
                       xorg-video-ahi=20 but it is not installable or
              Depends: xserver-xorg-core
E: Unable to correct problems: you have broken packages.
Earlier, when I had added the ppa:graphics-drivers/ppa, I got a message to the effect that 3 of the files wouldn't be available for 2 or 3 hours i the future.  I actually wound up running that command again after Ctrl-Alt-F1 when the times were a bit longer.  Then, later, I saw those 3 messages again but the times were even larger.  I'm sure it was on another command but I can't find it now.

I'm sure that it was something I did wrong.  Perhaps I should have waited 3+ hours and tried again?  (I had never run into a message say a package wouldn't be available until sometime in the future.)

Title: Re: ISSUE: PeppermintOS 10 Respin and NVidia 8800M GTS NVidia 340.108 (Solved)
Post by: vynny001 on August 09, 2020, 04:12:41 pm
Hi there Bruce. I too ran into the same thing you are when I was trying to test the 304 drivers. It seems that there was some changes made with Ubuntu 18.04 LTS which is what PeppermintOS 10 Respin is based off of. I found the following link where I think I was able to get the dependencies met to install, but my laptop was still having issues at the time. It could have been the headers for that driver too. Here is the information that I used to get those dependencies installed.

Code: [Select]
sudo apt-get install aptitude
sudo aptitude install <package-name>

REF: (