Author Topic: Matching date and time with Windows (solved, at least for now)  (Read 438 times)

Offline Bear

  • Jr. Member
  • **
  • Posts: 35
  • Karma: 17
  • Got a lot to learn
    • View Profile
  • Peppermint version(s): 10 Respin
My dual-boot Pep10/Win10 works fine except that the time is different, with Windows an hour behind Peppermint, which is currently correct. Leaving aside the contention that Windows will never catch up, what's the easiest way to make them both tell the right time please?
« Last Edit: July 01, 2020, 05:53:16 am by Bear »

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5898
  • Karma: 1160
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Matching date and time with Windows
« Reply #1 on: June 29, 2020, 12:38:48 pm »
My dual-boot Pep10/Win10 works fine except that the time is different [...] what's the easiest way to make them both tell the right time please?

This was an expensive lesson, for me...

After beating my head against the wall, trying to figure out this dual-boot time mystery - in an act of desperation - I replaced the mobo (in the machine I'm typing on). The new mobo did the same thing, e.g. not a mobo prob.   ;D

Turned out to be a tussle between Peppermint and winders, as to which OS got the privilege of adjusting the RTC in BIOS.  Before all this happened, I didn't know that an OS could get into BIOS and change the Realtime Clock.

Anyway, the workaround is to allow winders to be 'The Keeper of Father Time', and disable the RTC time adjusting function in Peppermint.

Here's a thread showing one how to do it:  https://is.gd/QFS3kp

Funny thing is... I ran into this exact same 'time problem' last week on my dual-boot Pep10/Win10 HP Compaq 8000 Elite desktop box.

The process described in the thread above still works...

Have fun!

Offline Bear

  • Jr. Member
  • **
  • Posts: 35
  • Karma: 17
  • Got a lot to learn
    • View Profile
  • Peppermint version(s): 10 Respin
Re: Matching date and time with Windows
« Reply #2 on: July 01, 2020, 05:51:07 am »
Thanks VinDSL. Between my original post and your reply I found the UbuntuTime article in the thread you cited. Running timedatectl set-local-rtc 1 from the command line yesterday seems to have done the job for me. My RTC is currently set to UTC plus 1 hour which is believable as I'm in the UK and we're in daylight saving time now. I'm now curious as to how Linux handles daylight saving time as UTC apparently doesn't.