Author Topic: Blank screen on wakeup (SOLVED)  (Read 643 times)

Offline straybit

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 8
  • New To PeppermintOS
    • View Profile
    • Middleton Post 39
  • Peppermint version(s): 10
Blank screen on wakeup (SOLVED)
« on: June 27, 2020, 02:46:24 pm »
I've several posts on this issue but couldn't find any thing recent/relevant.  inxi:
Spoiler (click here to view / hide)
[close]
I have the screen blank when I close the lid under power.  Nothing seems to wake it up and have to do a hard power off.  Same thing if I have it go to sleep via the start menu.
I ran nvidea-settings with the following message:
Spoiler (click here to view / hide)
[close]
Then I googled nvidea and downloaded NVIDIA-Linux-x86_64-304.137.run.  On checking it out, it is a shell script.  I set permissions to allow it to run in terminal and executed it.  After some checking, it said that x server was running and I needed exit it.  So in terminal, I typed 'init 2' which gave a black screen with a cursor.  Another Power off!
I also tried one of the alternate grub selections but still got the gui.
Tried logging in on the cli login, it showed what I had typed and went into the gui.

How do I exit x server?

Bruce
« Last Edit: September 01, 2020, 02:12:52 pm by straybit »

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2180
  • Karma: 457
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Blank screen on wakeup
« Reply #1 on: June 28, 2020, 01:37:11 am »
I don't know but
Quote
If you're installing on a system that is set up to use the Nouveau driver, then you should first disable it before attempting to install the NVIDIA driver.
https://download.nvidia.com/XFree86/Linux-x86_64/304.137/README/installdriver.html

Offline straybit

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 8
  • New To PeppermintOS
    • View Profile
    • Middleton Post 39
  • Peppermint version(s): 10
Re: Blank screen on wakeup
« Reply #2 on: June 28, 2020, 01:30:38 pm »
Thanks, Murraymint.  That contains a lot of reading.  And I do want to understand it before I under take the installation.

Unless another solution shows up.

Bruce

Offline josephd

  • Administrator
  • Member
  • *****
  • Posts: 737
  • Karma: 248
  • Peppermint OS Website Admin
    • View Profile
    • LinuxBookPro
  • Peppermint version(s): Peppermint 10
Re: Blank screen on wakeup
« Reply #3 on: June 30, 2020, 05:39:02 pm »
@straybit, does your laptop allow for turning off the GPU. If so does it still occur using Intel's graphics

Perhaps try switching to an alternative nvidia driver. I usually get 2-3 options when I check under my hardware settings.
Joseph Dickson | www.linuxbookpro.com | www.joseph-dickson.com | https://twitter.com/joe4ska - "I also enjoy Debian Stable, Pop!_OS, and Trisquel."

Offline straybit

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 8
  • New To PeppermintOS
    • View Profile
    • Middleton Post 39
  • Peppermint version(s): 10
Re: Blank screen on wakeup
« Reply #4 on: July 06, 2020, 09:40:58 am »
Thanks for your reply, Joseph.

Thinking (there I go - thoughting, again  ???) I had other problems, I wound up reinstalling P10 - no change!

I don't know where to look for turning off the GPU.  The problem arises when returning from Suspend, Sleep, or Switch off display.

Now that I spell Nvidia correctly, I see there are a lot of options in software manager - none installed - at least at the office.  (It has Intel graphics .  My home pc is the one giving me fits.)  What set me off on this tangent is
Code: [Select]
drivers: nouveau (unloaded: modesetting,fbdev,vesa)I thought that applied to nouveau, but I see the office also has "driver: modesetting unloaded: fbdev,vesa".

I'll look again when I get home this afternoon.

Bruce

Offline josephd

  • Administrator
  • Member
  • *****
  • Posts: 737
  • Karma: 248
  • Peppermint OS Website Admin
    • View Profile
    • LinuxBookPro
  • Peppermint version(s): Peppermint 10
Re: Blank screen on wakeup
« Reply #5 on: July 06, 2020, 08:22:40 pm »
Peppermint Settings Panel > Hardware > Additional Drivers
 "Software & Updates'" then flipping though the "Additional Drivers" options

With some lluck in a minute or two it will detect the drivers your system hardware needs :D

In my case these various NVIDIA drivers as well as Nouveau.

Once you activate a driver reboot, I believe it does some kernel integration and logging out may not be enough for it to work.

Side note. WIth my nvidia card the GRUB (boot screen) will end up 640x480 but the system and login screen will be the proper resolution.
« Last Edit: July 06, 2020, 08:30:38 pm by josephd »
Joseph Dickson | www.linuxbookpro.com | www.joseph-dickson.com | https://twitter.com/joe4ska - "I also enjoy Debian Stable, Pop!_OS, and Trisquel."

Offline straybit

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 8
  • New To PeppermintOS
    • View Profile
    • Middleton Post 39
  • Peppermint version(s): 10
Re: Blank screen on wakeup
« Reply #6 on: July 09, 2020, 03:14:40 pm »
Thanks, Joseph.

The only thing that came up was
Code: [Select]
Broadcom Limited: BCM4311 802.11b/g WLAN...
...
o Do not use the device
...
No proprietary drivers are in use.
Sorry - I had to hand type it.

Bruce

Offline straybit

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 8
  • New To PeppermintOS
    • View Profile
    • Middleton Post 39
  • Peppermint version(s): 10
Re: Blank screen on wakeup (SOLVED)
« Reply #7 on: September 01, 2020, 02:13:46 pm »
When I reinstalled P10 with more disk space, the issue was solved.
Bruce