Author Topic: Login Screen Resolution Not Correct  (Read 198 times)

Offline Fred

  • Member
  • ***
  • Posts: 110
  • Karma: 18
    • View Profile
  • Peppermint version(s): 8 & 10 Respins - 64 Bit
Login Screen Resolution Not Correct
« on: June 22, 2020, 01:46:13 pm »
After installing a new SSD on my old Dell Latitude 820 laptop, and doing a clean install of Peppermint 10 Respin... the screen resolution is not correct on my login screen. After I login, my screen resolution is ok.  But when I shutdown and reboot, the issue is still there of a small login screen with black space all around it.  Any ideas what I should try to correct this? Thanks...
Fred

Code: [Select]
fred@fred-Latitude-D820 ~ $ inxi -Fz
System:    Host: fred-Latitude-D820 Kernel: 5.3.0-59-generic x86_64 bits: 64
           Desktop: N/A Distro: Peppermint Ten
Machine:   Device: portable System: Dell product: Latitude D820 serial: N/A
           Mobo: Dell model: 0GF470 serial: N/A BIOS: Dell v: A10 date: 01/27/2010
Battery    BAT0: charge: 60.9 Wh 100.0% condition: 60.9/73.3 Wh (83%)
CPU:       Dual core Intel Core2 T5500 (-MCP-) cache: 2048 KB
           clock speeds: max: 1667 MHz 1: 1265 MHz 2: 1273 MHz
Graphics:  Card: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller
           Display Server: x11 (X.Org 1.20.8 )
           drivers: intel (unloaded: modesetting,fbdev,vesa)
           Resolution: 1280x800@60.00hz
           OpenGL: renderer: Mesa DRI Intel 945GM version: 1.4 Mesa 19.2.8
Audio:     Card Intel NM10/ICH7 Family High Def. Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k5.3.0-59-generic
Network:   Card-1: Broadcom and subsidiaries NetXtreme BCM5752 Gigabit Ethernet PCIE
           driver: tg3
           IF: enp9s0 state: down mac: <filter>
           Card-2: Intel PRO/Wireless 3945ABG [Golan] Network Connection
           driver: iwl3945
           IF: wlp12s0 state: up mac: <filter>
Drives:    HDD Total Size: 240.1GB (3.4% used)
           ID-1: /dev/sda model: KINGSTON_SA400S3 size: 240.1GB
Partition: ID-1: / size: 220G used: 7.7G (4%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 42.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 158 Uptime: 12 min Memory: 571.9/3235.4MB
           Client: Shell (bash) inxi: 2.3.56
 

Offline josephd

  • Administrator
  • Member
  • *****
  • Posts: 694
  • Karma: 242
  • Peppermint OS Website Admin
    • View Profile
    • LinuxBookPro
  • Peppermint version(s): Peppermint 10
Re: Login Screen Resolution Not Correct
« Reply #1 on: June 23, 2020, 12:57:26 am »
I was going to blame Nvidia or AMD but that's not the case.  :-\
Sorry, I'm stumped.
Joseph Dickson | www.linuxbookpro.com | www.joseph-dickson.com | https://twitter.com/joe4ska - "I also enjoy Debian Stable, Pop!_OS, and Trisquel."

Offline Fred

  • Member
  • ***
  • Posts: 110
  • Karma: 18
    • View Profile
  • Peppermint version(s): 8 & 10 Respins - 64 Bit
Re: Login Screen Resolution Not Correct
« Reply #2 on: June 23, 2020, 02:09:12 pm »
Thanks for taking a look Joseph...

Offline vynny001

  • Newly Subscribed
  • *
  • Posts: 10
  • Karma: 2
  • Very Novice to PeppermintOS 10 Respin
    • View Profile
    • Vitual World US
  • Peppermint version(s): 10 Respin
Re: Login Screen Resolution Not Correct
« Reply #3 on: June 26, 2020, 01:01:09 pm »
I too am working on this particular problem now of "setting the login screen resolution" to finalize the remedy of my original problem of "No Display".

https://forum.peppermintos.com/index.php/topic,9923.msg98975.html#msg98975

If I figure it out, I will be over here to let you know as soon as possible. :)

Until I get this figured out, I am just using AutoLogin.
Menu > System > Login Window
Users Tab and set the user for Automatic login
Reboot and I am operational.

Login Screen Resolution fix for above.
Get your mode. Since I wanted 1920x1080 mode, I typed in the following:
Code: [Select]
cvt 1920 1080
I got the output of
Code: [Select]
# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

I then added this mode to my system
Code: [Select]
xrandr --newmode 1920x1080_60.00  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode HDMI-A-0 1920x1080_60.00
Removed the Auto login and reboot. SUCCESS!
https://forum.peppermintos.com/index.php/topic,9564.0.html
https://forum.peppermintos.com/index.php/topic,8325.msg85369.html#msg85369

Thanks to alynur for finding this for me.
« Last Edit: June 26, 2020, 03:43:26 pm by vynny001 »

Offline Fred

  • Member
  • ***
  • Posts: 110
  • Karma: 18
    • View Profile
  • Peppermint version(s): 8 & 10 Respins - 64 Bit
Re: Login Screen Resolution Not Correct
« Reply #4 on: June 26, 2020, 04:26:18 pm »
Hi vynny001,
Glad you are getting some resolution (not to make a pun) to your issue!  While not solving my problem with the login screen resolution, I have adjusted my settings to auto login and this, of course, as you know, skips the login screen.  While this didn’t solve the issue, it did at least give me a work around if you will. As now my laptop boots up to the proper resolution without going through the login screen.  I would, however, prefer to have the login screen working with the proper resolution.
« Last Edit: June 26, 2020, 04:41:09 pm by Fred »