Author Topic: Compaq Presario CQ60 AR242X AR542X wireless  (Read 10919 times)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Compaq Presario CQ60 AR242X AR542X wireless
« Reply #15 on: September 13, 2014, 08:06:51 am »
OK with this setup, run:
Code: [Select]
sudo rfkill unblock allthen post the output from:
Code: [Select]
rfkill list alland let me know if wireless sprang to life ?

If it does work, reboot and let me know if it still works, or if you have to run:
Code: [Select]
sudo rfkill unblock allagain before wireless comes back to life

--
« Last Edit: September 13, 2014, 08:44:12 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline lswarte

  • Trusted User
  • Member
  • *****
  • Posts: 177
  • Karma: 201
  • Once a noob, always a noob.
    • View Profile
    • Facebook
  • Peppermint version(s): Peppermint 9
Re: Compaq Presario CQ60 AR242X AR542X wireless
« Reply #16 on: September 13, 2014, 11:29:21 am »
The output from
Code: [Select]
rfkill list all is:
Code: [Select]
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

The (right click) enable WiFi option in the LXDE panel switched on, but the left click says "WiFi networks disconnected".

Since there is no WiFi I assume rebooting is not necessary.

With kind regards,

Offline rjm65

  • Veteran
  • ****
  • Posts: 1029
  • Karma: 313
  • I have Peppermint Fresh Breath. :P
    • View Profile
  • Peppermint version(s): Win-98 /Win-7/ Peppermint 9
Re: Compaq Presario CQ60 AR242X AR542X wireless
« Reply #17 on: September 13, 2014, 11:33:14 am »
Are you sure there is not a switch, or a function key command to turn wireless on and off, it almost seems like it is switched off...   :)
Robert
Peppermint 9 User

Gateway Solo 9300 Pro
IBM T40

Offline lswarte

  • Trusted User
  • Member
  • *****
  • Posts: 177
  • Karma: 201
  • Once a noob, always a noob.
    • View Profile
    • Facebook
  • Peppermint version(s): Peppermint 9
Re: Compaq Presario CQ60 AR242X AR542X wireless
« Reply #18 on: September 13, 2014, 11:44:07 am »
There is a switch.

Upon switching on the laptop the indicator LED is orange (WiFi=off). As soon as Peppermint boots the indicator LED turns blue, indicating WiFi is switched on.

Peppermint, however, shows in the LXDE panel no WiFi network. There is also no way I physically turn WiFi "off" within Peppermint. No matter how long or how often I press the button, the indicator LED stays blue, and Peppermint doesn't show any WiFi networks.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Compaq Presario CQ60 AR242X AR542X wireless
« Reply #19 on: September 13, 2014, 11:48:59 am »
Try this....

Run:
Code: [Select]
sudo gedit /etc/modprobe.d/ath5k.confwhen a blank file opens, make it read
Code: [Select]
options ath5k no_hw_rfkill_switch=1SAVE the file and exit gedit.

REBOOT, and check wireless .. if still nothing, post the output from:
Code: [Select]
rfkill list alland
Code: [Select]
sudo iwlist scanning
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline lswarte

  • Trusted User
  • Member
  • *****
  • Posts: 177
  • Karma: 201
  • Once a noob, always a noob.
    • View Profile
    • Facebook
  • Peppermint version(s): Peppermint 9
Re: Compaq Presario CQ60 AR242X AR542X wireless
« Reply #20 on: September 13, 2014, 11:57:25 am »
Oops ... the trouble is .... no blank file opens.

The file contains one line:
Code: [Select]
options ath5k nohwcrypt=1
Should I add the line, or leave it as it is?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Compaq Presario CQ60 AR242X AR542X wireless
« Reply #21 on: September 13, 2014, 12:01:13 pm »
replace that line with the one above .. I don't think that's necessary and you must have added it previously
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline lswarte

  • Trusted User
  • Member
  • *****
  • Posts: 177
  • Karma: 201
  • Once a noob, always a noob.
    • View Profile
    • Facebook
  • Peppermint version(s): Peppermint 9
Re: Compaq Presario CQ60 AR242X AR542X wireless
« Reply #22 on: September 13, 2014, 12:09:43 pm »
The output from
Code: [Select]
rfkill list all is:
Code: [Select]
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

The output from
Code: [Select]
sudo iwlist scanning is:
Code: [Select]
wlan0     No scan results

lo        Interface doesn't support scanning.

eth1      Interface doesn't support scanning.

Thank you!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Compaq Presario CQ60 AR242X AR542X wireless
« Reply #23 on: September 13, 2014, 12:20:45 pm »
What's the output from:
Code: [Select]
nmcli nm status
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline lswarte

  • Trusted User
  • Member
  • *****
  • Posts: 177
  • Karma: 201
  • Once a noob, always a noob.
    • View Profile
    • Facebook
  • Peppermint version(s): Peppermint 9
Re: Compaq Presario CQ60 AR242X AR542X wireless
« Reply #24 on: September 13, 2014, 12:23:20 pm »
The output from
Code: [Select]
nmcli nm status is:
Code: [Select]
RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN     
running         connected       enabled         enabled    enabled         disabled 

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Compaq Presario CQ60 AR242X AR542X wireless
« Reply #25 on: September 13, 2014, 12:25:24 pm »
is it working ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline lswarte

  • Trusted User
  • Member
  • *****
  • Posts: 177
  • Karma: 201
  • Once a noob, always a noob.
    • View Profile
    • Facebook
  • Peppermint version(s): Peppermint 9
Re: Compaq Presario CQ60 AR242X AR542X wireless
« Reply #26 on: September 13, 2014, 12:42:24 pm »
No, unfortunately it is not working ....  >:(

Left click in the LXDE panel shows this:


Right click shows:

Offline lswarte

  • Trusted User
  • Member
  • *****
  • Posts: 177
  • Karma: 201
  • Once a noob, always a noob.
    • View Profile
    • Facebook
  • Peppermint version(s): Peppermint 9
Re: Compaq Presario CQ60 AR242X AR542X wireless
« Reply #27 on: September 13, 2014, 12:47:42 pm »
And this is the indicator LED burning blue (not very clear, but anyway ...)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Compaq Presario CQ60 AR242X AR542X wireless
« Reply #28 on: September 13, 2014, 12:54:13 pm »
OK, let's try removing the hp_wmi blacklist

Run:
Code: [Select]
sudo gedit /etc/modprobe.d/blacklist.confand remove the line

blacklist hp_wmi

that you added previously

SAVE the file and reboot.

Any change ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline lswarte

  • Trusted User
  • Member
  • *****
  • Posts: 177
  • Karma: 201
  • Once a noob, always a noob.
    • View Profile
    • Facebook
  • Peppermint version(s): Peppermint 9
Re: Compaq Presario CQ60 AR242X AR542X wireless
« Reply #29 on: September 13, 2014, 12:59:39 pm »
 :( Unfortunately no changes ...