Author Topic: Constant Monitor Weakup problem fix.  (Read 319 times)

Offline babis1

  • Newly Subscribed
  • *
  • Posts: 19
  • Karma: 14
  • Admirer and Enthusiast of Peppermint Linux OS.
    • View Profile
  • Peppermint version(s): 10
Constant Monitor Weakup problem fix.
« on: June 01, 2020, 05:03:50 pm »
Do you have a computer where your monitor turns on constantly instead of staying asleep?  My research found a solution.  You need to install a tool called vbetool.

sudo apt-get install vbetool

After the installation run the command to run vbetool as root every time so you don't have to use sudo and type in the password:

sudo chmod 4755 /usr/sbin/vbetool

Then you need to create a hotkey to turn your screen on and off. For Peppermint 10 goto: Menu -> Peppermint Settings Panel -> User -> Keyboard Settings -> Application Shortcuts -> Add.
For the first hotkey use command to turn off your monitor: vbetool dpms off
For the second hotkey use command to turn on your monitor: vbetool dpms on

vbetool and the method of making it execute as root as stated above works on any Linux distribution. For other distributions, however, you may need to use their way of installing vbetool, and find out how to set hotkeys to execute the command on demand.

I hope you find my research useful.
--Isaak.
« Last Edit: June 01, 2020, 05:27:58 pm by babis1 »
Don't forget to click applaud to encourage effort on this forum whenever you learn something new, or interesting.  It will inspire me to research new information and put up new tutorials.
-Isaak.

Offline babis1

  • Newly Subscribed
  • *
  • Posts: 19
  • Karma: 14
  • Admirer and Enthusiast of Peppermint Linux OS.
    • View Profile
  • Peppermint version(s): 10
Re: Constant Monitor Weakup problem fix.
« Reply #1 on: June 14, 2020, 04:00:33 pm »
One thing I would like to draw your attention to is: If you implement above hotkeys, make sure that the automatic lockscreen is disabled, because if it executes in the background while the screen is off the hotkey to turn your screen back on will be ignored because the lockscreen will prevent it from executing.

In Peppermint 10 you can disable screen locking via menu -> Peppermint Settings Panel -> Hardware -> Power Manager -> General -> When Laptop Lid is closed -> select either "Switch off display" or "Suspend" for both On Battery and Plugged in settings
Also in "Display" tab, turn off Display Power Management and put blank after setting to Never for both On Battery and Plugged in.
Also in Security tab, uncheck Lock screen when system is going to sleep

Hope this helps.
--Isaak
« Last Edit: June 15, 2020, 11:38:24 am by babis1 »
Don't forget to click applaud to encourage effort on this forum whenever you learn something new, or interesting.  It will inspire me to research new information and put up new tutorials.
-Isaak.

Offline babis1

  • Newly Subscribed
  • *
  • Posts: 19
  • Karma: 14
  • Admirer and Enthusiast of Peppermint Linux OS.
    • View Profile
  • Peppermint version(s): 10
Re: Constant Monitor Weakup problem fix.
« Reply #2 on: June 15, 2020, 03:57:09 am »
There is a way to implement lockscreen to the above method, it just needs to be executed after the hotkey for vbetool dpms on.

So the hotkey for screen on will look like this in Peppermint or any LXDE distribution :
sh -c "vbetool dpms on && lxlock"

for other distributions find out what lockscreen your distribution is using and replace the lxlock command with your lockscreen command.

Once again, please make sure that automatic lockscreen is disabled on your system, you don't want to get locked out with a blank screen, because your hotkey to turn on your monitor will be ignored if the lockscreen executes before you turn on your monitor with your set hotkey.

--Isaak
« Last Edit: June 15, 2020, 06:29:05 am by babis1 »
Don't forget to click applaud to encourage effort on this forum whenever you learn something new, or interesting.  It will inspire me to research new information and put up new tutorials.
-Isaak.