Author Topic: 100% CPU usage on reddit in the past days  (Read 193 times)

Offline zackxoxo

  • Newly Subscribed
  • *
  • Posts: 1
  • Karma: 0
  • New To PeppermintOS
    • View Profile
100% CPU usage on reddit in the past days
« on: May 19, 2020, 03:59:22 pm »
Reddit has become unusable. I use Vivaldi as a browser (chromium bnased). There's some Javascript running and fully exhausting my CPU. I have an i7-3930k which is NOT a slow CPU.

When I disable JavaScript, it runs fast and normal, but obcviously it's not a solution, because reddit doesn't run without JavaScript proerly.

I struggle to even type this post because of the severe slowdown. Words appear only 10 seconds after I type them.

This is horrible and i I am not sure what to do. Please help.

Offline rayzer

  • Trusted User
  • Member
  • *****
  • Posts: 385
  • Karma: 148
  • Graphics n Stuff
    • View Profile
  • Peppermint version(s): 10 Respin
Re: 100% CPU usage on reddit in the past days
« Reply #1 on: May 20, 2020, 06:33:41 am »
could be an issue with reddit or your browser,  at the moment im on reddit, facebook, discord and here on a old dual core cpu and 3gb of ram and the whole lot is only using 1.5gb of ram with the brave browser. 
have you tried loading addons such as ublock origin and privacy badger and see if it makes any difference or even install another browser to test.
if youre on the peppermint 10 respin you can use the web browser manager in the menu to do so
For wallpapers ive made you can download them here

Offline Slim.Fatz

  • Global Moderator
  • Veteran
  • *****
  • Posts: 2343
  • Karma: 616
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: 100% CPU usage on reddit in the past days
« Reply #2 on: May 20, 2020, 07:46:55 am »
Hi zackxoxo,

I agree with rayzer: try different browser.  ;)

Regards,

-- Slim
Respect science, respect nature, respect each other.

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome