Author Topic: Vulkan for AMD HD 7850 / R7 265/ R9 270 (1024) / R9 270 {{SOLVED}}}  (Read 232 times)

Offline vynny001

  • Newly Subscribed
  • *
  • Posts: 10
  • Karma: 2
  • Very Novice to PeppermintOS 10 Respin
    • View Profile
    • Vitual World US
  • Peppermint version(s): 10 Respin
Vulkan for AMD R9 270/HD 7850

Operating System: PeppermintOS 10 Respin

After installing Lutris, I get a message that Vulkan is not installed, so I start my misison to install Vulkan and DXVK for some gaming.

The first step was to install Vulkan. Since Vulkan supports both the AMD Radeon HD 7850 and the rebranded AMD Radeon R9 270, I did that by doing the following:

    sudo add-apt-repository ppa:oibaf/graphics-drivers
    sudo apt update
    sudo apt upgrade
    sudo apt install libvulkan1 mesa-vulkan-drivers vulkan-utils

After this, you try the following to check your vulkan installation:
    vulkaninfo

And I now I am getting the famous "VK_ERROR_INITIALIZATION_FAILED" error. Digging around and it seems that the HD 7850/R9 270 is supposed to have "Southern Islands" and maybe "Sea Islands" enabled for Vulkan to work. So I followed the instructions on creating an /etc/modprobe.d/amdgpu.conf and inserting the following:

            options amdgpu si_support=1
            options amdgpu cik_support=1

The forum posts for that talked about the R9 270X only needing the "si" enabled to get Vulkan to work. I ended up trying both enabled/disabled, one enabled/disabled, and the other enabled/disabled. It seems that PeppermintOS 10 Respin has nothing to do with the /etc/modprobe.d/amdgpu.conf file. The other suggestions were to add a line to /etc/default/grub which does not work with PeppermintOS 10 Respin, I attempted to insert that line into the /etc/grub.d/40_custom instead. That line they wanted is:

        GRUB_CMDLINE_LINUX_DEFAULT="radeon.cik_support=0 amdgpu.cik_support=1 radeon.si_support=0 amdgpu.si_support=1"

Next, I found a post stating that the issue with the R9 270 and Vulkan is that you have to use the "amdgpu" driver and not the "radeon" driver. You can check to see which one you are running by typing the following terminal command:

    lspci -k | grep -EA3 'VGA|3D|Display' 

When I type that I get the following:

    02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn PRO [Radeon HD 7850 / R7 265 / R9 270 1024SP]
   Subsystem: XFX Pine Group Inc. Radeon R9 270 1024SP
   Kernel driver in use: radeon
   Kernel modules: radeon, amdgpu

Their suggestion was to blacklist the "radeon" driver and it should automatically load the "amdgpu" driver. So I tried adding the "blacklist radeon" to the bottom of the /etc/modprobe.d/blacklist.conf by adding the following lines:
    # Blacklist "radeon" driver so that the "amdgpu" driver may be used for Vulkan
    blacklist radeon

Now my output is:

    02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn PRO [Radeon HD 7850 / R7 265 / R9 270 1024SP]
   Subsystem: XFX Pine Group Inc. Radeon R9 270 1024SP
   Kernel modules: radeon, amdgpu
    02:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon HD 7000 Series]

And of course, I still get the "VK_ERROR_INITIALIZATION_FAILED" error even after doing the sudo apt update/upgrade..

Too bad you cannot specify a search through specific forums/subforums in the PeppermintOS or better yet in the specific version of PeppermintOS forum/subforms. :)

Anyway, I am posting in hopes that someone with specific PeppermintOS 10 Respin knowledge that already come across fixing this particular thing.
« Last Edit: May 18, 2020, 10:44:05 am by vynny001 »

Offline spence

  • Administrator
  • Hero
  • *****
  • Posts: 2949
  • Karma: 334
  • peppermint user since 2010
    • View Profile
  • Peppermint version(s): PMVII, PMVIII, PMIX, PMX Respins
Re: Vulkan for AMD R9 270/HD 7850
« Reply #1 on: May 16, 2020, 10:23:53 pm »
Too bad you cannot specify a search through specific forums/subforums in the PeppermintOS or better yet in the specific version of PeppermintOS forum/subforms. :)

Actually... if one first navigates into the subforum in which they expect the answer to be found... then enters their search terms in the search box upper left of desktop, only results in that subforum  will turn up... 

 ;)

Not that the majority of forum users post their queries in the proper forums, nor  does our team always have time to move posts about...

There's also a  secret little known crunchbang search option ...  :o

click on Menu... in the run/search box type:
 !p + your search term... and it will search the entire public facing forum.peppermintos.com...

  :o

!p Vulcan turns up:

https://forum.peppermintos.com/index.php?action=search2&search=Vulcan
« Last Edit: May 16, 2020, 11:08:19 pm by spence »
spence
PeppermintOS 8,9 & 10 Respins currently installed  on:
'16 Antec Aria rebuild
PMX Respin on '18 Asus VivoBook


Do not despair, grasshopper...
    with patience all will be revealed...
       Through pain, enlightenment will come.

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 618
  • Karma: 146
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
Re: Vulkan for AMD R9 270/HD 7850
« Reply #2 on: May 17, 2020, 01:53:21 am »
Too bad you cannot specify a search through specific forums/subforums in the PeppermintOS or better yet in the specific version of PeppermintOS forum/subforms. :)

Actually... if one first navigates into the subforum in which they expect the answer to be found... then enters their search terms in the search box upper left of desktop, only results in that subforum  will turn up... 

 ;)

Not that the majority of forum users post their queries in the proper forums, nor  does our team always have time to move posts about...

There's also a  secret little known crunchbang search option ...  :o

click on Menu... in the run/search box type:
 !p + your search term... and it will search the entire public facing forum.peppermintos.com...

  :o

!p Vulcan turns up:

https://forum.peppermintos.com/index.php?action=search2&search=Vulcan

That's one of the most cleverest things PCNetSpec added to Peppermint and I only found out about it about a month or so ago. Full of magic this operating system.  ;D
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline spence

  • Administrator
  • Hero
  • *****
  • Posts: 2949
  • Karma: 334
  • peppermint user since 2010
    • View Profile
  • Peppermint version(s): PMVII, PMVIII, PMIX, PMX Respins
Re: Vulkan for AMD R9 270/HD 7850
« Reply #3 on: May 17, 2020, 06:47:08 am »
Too bad you cannot specify a search through specific forums/subforums in the PeppermintOS or better yet in the specific version of PeppermintOS forum/subforms. :)

Actually... if one first navigates into the subforum in which they expect the answer to be found... then enters their search terms in the search box upper left of desktop, only results in that subforum  will turn up... 

 ;)

Not that the majority of forum users post their queries in the proper forums, nor  does our team always have time to move posts about...

There's also a  secret little known crunchbang search option ...  :o

click on Menu... in the run/search box type:
 !p + your search term... and it will search the entire public facing forum.peppermintos.com...

  :o

!p Vulcan turns up:

https://forum.peppermintos.com/index.php?action=search2&search=Vulcan

That's one of the most cleverest things PCNetSpec added to Peppermint and I only found out about it about a month or so ago. Full of magic this operating system.  ;D

I forget when that easter egg.. appeared... I think it was a Christmas Season Respin surprise...
spence
PeppermintOS 8,9 & 10 Respins currently installed  on:
'16 Antec Aria rebuild
PMX Respin on '18 Asus VivoBook


Do not despair, grasshopper...
    with patience all will be revealed...
       Through pain, enlightenment will come.

Offline vynny001

  • Newly Subscribed
  • *
  • Posts: 10
  • Karma: 2
  • Very Novice to PeppermintOS 10 Respin
    • View Profile
    • Vitual World US
  • Peppermint version(s): 10 Respin
Re: Vulkan for AMD R9 270/HD 7850
« Reply #4 on: May 17, 2020, 09:59:27 am »
Thanks so much for the search "easter egg" information. I am definitely putting that to use.

As for the installation of Vulkan with the R9 270/HD 7850, I am still hoping someone can help me on this. With the newer file system tree of PeppermintOS 10 Respin (I am suspecting it is that way with all new Ubuntu distros), the old instructions do not work. How can we force the kernel to use the "amdgpu" instead of the "radeon" driver and also enable the "si" and the "csi" tech.

Offline vynny001

  • Newly Subscribed
  • *
  • Posts: 10
  • Karma: 2
  • Very Novice to PeppermintOS 10 Respin
    • View Profile
    • Vitual World US
  • Peppermint version(s): 10 Respin
Re: Vulkan for AMD R9 270/HD 7850
« Reply #5 on: May 18, 2020, 09:42:15 am »
Okay, for those who own the AMD R9 270 and below, the "radeon" driver does not work with Vulkan. It seems that you have to use the "amdgpu" to get it to work. For me, I have 6 older computers that I have the AMD HD 7850 / R7 265 / R9 270 (1024SP) in so it had me a little stumped. I now have it working but I probably did a little overkill to get it to work. I may have to do some more testing and narrow it down. I guess that kind of happens for the newbs. To be honest, I think my first attempt to edit grub actually had me in a different file as it was blank.

First thing I did was reinstall PeppermintOS 10 Respin in order to get the fresh start. Second was to install Vulkan with the line at the very bottom.

Code: [Select]
sudo apt install libvulkan1 mesa-vulkan-drivers vulkan-utils
sudo apt update
sudo apt upgrade

 I then edited grub. I did not edit the /etc/boot/grub but the /default.

Code: [Select]
sudo xed /etc/default/grub
This is the GRUB_ section that I now have.

Code: [Select]
GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash modprobe.blacklist=radeon radeon.cik_support=0 amdgpu.cik_support=1 radeon.si_support=0 amdgpu.si_support=1"
GRUB_CMDLINE_LINUX=""

I then updated grub with the following:

Code: [Select]
sudo update-grub2
sudo update-grub

Reboot and viola...

Code: [Select]
lspci -k | grep -EA3 'VGA|3D|Display'   now renders the following:
Quote
   02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn PRO [Radeon HD 7850 / R7 265 / R9 270 1024SP]
   Subsystem: XFX Pine Group Inc. Radeon R9 270 1024SP
   Kernel driver in use: amdgpu
   Kernel modules: radeon, amdgpu

and I can use without an error
Code: [Select]
vulkaninfo | less
If vulkaninfo is missing, make sure you run the following:
Code: [Select]
sudo apt install libvulkan1 mesa-vulkan-drivers vulkan-utils
sudo apt update
sudo apt upgrade

My reference for getting this to working was
Quote
https://askubuntu.com/questions/927601/i-think-im-using-radeon-instead-of-amdgpu-how-do-i-change
« Last Edit: May 18, 2020, 09:49:21 am by vynny001 »