Author Topic: Loud "BEEP" when connecting power to laptop.  (Read 440 times)

Offline richamc01

  • Newly Subscribed
  • *
  • Posts: 2
  • Karma: 0
  • New To PeppermintOS
    • View Profile
  • Peppermint version(s): 10
Loud "BEEP" when connecting power to laptop.
« on: May 01, 2020, 10:38:00 am »
I just installed Peppermint 10 onto an older laptop that I have. The machine is an Acer Aspire One from 2016. When it was new it came with Windows 7 installed. I upgraded the RAM awhile back to 4GB. None of this is relevant to my question, but I wanted to list the specs of the machine in case it would be helpful. I have searched and tried a few things that I found but I am still not successful in getting this resolved.

When I plug in the charger to the laptop, I get a very loud and annoying beep sound from the laptop speakers, not from an internal speaker. For the record, I do not remember if it did this with Windows installed. My first thought was to check in the BIOS for a setting to disable this. I checked and there is no setting to be found.

I did some searching and found this topic (https://forums.linuxmint.com/viewtopic.php?t=75825). Different OS, but Linux none the less. I little ways down in this article, the OP says he found a solution which was to install and run alsamixer and mute the "beep" volume. I ran alsamixer and I found the "beep". I muted it but I still get the sound when unplugging and plugging in the power cord. I ran alsamixer again and I found that the "beep" volume was unmuted once again.

No matter what I do, I cannot get the mute to save when changing it with alsamixer. I read a few posts about entering "alsactl store" in the terminal after making the change but when I do this, I get an error that says "alsactl: state_lock:125: file /var/lib/alsa/asound.state lock error: File exists".

When I use "sudo alsactl store" I get no error, but it still does not save.

I'm not sure what else to try. Any suggestions? TIA!

Offline Slim.Fatz

  • Global Moderator
  • Veteran
  • *****
  • Posts: 2301
  • Karma: 612
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: Loud "BEEP" when connecting power to laptop.
« Reply #1 on: May 01, 2020, 01:01:02 pm »
Hi richamc01,

Open a terminal and enter this:

Code: [Select]
sudo xed /var/lib/alsa/asound.statethen do a search for Beep. On my machine there are two entries: one is for 'Beep Playback Volume' and the other is for 'Beep Playback Switch'. You can change the values in these and save the results to test each change you make.

Regards,

-- Slim
Respect science, respect nature, respect each other.

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline richamc01

  • Newly Subscribed
  • *
  • Posts: 2
  • Karma: 0
  • New To PeppermintOS
    • View Profile
  • Peppermint version(s): 10
Re: Loud "BEEP" when connecting power to laptop.
« Reply #2 on: May 01, 2020, 01:14:46 pm »
Hi richamc01,

Open a terminal and enter this:

Code: [Select]
sudo xed /var/lib/alsa/asound.statethen do a search for Beep. On my machine there are two entries: one is for 'Beep Playback Volume' and the other is for 'Beep Playback Switch'. You can change the values in these and save the results to test each change you make.

Regards,

-- Slim

Thank you for this! I changed the value of "Beep Playback Volume" from 7 to 0, saved, and then rebooted. I still get a beep, but it is not nearly as loud. I changed the value of "Beep Playback Switch" from true to false, saved, and rebooted in an attempt to get rid of the beep altogether, but it doesn't seem to have a noticeable effect.

Offline Slim.Fatz

  • Global Moderator
  • Veteran
  • *****
  • Posts: 2301
  • Karma: 612
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: Loud "BEEP" when connecting power to laptop.
« Reply #3 on: May 01, 2020, 11:22:07 pm »
Hi richamc01,

Well at least it is not so loud now!  ;D I'm sorry to say that beyond those suggestions I don't have anything else to suggest.  :-\ I hope that you can live with the volume intensity that you now have achieved.

Regards,

-- Slim
Respect science, respect nature, respect each other.

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1231
  • Karma: 133
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Loud "BEEP" when connecting power to laptop.
« Reply #4 on: May 02, 2020, 07:49:03 am »
Hi richamc01, welcome to Peppermint. Read this tutorial explaining how to post terminal outputs
Then run this code in a terminal;
Code: [Select]
inxi -FzIt's best to copy and paste the code into the terminal instead if typing to avoid errors. This information will give us a better idea of what we are trying to fix equipment wise. Also, it is best to indicate the brand of the equipment in the post title. Your laptop may have a particularity to it that only owners of that brand/model laptop would be aware of.
Also I'm assuming the buzzing noise only occurs when the laptop is already booted up and the charger is then plugged in?
What was I thinking?

Offline alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1231
  • Karma: 133
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Loud "BEEP" when connecting power to laptop.
« Reply #5 on: May 02, 2020, 08:10:15 am »
I couldn't find the post but quite a while back I had problems saving settings in alsamixer which PCNetSpec helped me solve. These are the steps he gave me to solve my problem;

run
Code: [Select]
sudo xed ~/.config/autostart/alsarestore.desktop   install config. file;

      [Desktop Entry]
      Type=Application
      Terminal=false
      Name=alsarestore
      Exec=bash -c 'sleep 15 ; alsactl --file ~/.config/asound.state restore'

   save changes to alsamixer by running:

   
Code: [Select]
sudo alsactl --file ~/.config/asound.state store

As noted in the code, this was for a desktop so you might want to change that to laptop
What was I thinking?

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2164
  • Karma: 415
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Loud "BEEP" when connecting power to laptop.
« Reply #6 on: May 02, 2020, 10:36:18 am »

As noted in the code, this was for a desktop so you might want to change that to laptop

No... desktop as in the UI, not the device.

Offline alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1231
  • Karma: 133
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Loud "BEEP" when connecting power to laptop.
« Reply #7 on: May 02, 2020, 03:39:28 pm »

As noted in the code, this was for a desktop so you might want to change that to laptop

No... desktop as in the UI, not the device.


Thanks for the correction murraymint. If I knew something, I'ld be dangerous.
What was I thinking?