Choose style:

Author Topic: Problem with resolution (SOLVED)  (Read 129 times)

0 Members and 1 Guest are viewing this topic.

Offline alazgreg

  • Newly Subscribed
  • *
  • Posts: 1
  • Karma: 0
  • New To PeppermintOS
    • View Profile
  • Peppermint version(s): P10
Problem with resolution (SOLVED)
« on: March 30, 2020, 01:11:12 pm »
Hello to all Peppermint users ;D
Fresh install to a Dell OptiPlex-GX520,trying to set a custom resolution for external monitor, the higher was 1024x768.
My monitor can support 1360x768.
So following instuctions on this topic

https://forum.peppermintos.com/index.php/topic,8325.msg85526.html#msg85526

my inxi -Fz

Spoiler (click here to view / hide)
System:    Host: greg-OptiPlex-GX520 Kernel: 5.3.0-42-generic x86_64 bits: 64
           Console: tty 1 Distro: Peppermint Ten
Machine:   Device: desktop System: Dell product: OptiPlex GX520 serial: <filter>
           Mobo: Dell model: 0C8810 serial: <filter>
           BIOS: Dell v: A03 date: 08/05/2005
CPU:       Single core Intel Pentium 4 (-MT-) cache: 2048 KB
           clock speeds: max: 3191 MHz 1: 3191 MHz 2: 3191 MHz
Graphics:  Card: Intel 82945G/GZ Integrated Graphics Controller
           Display Server: X.Org 1.20.5
           drivers: intel (unloaded: modesetting,fbdev,vesa)
           Resolution: 1024x768@60.00hz
           OpenGL: renderer: Mesa DRI Intel 945G version: 1.4 Mesa 19.2.8
Audio:     Card Intel 82801G (ICH7 Family) AC'97 Audio Controller
           driver: snd_intel8x0
           Sound: Advanced Linux Sound Architecture v: k5.3.0-42-generic
Network:   Card-1: Broadcom and subsidiaries NetXtreme BCM5751 Gigabit Ethernet PCIE
           driver: tg3
           IF: enp2s0 state: down mac: <filter>
           Card-2: Ralink RT2870/RT3070 Wireless Adapter driver: rt2800usb
           IF: wlx784476a3fcc7 state: N/A mac: N/A
Drives:    HDD Total Size: 320.1GB (2.7% used)
           ID-1: /dev/sda model: Hitachi_HTS54323 size: 320.1GB
Partition: ID-1: / size: 293G used: 8.2G (3%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 172 Uptime: 36 min Memory: 1356.6/3485.3MB
[close]
No additional drivers available

My xrandr

Spoiler (click here to view / hide)
Screen 0: minimum 8 x 8, current 1024 x 768, maximum 32767 x 32767
VGA1 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00*
   800x600       60.32    56.25 
   848x480       60.00 
   640x480       59.94 
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

[close]

following the instructions of that topic open terminal and

Spoiler (click here to view / hide)
greg@greg-OptiPlex-GX520 ~ $ cvt 1360 768
# 1360x768 59.80 Hz (CVT) hsync: 47.72 kHz; pclk: 84.75 MHz
Modeline "1360x768_60.00"   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync
greg@greg-OptiPlex-GX520 ~ $ xrandr --newmode 1360x768_60.00 84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync
greg@greg-OptiPlex-GX520 ~ $ xrandr --addmode VGA1 1360x768_60.00
greg@greg-OptiPlex-GX520 ~ $ xrandr --output VGA1 --mode 1360x768_60.00
[close]

 ;D mission successful

But thus setting is not saved,after a reboot resolution was 1024x768.
How to save this??


Found it!!
In /home/you you should find a file called .profile.
Simply add the two lines for xrandr --newmode and xrandr --addmode that worked to the end of the file
It gets executed every time you start up. Note - if you have more resolutions that you want to add, simply repeat what you have done to get the modelines for the other resolutions and also add them as well.
Save,restart done!!
I found the solution here:https://forums.linuxmint.com/viewtopic.php?t=285998
 ;D 8)
« Last Edit: April 01, 2020, 03:20:13 am by alazgreg »

Offline Slim.Fatz

  • Global Moderator
  • Veteran
  • *****
  • Posts: 2175
  • Karma: 590
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: Problem with resolution
« Reply #1 on: March 30, 2020, 02:38:26 pm »
Hi alazgreg,

You need to start a new topic of your own. The original poster here obviously did not have this problem;)

Topic split by Administrator.
 
 Regards,

-- Slim
« Last Edit: March 31, 2020, 03:19:52 am by Slim.Fatz »
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline spence

  • Administrator
  • Hero
  • *****
  • Posts: 2618
  • Karma: 315
  • peppermint user since 2010
    • View Profile
  • Peppermint version(s): PMVIII, PMIX, PMX Respins
Re: Problem with resolution
« Reply #2 on: March 30, 2020, 02:59:08 pm »
Hello and welcome to our forum @alazgreg.

First, please remember not to ask for support underneath other forum members posts.  I have split the thread so you will be able to mark it (SOLVED), (RESOLVED) or (ABANDONED) as your particular case warrants.

When experiencing similar difficulties, it's best to provide a link back to the similar issue you are having like so:


https://forum.peppermintos.com/index.php/topic,8325.msg85369.html#msg85369

To help you further, please edit your OP to give us a bit more information of how this problem shows up for you. Also, so we know what kind of hardware we're triaging, please help us help you by providing the terminal output for:

Code: [Select]
inxi -Fz

 ;)
« Last Edit: March 30, 2020, 03:31:40 pm by spence, Reason: clarification edit »
spence
PeppermintOS 8,9 & 10 Respins currently installed  on:
'16 Antec Aria rebuild
PMX Respin on '18 Asus VivoBook


Do not despair, grasshopper...
    with patience all will be revealed...
       Through pain, enlightenment will come.