Choose style:

Author Topic: Problem upgrading VirtualBox v5 to v6.1 on Pep10 respin  (Read 60 times)

0 Members and 1 Guest are viewing this topic.

Offline Inkblotr

  • Newly Subscribed
  • *
  • Posts: 3
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Problem upgrading VirtualBox v5 to v6.1 on Pep10 respin
« on: March 17, 2020, 09:32:31 pm »
I'm running Peppermint 10 respin on a Dell Preciaion M6500.  It is a fresh install with no other software.  I installed VirtualBox from the Software Manager and found it to be version 5.  So I downloaded version 6.1 .deb package from Oracle and tried to upgrade/install.  It errors out and won't install.  I went back to Software Manager and removed the v5 installation.  Tried to install downloaded v6.1 again.  Again it errors out.  The error message is:

Error: Breaks existing package 'virutalbox' that conflict: 'virtualbox'.  But the '/media/michael/FAC2-F718/virtualbox-6.1_6.1.4-136177~Ubuntu~bionic_amd64.deb' provides it via: 'virtualbox'

On a different machine, running Ubuntu Budgie 18.04, Software store also installs v5 of VirtualBox.  However, the same downloaded v6.1 file will remove v5 and install the v6.1 version without error....

Can anyone think what might be causing the v.6.1 to not install? 

Thank  you in advance!
« Last Edit: March 17, 2020, 09:47:55 pm by Inkblotr »

Offline Inkblotr

  • Newly Subscribed
  • *
  • Posts: 3
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Problem upgrading VirtualBox v5 to v6.1 on Pep10 respin
« Reply #1 on: March 17, 2020, 09:59:01 pm »
As you might have guessed I was only using the GUI.  When I used a terminal to attempt an install of the v6.1 file, it worked.  There was a curious line during the install that might help a developer somewhere...

michael@mdk-M6500 ~/Downloads $ sudo dpkg -i virtualbox-6.1_6.1.4-136177~Ubuntu~bionic_amd64.deb
[sudo] password for michael:
Selecting previously unselected package virtualbox-6.1.
dpkg: considering removing virtualbox in favour of virtualbox-6.1 ...
dpkg: yes, will remove virtualbox in favour of virtualbox-6.1

My problem is solved.

Online spence

  • Administrator
  • Veteran
  • *****
  • Posts: 2270
  • Karma: 259
  • peppermint user since 2010
    • View Profile
    • My MeWe profile
  • Peppermint version(s): Peppermint 10
Re: Problem upgrading VirtualBox v5 to v6.1 on Pep10 respin
« Reply #2 on: March 18, 2020, 10:42:37 am »
G'morning, afternoon or evening as the case may be wherever you are @Inkblotr, and welcome to our friendly forums! Excellent bit of self sleuthing there. Now we ask that you kindly edit your OP (original post) subject line to append (SOLVED) at the end.

 ;)
« Last Edit: March 18, 2020, 11:20:02 am by spence »
spence
PeppermintOS 10 Respin currently installed  on:
'16 Antec Aria rebuild
 '18 Asus VivoBook


Do not despair, grasshopper...
    with patience all will be revealed...
       Through pain, enlightenment will come.