Author Topic: [SOLVED] Peppermint on Toshiba nb500 - no audio  (Read 682 times)

Offline chespa

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 1
  • New Forum User
    • View Profile
[SOLVED] Peppermint on Toshiba nb500 - no audio
« on: March 10, 2020, 10:31:48 am »
Hello to everybody,
I installed Peppermint on a Toshiba nb500-12w, but I have a problem with the audio, which doesn't work.
I found that by starting "alsamixer" from the terminal and then pressing F6 to select my sound card HD Intel, which is NOT the default card, the "Headphone" item is silent and with the volume at 0.
If I move on this item with the cursors and press "M" and then with the cursor "up" I turn up the volume I can hear the audio.
If I did not explain well I filmed the procedure, viewable in the link at the bottom of the post.
The problem is that after every boot I have to do the whole procedure again.
Is there any way to make sure that "Headphone" is not muted and the volume is 0 at startup?

https://vimeo.com/396748131
« Last Edit: March 17, 2020, 02:07:07 am by chespa »

Offline chespa

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 1
  • New Forum User
    • View Profile
Re: Peppermint on Toshiba nb500 - no audio
« Reply #1 on: March 12, 2020, 05:10:22 am »
up...?

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2180
  • Karma: 457
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Peppermint on Toshiba nb500 - no audio
« Reply #2 on: March 12, 2020, 06:43:43 am »
Yes, check how to save the ALSA state and reload it at boot.

Offline Slim.Fatz

  • Global Moderator
  • Veteran
  • *****
  • Posts: 2377
  • Karma: 624
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: Peppermint on Toshiba nb500 - no audio
« Reply #3 on: March 12, 2020, 08:13:40 am »
Hi chespa,

Make your settings in alsamixer to the way you wish to have them stored. Then (without closing alsamixer) open another terminal window and enter:

Code: [Select]
sudo alsactl store
enter your password as requested and the settings should get stored in the file

Code: [Select]
/etc/asound.state
This file should automatically load at each boot.  ;)   

 If this solves your issue, please do everyone a favor by going back to your initial message about the issue, and click on the button Modify and then add (SOLVED) to the end of the line Subject: Finally, save the result.

Regards,

-- Slim
Respect science, respect nature, respect each other.

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline chespa

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 1
  • New Forum User
    • View Profile
Re: Peppermint on Toshiba nb500 - no audio
« Reply #4 on: March 14, 2020, 05:12:21 am »
I've tried by "sudo alsactl store" but this solution doesn't work.

/etc/asound.state does not exist, but /var/lib/alsa/asound.state exists, so I've tried copy this file to /etc/ and reboot, but this doesn't work too.

Can I edit /etc/asound.state? If yes, how can I edit it? Which line must I edit?
« Last Edit: March 14, 2020, 06:51:11 am by chespa »

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2180
  • Karma: 457
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Peppermint on Toshiba nb500 - no audio
« Reply #5 on: March 14, 2020, 06:42:59 am »
The file is saved to /var/lib/alsa/asound.state

If you run sudo alsactl restore does your headphone volume go up?

Offline chespa

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 1
  • New Forum User
    • View Profile
Re: Peppermint on Toshiba nb500 - no audio
« Reply #6 on: March 14, 2020, 06:55:55 am »
The file is saved to /var/lib/alsa/asound.state

If you run sudo alsactl restore does your headphone volume go up?


nope

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2180
  • Karma: 457
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Peppermint on Toshiba nb500 - no audio
« Reply #7 on: March 14, 2020, 07:27:28 am »
How about something like this?

Code: [Select]
amixer set Headphone unmute && amixer set Headphone 100
If you can find the command to unmute it you can run that command at every login.
« Last Edit: March 14, 2020, 07:29:05 am by murraymint »

Offline chespa

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 1
  • New Forum User
    • View Profile
Re: Peppermint on Toshiba nb500 - no audio
« Reply #8 on: March 14, 2020, 08:02:27 am »
How about something like this?

Code: [Select]
amixer set Headphone unmute && amixer set Headphone 100
If you can find the command to unmute it you can run that command at every login.

Terminal answer "amixer: Unable to find simple control 'Headphone', 0

Offline chespa

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 1
  • New Forum User
    • View Profile
Re: Peppermint on Toshiba nb500 - no audio
« Reply #9 on: March 17, 2020, 02:06:06 am »
SOLVED!!!
1) open terminal and type
Code: [Select]
sudo alsamixer set your values and press ESC
2) type
Code: [Select]
sudo alsactl --file ~/.config/asound.state store3) type
Code: [Select]
sudo alsactl --file ~/.config/asound.state restore4) create the file
Code: [Select]
sudo nano ~/.config/autostart/alsarestore.desktopand compile it so:
Code: [Select]
[Desktop Entry]
Type=Application
Terminal=false
Name=alsarestore
Exec=bash -c 'sleep 15 ; alsactl --file ~/.config/asound.state restore'

5) delete /var/lib/alsa/asound.state by:
Code: [Select]
cd /var/lib/alsa
Code: [Select]
sudo rm asound.state
6) reload alsa
Code: [Select]
sudo alsactl restore