Author Topic: Login (SOLVED)  (Read 409 times)

Offline Peewee_1985

  • Jr. Member
  • **
  • Posts: 29
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Login (SOLVED)
« on: February 15, 2020, 05:14:55 am »
Hi there!

Hope you're all well and enjoying the weekend.

I just wanted to ask whether it's possible to ask for login and password after booting, even though I decided not to do so once installed the operating system.

Since I'm starting to take my laptop with me everywhere, I don't want people to access to my information in case of stealing or something.

Thanks a lot. This community is awesome!
« Last Edit: February 22, 2020, 04:47:04 am by Peewee_1985 »

Offline Howling Wolf

  • Newly Subscribed
  • *
  • Posts: 23
  • Karma: 6
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Login
« Reply #1 on: February 20, 2020, 01:03:49 pm »
Hi,
if I am right you set automatic login without password during installation. To revert this, edit this file:
Code: [Select]
sudo xed /etc/lightdm/lightdm.conf
and there:

Seat:*]
autologin-guest=false
autologin-user=
autologin-user-timeout=0
allow-guest=false

Pay attention to the second line: there you will find your own user name. Make it empty but don't delete the whole line. This way you will asked for password and any guest login will disabled.
Cheerz  :)
« Last Edit: February 20, 2020, 01:05:36 pm by Howling Wolf »

Offline Peewee_1985

  • Jr. Member
  • **
  • Posts: 29
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Login
« Reply #2 on: February 21, 2020, 12:00:18 am »
That's great!

Thanks a lot, Howling Wolf  ;)

Offline Peewee_1985

  • Jr. Member
  • **
  • Posts: 29
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Login
« Reply #3 on: February 21, 2020, 02:35:44 pm »
Hi,
if I am right you set automatic login without password during installation. To revert this, edit this file:
Code: [Select]
sudo xed /etc/lightdm/lightdm.conf
and there:

Seat:*]
autologin-guest=false
autologin-user=
autologin-user-timeout=0
allow-guest=false

Pay attention to the second line: there you will find your own user name. Make it empty but don't delete the whole line. This way you will asked for password and any guest login will disabled.
Cheerz  :)

Here I am again!!

I thought it will automatically work but the thing is that, although the login screen appears, there's no need to know the password... you press enter or any other key and you're in.

What's wrong??

Kind regards,

Offline Slim.Fatz

  • Global Moderator
  • Veteran
  • *****
  • Posts: 2314
  • Karma: 613
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: Login
« Reply #4 on: February 22, 2020, 12:32:30 am »
Hi Peewee_1985,


FYI my lightdm.conf file looks like this:


Code: [Select]
[Seat:*]
allow-guest=true


Nothing else is present in the file. However, I installed PeppermintOS to ask for the user name and password. I wonder if you changed your file to look like mine it would work in the way you wish?


Regards,


-- Slim
Respect science, respect nature, respect each other.

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline Peewee_1985

  • Jr. Member
  • **
  • Posts: 29
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Login
« Reply #5 on: February 22, 2020, 04:46:14 am »
Hi Peewee_1985,


FYI my lightdm.conf file looks like this:


Code: [Select]
[Seat:*]
allow-guest=true


Nothing else is present in the file. However, I installed PeppermintOS to ask for the user name and password. I wonder if you changed your file to look like mine it would work in the way you wish?


Regards,


-- Slim

Hi there!!

Thanks for your help, Slim.Fatz,

After following your advice and encountering the same issue I finally found the origin of the problem (though I needed the configuration that you both provided).

I just needed to select "ask for password when starting the session" (since I have it in spanish I don't know the exact translation you'll have) at the "users and groups" menu.


Again, thanks a lot for your help. I'm still amazed by the kindness of this "family".

Offline Slim.Fatz

  • Global Moderator
  • Veteran
  • *****
  • Posts: 2314
  • Karma: 613
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: Login (SOLVED)
« Reply #6 on: February 22, 2020, 06:29:59 am »
Hi Peewe_1985,

Very glad to hear that you had success solving your issue and providing the needed steps to solve it !! This will help others who might also have this issue. And thank you very much for marking this issue as SOLVED8)

Regards,

-- Slim
Respect science, respect nature, respect each other.

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome