Choose style:

Author Topic: Proper settings for X2GO client connection  (Read 132 times)

0 Members and 1 Guest are viewing this topic.

Offline cameron1963

  • Newly Subscribed
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Proper settings for X2GO client connection
« on: January 09, 2020, 03:14:42 pm »
Hi all - I am a new Peppermint 10 user, I installed it on an older Mac Mini and it is working great!  However, I have yet been able to get a good solid looking desktop when connecting to the Peppermint 10 system from a client machine running WIndows 10 and the X2GO client software.  I have tried various desktop choices like Mate, XFCEW, LXDE, etc, but non seem to be able to replicate the default Peppermint 10 desktop correctly.  Has anyone got a working setup with X2GO server on Peppermint 10 that provieds the same visual experience via remote desktop X2GO as when sitting on the machine?  I would greatly appreciate any help you can give me.  I'm a pretty esperienced Linux user and have set up X2GO on CentOS, Linux Mint, Ubuntu, and Debian systems, but I have hit a mental roadblock with Peppermint 10.

Thanks in advance for any help!!

Offline cameron1963

  • Newly Subscribed
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Proper settings for X2GO client connection
« Reply #1 on: February 16, 2020, 12:14:25 pm »
Anyone?

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2087
  • Karma: 373
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Proper settings for X2GO client connection
« Reply #2 on: February 16, 2020, 08:11:17 pm »
I've never used it but I've had good results using NoMachine.

Offline cameron1963

  • Newly Subscribed
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Proper settings for X2GO client connection
« Reply #3 on: February 18, 2020, 01:30:17 pm »
Yep, I've been using NoMachine with it and that works ok, but my issue with NoMachine is a problem with resolution.  The machine I am connecting to is headless, and so NoMachine is giving me a connection that is only 1024x768.  Other systems I have which are headless and running Linux Mint with X2Go I can specify the resolution to something higher, like 1920x1080 so the visual experience is better for me.   At least NoMachine does work so I can use it, I just wish I could milk it for higher resolutions that are clear and crisp.

Thanks though for your answer, I'm glad someone is reading this post!

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2087
  • Karma: 373
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Proper settings for X2GO client connection
« Reply #4 on: February 18, 2020, 02:31:30 pm »
I've tried using it with a headless machine too and had problems. Check out the solution proposed in the final post here: https://forums.nomachine.com/topic/resizing-of-a-headless-session

Quote
You may try to switch off your X server and let NoMachine create the virtual display for you. Switch to runlevel 3 or stop lightdm, and create a connection to that desktop. Visit this link for more information about the configuration:

https://www.nomachine.com/FR10L02842

Offline cameron1963

  • Newly Subscribed
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Proper settings for X2GO client connection
« Reply #5 on: February 18, 2020, 03:10:54 pm »
Ok, I might give this a try and see if it works better.  Thanks!