Author Topic: (Solved) Apt installs/updates failing (smfpd, grub-common and $all error)  (Read 234 times)

Offline Clownrazer

  • Newly Subscribed
  • *
  • Posts: 11
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
I was trying to install Haguichi (gui for Hamachi VPN) and ran into an loop error -- I'm unsure if this install broke things, or if there was an issue before and I just nticed it here.  I did this same thing last night on a similar laptop at home and it worked with no issues.  Frankly I've been thinking of installing Pep 10 on this one anyway, so if the sleuthing is going to be too much of a PITA, then I'll just slick it and start fresh.

Basic install instructions here: https://www.haguichi.net/download/

System info:
Pep 8
Code: [Select]
System:    Host: Lenovo-G570 Kernel: 4.15.0-76-generic x86_64 (64 bit)
           Desktop: N/A Distro: Peppermint Eight
Machine:   System: LENOVO product: 4334 v: Lenovo G570
           Mobo: LENOVO model: N/A
           Bios: LENOVO v: 40CN28WW(V2.14) date: 10/07/2011
CPU:       Dual core Intel Core i5-2430M (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 3000 MHz 1: 980 MHz 2: 1081 MHz 3: 1150 MHz
           4: 915 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           Display Server: X.org 1.19.6 drivers: (unloaded: fbdev,vesa)
           tty size: 82x24 Advanced Data: N/A for root
Audio:     Card Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-76-generic
Network:   Card-1: Qualcomm Atheros AR8152 v2.0 Fast Ethernet driver: atl1c
           IF: enp1s0 state: down mac: <filter>
           Card-2: Broadcom and subsidiaries BCM4313 802.11bgn Wireless Network Adapter
           driver: bcma-pci-bridge
           IF: wlp2s0b1 state: up mac: <filter>
Drives:    HDD Total Size: 275.1GB (25.0% used)
           ID-1: /dev/sda model: Crucial_CT275MX3 size: 275.1GB
Partition: ID-1: / size: 19G used: 6.4G (37%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 230G used: 55G (25%) fs: ext4 dev: /dev/sda5
           ID-3: swap-1 size: 4.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 41.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 214 Uptime: 20 min Memory: 2396.6/3887.9MB
           Client: Shell (sudo) inxi: 2.2.35

Error of two apt commands (when this first started there were mentions of Plymouth issues as well, but after a restart it seems upset with Grub):
Code: [Select]
sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 24 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up util-linux (2.27.1-6ubuntu3.10) ...
insserv: warning: script 'K01smfpd' missing LSB tags and overrides
insserv: warning: script 'smfpd' missing LSB tags and overrides
insserv: There is a loop between service smfpd and grub-common if started
insserv:  loop involving service grub-common at depth 2
insserv:  loop involving service smfpd at depth 1
insserv:  loop involving service rsyslog at depth 1
insserv: Starting smfpd depends on grub-common and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on grub-common and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on grub-common and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on grub-common and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package util-linux (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up samba (2:4.3.11+dfsg-0ubuntu0.16.04.25) ...
insserv: warning: script 'K01smfpd' missing LSB tags and overrides
insserv: warning: script 'smfpd' missing LSB tags and overrides
insserv: There is a loop between service smfpd and grub-common if started
insserv:  loop involving service grub-common at depth 2
insserv:  loop involving service smfpd at depth 1
insserv:  loop involving service rsyslog at depth 1
insserv: Starting smfpd depends on grub-common and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on grub-common and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on grub-common and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on grub-common and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package samba (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin (2.23-0ubuntu11) ...
Errors were encountered while processing:
 util-linux
 samba
E: Sub-process /usr/bin/dpkg returned an error code (1)
andy@Lenovo-G570 ~ $ sudo apt install -y haguichi
Reading package lists... Done
Building dependency tree       
Reading state information... Done
haguichi is already the newest version (1.4.2-0~ubuntu16.04.1).
0 upgraded, 0 newly installed, 0 to remove and 24 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up util-linux (2.27.1-6ubuntu3.10) ...
insserv: warning: script 'K01smfpd' missing LSB tags and overrides
insserv: warning: script 'smfpd' missing LSB tags and overrides
insserv: There is a loop between service smfpd and grub-common if started
insserv:  loop involving service grub-common at depth 2
insserv:  loop involving service smfpd at depth 1
insserv:  loop involving service rsyslog at depth 1
insserv: Starting smfpd depends on grub-common and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on grub-common and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on grub-common and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on grub-common and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package util-linux (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up samba (2:4.3.11+dfsg-0ubuntu0.16.04.25) ...
insserv: warning: script 'K01smfpd' missing LSB tags and overrides
insserv: warning: script 'smfpd' missing LSB tags and overrides
insserv: There is a loop between service smfpd and grub-common if started
insserv:  loop involving service grub-common at depth 2
insserv:  loop involving service smfpd at depth 1
insserv:  loop involving service rsyslog at depth 1
insserv: Starting smfpd depends on grub-common and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on grub-common and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on grub-common and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on grub-common and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package samba (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin (2.23-0ubuntu11) ...
Errors were encountered while processing:
 util-linux
 samba
E: Sub-process /usr/bin/dpkg returned an error code (1)

Thanks for looking!
« Last Edit: February 11, 2020, 07:06:01 pm by Clownrazer »

Offline Clownrazer

  • Newly Subscribed
  • *
  • Posts: 11
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: (Solved) Apt installs/updates failing (smfpd, grub-common and $all error)
« Reply #1 on: February 11, 2020, 07:07:57 pm »
SMFPD is a samsung printer driver that did work to get a Samsung laser printer functioning, but apparently it's pretty buggy.   Didn't bother removing from pep8, just slicked and installed 10.  All is good and I'll just not hook that printer up directly again.