Choose style:

Author Topic: Dual Display Reverts to Mirrored Display Mode When monitor turned off and on.  (Read 381 times)

0 Members and 1 Guest are viewing this topic.

Offline alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1149
  • Karma: 83
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Hi clatterfordslim, I already tried it and the reason that the method you described
does not work for me is that the file is only read when logging in .I never log off when I turn off my
monitors so when I turn them off I am used to just working without having to log in again.
XFCE monitors when a new display is connected and defaults to configuring the dual monitor layout to
mirrored mode by default which I do not want. The resolutions remain the same but the
dual monitor layout changes.

you will have to log off and then back in for these type of changes to take affect. In fact several repairs for different problems will require a reboot to take affect.
What was I thinking?

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 526
  • Karma: 94
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
Hi clatterfordslim, I already tried it and the reason that the method you described
does not work for me is that the file is only read when logging in .I never log off when I turn off my
monitors so when I turn them off I am used to just working without having to log in again.
XFCE monitors when a new display is connected and defaults to configuring the dual monitor layout to
mirrored mode by default which I do not want. The resolutions remain the same but the
dual monitor layout changes.

you will have to log off and then back in for these type of changes to take affect. In fact several repairs for different problems will require a reboot to take affect.

That's what I've been saying, even in the tutorial it states you logout or reboot to take affect.  :D
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline bobert

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
I turned off my monitors for an hour to test this and it comes back as is, without going back to mirror mode. I have Peppermint logo to the right of me and my main desktop to the left. I don't log out of the computer it's on just monitors switched off. What you have to remember is Peppermint is not just XFCE it is Lubuntu too LXDE and the tutorial with the xsession.sh file I done is for LXDE which still at it's heart Peppermint is.

I don't know what to tell you man, it defaults to mirrored mode for me. I am running 2 displays off a nvidia gtx 670. My main monitor is an acer x34 predator at 3440x1440 plugged in to the hdmi-0 port and my secondary monitor is a Viewsonic VX3209-2k monitor
running at 2560x1440 plugged in to the DP-1 (display port) of the gtx 670.

After much testing, I have determined that if I check the radio box for "Configure new displays when connected" in the display settings when I turn my secondary monitor off and turn it back on, a dialog box will pop up
prompting me to select between four different layouts, namely "Acer Technologies 34", "Mirror Displays", "Extend  Right" or "Viewsonic Corporation 32" and the mode selected by default is "Mirror Displays" and if I don't select one
before the prompt times out. it will default to  the selected Mode which is Mirror Displays.




Now if I don't select  "Configure new displays when connected" in the display settings, when I turn off then turn off my
 secondary monitor, no prompt appears and my screen layout is automatically switched to mirrored mode. Interestingly, this only happens if I turn off my secondary monitor and turn it back on. It does not happen it I do the same to my primary monitor.


I do not want to log out and log back in when I turn off my monitors so I have decided to just live with having to force my preferred screenlayout
automatically. I have been testing a script to detect a new connected display but have still have to work out timing it so that it does not precede
whatever xfce-display-settings does to revert the layout. The ideal solution would be for there to be a way to make the OS or xfce stop taking action whenever
a new display is detected because I have never had any issue with resolution settings surviving a reboot.


Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5597
  • Karma: 1012
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Not exactly the same situation (mirrored vs multi-displays).

Don't know if it will help, but here's how I setup multi-displays: https://is.gd/IjA3GX

It helped Zeb.

Read between the lines, maybe?!

« Last Edit: February 01, 2020, 12:00:15 am by VinDSL, Reason: Addendum »

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 526
  • Karma: 94
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
The problem is you need to reboot to initiate the screen configurations, then you can turn off your monitors after you have logged back in for that one and only time and keep your computer on forever but just switch off your monitors when you're not using your computer, like you do anyway. I cannot seem to get through to you that you need to reboot once, to initiate the changes then you can turn off your monitors, with the peace of mind of knowing that when you turn on your monitors it will be setup the same as when you left it. I take it you have followed my tutorial?  :D Why are you using the display settings when Arandr is all you need. I have not touched Display settings and it's working fine for me. I too am using Nvidia.
« Last Edit: February 01, 2020, 02:40:36 am by clatterfordslim »
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 526
  • Karma: 94
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
If you followed my tutorial go into
Code: [Select]
.xsessionrc folder and double click xsession.sh file
As you don't want to reboot
Code: [Select]
Left Click Run
As illustrated in picture. It'll still be there after you've switched your monitors off and on again.
Here is mine with both monitors.


I'm going to setup another monitor and see what I get out of three with a tinkered xsession.sh file out of Arandr.
« Last Edit: February 01, 2020, 05:55:48 am by clatterfordslim »
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 526
  • Karma: 94
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
Here we are working in Arandr all three screens all set at 1080.
This is Arandr Gui. The DVI is a HDMI converter on it, so it makes my graphic card think it is HDMI.

This is where I saved the xsession.sh files.

Here is all three screens


Now going to change resolutions on the extra two screens and save the file once more in .xsessionrc folder.






« Last Edit: February 01, 2020, 07:05:32 am by clatterfordslim »
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 526
  • Karma: 94
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
The next trial will be to switch monitors off for an hour, so will be back with a video.  :D
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 526
  • Karma: 94
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
OK as promised taken me ages to get it rendered uploaded and wot-not. Full tutorial getting screens going in Peppermint. Plus I turn off monitors for over fifty minutes still leave computer on and all three monitors are set to different resolutions. I also show that you don't have to reboot to get your screen configurations going.
« Last Edit: February 01, 2020, 01:34:28 pm by clatterfordslim »
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline bobert

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
The problem is you need to reboot to initiate the screen configurations, then you can turn off your monitors after you have logged back in for that one and only time and keep your computer on forever but just switch off your monitors when you're not using your computer, like you do anyway. I cannot seem to get through to you that you need to reboot once, to initiate the changes then you can turn off your monitors, with the peace of mind of knowing that when you turn on your monitors it will be setup the same as when you left it. I take it you have followed my tutorial?  :D Why are you using the display settings when Arandr is all you need. I have not touched Display settings and it's working fine for me. I too am using Nvidia.

Hi clatterfordslim, I have rebooted after every change I made and xfce-display-settings still resets my screen layout to mirrored mode after turning my secondary display off and on. If you can point me to the setting/config that disables xfce-display-settings
automatically everytime it detects a new display connection, that'd be cool. :)

Offline bobert

  • Newly Subscribed
  • *
  • Posts: 7
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
I have managed to solve my problem by removing the xfsettingsd daemon from the list of programs that
auto launch when logging in to a desktop session. It turns out that this daemon was listening for the
RRScreenChangeNotify event from xrandr and checking if there was a change in the
number of detected displays then calling a function to apply a default display profile if a preferred profile
was not detected.

Offline alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1149
  • Karma: 83
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Hi bobert, glad you found a solution. We always think that what works for one should work for everyone or if you're having a problem with something, everybody should be suffering from the same problem if it's software based. That doesn't always happen. Sometimes it takes a reinstall to get things to work correctly. That said, once your system is working to your liking, take a snapshot of it with Timeshift or Resync or whatever, so you can restore it should something happen to screw it up. Also, it would have been easier for someone to come up with a different solution if you would have mentioned that you tried what was recommended and it didn't work after rebooting. We were all thinking you hadn't rebooted. Just a little advice for the next problem you need help with.
What was I thinking?

Offline deefster

  • Newly Subscribed
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10
I have managed to solve my problem by removing the xfsettingsd daemon from the list of programs that
auto launch when logging in to a desktop session. It turns out that this daemon was listening for the
RRScreenChangeNotify event from xrandr and checking if there was a change in the
number of detected displays then calling a function to apply a default display profile if a preferred profile
was not detected.
Just wanted to say this led me to the answer, thanks.  I couldn't disable it in startup, though.  Doing so fixed the mirrored display issue, but login was loading with the wrong resolution. What I did instead was to keep xfsettingsd in startup, but added another script to kill it shortly after login.