Author Topic: SOLVED - PulseAudio No Sound in Multi User mode  (Read 556 times)

Offline zopeck

  • Newly Subscribed
  • *
  • Posts: 2
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint OS 7
SOLVED - PulseAudio No Sound in Multi User mode
« on: February 04, 2020, 03:18:24 pm »
If I log in with a user and start some sound, say, mocp or anything, the sound works fine, but If, and only if I leave the sound working and switch users, when I open the Pulse Audio properties, in the Configuration tab it says that there is No audio card.

I also realized that if I left the audio working, and try and switch users, the audio keeps working as if I did nothing. I log in as a different user and still hear the sound from the former logged in user.

After googling a while, I found this article:

Where it says that if the user in question is member of the "Audio" group, it will present the said problem with the audio.

The problem is solved if as root, unchecking all users from the "Audio" group.

From then on, you have to close session, open again, start some audio, and when you switch users, you realize that the audio stops immediately after clicking the "switch user" button in the whisker menu.

You log in as a different user, and you can start using the audio normally.

Hope this helps someone. Cheers.