Choose style:

Author Topic: [SOLVED] btrfs installation  (Read 4120 times)

0 Members and 1 Guest are viewing this topic.

Offline hofy

  • Jr. Member
  • **
  • Posts: 86
  • Karma: 6
    • View Profile
  • Peppermint version(s): 8, 10
[SOLVED] btrfs installation
« on: August 31, 2014, 04:01:23 am »
Hi,

I've searched for the solution in forums, but only found advice for folks who don't actually use btrfs.

I've chosen to use the btrfs with my hdd installation of peppermint 5. I have a question about the startup line "scanning for btrfs ..."

1. it seems to slow down boot process. but does it really?
2. is there a way to stop the scan? Is it wise? Note I AM using btrfs on peppermint 5 partition. have three other partitions on the same disk: swap, ntfs and ext4.
3. is there a way to at least black out the notification?

thanks!
« Last Edit: September 08, 2014, 03:32:58 pm by hofy »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25725
  • Karma: 2822
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: btrfs installation
« Reply #1 on: September 02, 2014, 06:42:05 am »
Good question(s), and ones I've been wondering about myself .. I'm planning on trying btrfs on my next install (wanna check out snapshots), so please don't take the following as gospel, but here's how I understand it....

1) yes it does, as it's scanning for volumes that span multiple devices.

2) I don't know for sure if it could be disabled (it may be that the kernel module doesn't get loaded if the scan comes up empty, so you may need to modprobe the module from GRUB) .. I suppose you could try renaming the "btrfs" executable and see what happens .. but be sure to have a LiveCD that can read/write to btrfs handy so you can name it back if it won't boot.
(the kernel module will still be present, but may not be loaded)

3) So far I haven't found a way to "quieten" that message.
« Last Edit: September 02, 2014, 06:51:33 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline hofy

  • Jr. Member
  • **
  • Posts: 86
  • Karma: 6
    • View Profile
  • Peppermint version(s): 8, 10
Re: btrfs installation
« Reply #2 on: September 04, 2014, 02:36:18 pm »
renamed the btrfs executable in /sbin , no effect. boots fine.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25725
  • Karma: 2822
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: btrfs installation
« Reply #3 on: September 04, 2014, 02:52:41 pm »
and no more "scanning for btrfs..." message ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline hofy

  • Jr. Member
  • **
  • Posts: 86
  • Karma: 6
    • View Profile
  • Peppermint version(s): 8, 10
Re: btrfs installation
« Reply #4 on: September 05, 2014, 08:48:39 am »
no, it had no perceivable effect on the system.  everything remained the same. I renamed the /sbin/btrfs-find-root file as well, and still nothing changed.

there's a bunch of files starting with btrfs-... in /sbin, I can try renaming them all...

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25725
  • Karma: 2822
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: btrfs installation
« Reply #5 on: September 05, 2014, 11:35:41 am »
As I understand it...

With a renamed btrfs you may still get the "Scanning" message, but it will (or should) be unable to actually run the scan.

After looking through what's contained in the "btrfs-tools" package, I think the scan is being run from:
/usr/share/initramfs-tools/scripts/local-premount/btrfs
with the line
/sbin/btrfs device scan 2> /dev/null

so I searched google for the search term:
disable message scanning for btrfs "/usr/share/initramfs-tools/scripts/local-premount/btrfs"
and came up with this discussion (pain to follow as it's in xml):
http://logs.tvrrug.org.uk/logs/%23btrfs/2013-04-03.xml
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline hofy

  • Jr. Member
  • **
  • Posts: 86
  • Karma: 6
    • View Profile
  • Peppermint version(s): 8, 10
Re: btrfs installation
« Reply #6 on: September 05, 2014, 12:33:14 pm »
One before last in the xml discussion is a line that says

slow boot unrelated to btrfs scan.

just because it shows on the screen for a good couple seconds might not necessarily mean that it's running all this time, ey?
how do I enable full verbose boot so I can see what's loadin and where it hangs? instead of the splash screen with the red progress bar.
thanks :)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25725
  • Karma: 2822
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: btrfs installation
« Reply #7 on: September 05, 2014, 01:08:45 pm »
Remove:-
quiet splash
(and possibly the $vt_handoff=7 parameter)
from the kernel boot line.

If you want even more verbose output, replace:
quiet splash
with:-
--verbose nosplash debug
that should give you ALL output right up until X kicks in (expect it to be a blur until it hangs though ;) )

You can either do this manually at the GRUB screen, or permanently by editing /etc/default/grub and running update-grub .. as described here:
http://www.matrix44.net/blog/?p=1459

let me know if you need help with that.
« Last Edit: September 05, 2014, 01:14:45 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline hofy

  • Jr. Member
  • **
  • Posts: 86
  • Karma: 6
    • View Profile
  • Peppermint version(s): 8, 10
Re: btrfs installation
« Reply #8 on: September 07, 2014, 11:23:52 am »
yup, too fast to follow. Is there a way to log all the startup messages to study after boot?
or some other handy trick ?
thanks!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25725
  • Karma: 2822
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: btrfs installation
« Reply #9 on: September 07, 2014, 11:39:38 am »
Does the --verbose kernel boot parameter not make the boot.log entries verbose ?

boot.log is located at:
/var/log/boot.log

but I think it only records the last boot .. so you'll need to reboot with the previously mentioned parameters, then check the boot.log



[EDIT]

Adding the kernel boot parameter ignore_loglevel should cause dmesg to be unable to lower the loglevel .. giving more output in dmesg
/var/log/dmesg
I wouldn't add that as a permanent boot parameter though

source:
https://wiki.archlinux.org/index.php/Boot_debugging
« Last Edit: September 07, 2014, 11:47:07 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline hofy

  • Jr. Member
  • **
  • Posts: 86
  • Karma: 6
    • View Profile
  • Peppermint version(s): 8, 10
Re: btrfs installation
« Reply #10 on: September 08, 2014, 03:32:28 pm »
thanks for the advice!

I used the --verbose nosplash debug option and did not notice any significant delays. Apparently, btrfs SEEMS to cause a delayed boot, but it isn't really the case. It is just unfortunate  that it is the only message visible during quiet boot.

Marking thread solved.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25725
  • Karma: 2822
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: [SOLVED] btrfs installation
« Reply #11 on: September 08, 2014, 03:37:34 pm »
Cheers :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec