Author Topic: Lenovo ThinkPad X140e ... only beef ... slow shutdown  (Read 532 times)

Offline Minux1

  • Jr. Member
  • **
  • Posts: 35
  • Karma: 5
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Lenovo ThinkPad X140e ... only beef ... slow shutdown
« on: December 28, 2019, 01:12:25 pm »
Actually arrive at Peppermint Linux by default as Linux Mint v19.3 "Tricia" would not install a WIFI driver for my Lenovo ThinkPad X140e.
No WIFI pretty well means "That's all she wrote" and time to move on.
Besides my eyeballs were turning green and I needed a change.
No issue with WIFI driver with Peppermint and everything works.
My only beef is that the GUI shutdown takes forever.
sudo shutdown -h now and Terminal solved that issue.

Offline clatterfordslim

  • Trusted User
  • Member
  • *****
  • Posts: 624
  • Karma: 149
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 10, Nine Respin 2
Re: Lenovo ThinkPad X140e ... only beef ... slow shutdown
« Reply #1 on: December 29, 2019, 01:08:48 am »
No issue with WIFI driver with Peppermint and everything works.
My only beef is that the GUI shutdown takes forever.
sudo shutdown -h now and Terminal solved that issue.

I have an idea and it is what I always setup on my installs of Peppermint.

In Terminal type or copy and paste
Code: [Select]
sudo xed /etc/default/grub
Pop your password in and this screen should pop up


Where it says
Code: [Select]
GRUB_TIMEOUT_STYLE=hiddenMake it look like this
Code: [Select]
#GRUB_TIMEOUT_STYLE=hidden
Scroll down a little till you get to the line that says
Code: [Select]
#GRUB_GFXMODE=640x480Pop your cursor to the right of the hash symbol and delete the hash.
So it looks like this
Code: [Select]
GRUB_GFXMODE=640x480The 640x480 is the size of the grub screen. I have mine set to.
Code: [Select]
GRUB_GFXMODE=1920x1080Just underneath this line add
Code: [Select]
GRUB_GFXPAYLOAD_LINUX=keepThis tells grub to keep the resolution. Save the file but do not close your Terminal.
We need to rebuild grub with a image so we need to type or copy and paste
Code: [Select]
sudo update-initramfs -uThen finally we need to put all this together by updating grub
Code: [Select]
sudo update-grub2You don't have to have 2 on the end of grub but I always do out of habit.
When you reboot you will have a list that pops up push enter and it'll boot in no time, also shutting down is quicker too.
I hope this helps?  ;D Your Grub file should look like this
                                     
                                     
« Last Edit: December 29, 2019, 01:15:36 am by clatterfordslim »
Not only is Peppermint an addictive OS to use.
But so is this Forum :)

Offline Minux1

  • Jr. Member
  • **
  • Posts: 35
  • Karma: 5
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Lenovo ThinkPad X140e ... only beef ... slow shutdown
« Reply #2 on: December 30, 2019, 04:15:56 pm »
The shut down latency with my ThinkPad X140e solved itself.
Now it shuts down normally from the GUI.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Lenovo ThinkPad X140e ... only beef ... slow shutdown
« Reply #3 on: December 30, 2019, 04:49:15 pm »
Ya gotta love self healing issues :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Minux1

  • Jr. Member
  • **
  • Posts: 35
  • Karma: 5
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Lenovo ThinkPad X140e ... only beef ... slow shutdown
« Reply #4 on: December 30, 2019, 05:25:01 pm »
I find it interesting that Peppermint 10 would supply a wifi driver for the ThinkPad X140e and Linux Mint v 19.3 wouldn’t.
I determined that the wifi driver supplied by Peppermint was a kernel driver rather than a proprietary driver as I first suspected.
“lspci -nnk | grep -iA3 net”
I thought these distros were based on the same generic Linux kernels?
Go figure ...

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Lenovo ThinkPad X140e ... only beef ... slow shutdown
« Reply #5 on: December 31, 2019, 02:19:43 am »
Yeah I'm a bit surprised by that too :-\

What exactly was the output from
Code: [Select]
lspci -nnk | grep -iA3 net?

Anyway, when shutting down (at the "shutting down" screen), if you hit the Esc key, are there any messages onscreen that might give us a clue what's hanging ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Minux1

  • Jr. Member
  • **
  • Posts: 35
  • Karma: 5
  • New Forum User
    • View Profile
  • Peppermint version(s): 10
Re: Lenovo ThinkPad X140e ... only beef ... slow shutdown
« Reply #6 on: December 31, 2019, 01:45:31 pm »
We can techno-geek ourselves until the cows come home but at the end of the day it boils down to it either works or it doesn't.
I overwrote Linux Mint v19.3 XFCE with Peppermint 10 and everything is working fine and as they say "the rest is history".
The initial shutdown latency in Peppermint apparently resolved itself and I won't look that gift horse in the mouth.
Linux Mint and Peppermint are both very fine distros.
« Last Edit: December 31, 2019, 01:49:04 pm by Minux1 »