Choose style:

Author Topic: SOLVED: How to set desktop color if Nemo autostart is disabled  (Read 501 times)

0 Members and 1 Guest are viewing this topic.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26454
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: SOLVED: How to set desktop color if Nemo autostart is disabled
« Reply #15 on: December 31, 2019, 10:23:28 am »
I should add at this point that although nemo-desktop doesn't appear to 'leak' memory (at least in my tests), it also doesn't appear great at releasing memory back to the system when the added icons are deleted (garbage collection).

But ..

a) I wouldn't see this as a big deal, I mean how many desktop icons is anyone likely to create / delete / and recreate in a single session ?

and

b) I have no idea what the garbage collection routines triggers are .. it still may clean up after itself at some point in time, or upon a certain trigger.



At some stage I'll run a kinda 'stress' test that automates the creation and deletion of files on the desktop, and keep an eye on nemo-desktop's memory usage and garbage collection .. but obviously this isn't something likely to arise in the real world.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26454
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: SOLVED: How to set desktop color if Nemo autostart is disabled
« Reply #16 on: December 31, 2019, 10:32:35 am »
The point is maybe drawing the icons on top of each other at the bottom right is what triggers the leak if there are enough icons, or there is a calculation overflow as often happens in extreme cases. Another thing in my setup is that an NTFS drive is mounted at the Desktop directory at boot time. Shouldn't matter but it had to be mentioned. Next time I see it happen, what info should I print-screen?

Next time it happens it might be handy just to get a ~/Desktop directory listing
Code: [Select]
ls -al ~/Desktop
just to see if it's down to file TYPE maybe .. or maybe it's down to thumbnail generation.

Is this 32bit or 64bit Peppermint ? .. and which version ?
(the reason I ask is IIRC there was a problem with thumbnails for images in the 32bit version .. just wondering if it might be related)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ulysses_

  • Jr. Member
  • **
  • Posts: 53
  • Karma: 1
  • New Forum User
    • View Profile
Re: SOLVED: How to set desktop color if Nemo autostart is disabled
« Reply #17 on: December 31, 2019, 11:20:53 am »
64-bit. Don't remember what version it started as, don't the upgrades with synaptic make it the same as the current one?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26454
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: SOLVED: How to set desktop color if Nemo autostart is disabled
« Reply #18 on: December 31, 2019, 11:27:24 am »
what's the output from:
Code: [Select]
cat /etc/lsb-release
and
Code: [Select]
uname -a
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ulysses_

  • Jr. Member
  • **
  • Posts: 53
  • Karma: 1
  • New Forum User
    • View Profile
Re: SOLVED: How to set desktop color if Nemo autostart is disabled
« Reply #19 on: December 31, 2019, 11:51:17 am »
Code: [Select]
DISTRIB_ID=Peppermint
DISTRIB_RELEASE=9
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Peppermint 9 Nine"

Code: [Select]
Linux peppermint 4.15.0-72-generic #81-Ubuntu SMP Tue Nov 26 12:20:02 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
« Last Edit: January 10, 2020, 12:35:16 am by AndyInMokum, Reason: Encapsulating with [code]. »